Preguntas frecuentes sobre Scan-IT to Office
Cómo enviar datos de formulario a distintas hojas
Cómo enviar datos de formulario a distintas hojas
A veces puede que desee crear varios formularios y enviar cada formulario a su propia hoja en la hoja de cálculo.
Esto se puede resolver con una macro en Excel o con Google Apps Script en Google Sheets.
Añadiendo un campo de texto estático con un identificador de categoría a sus formularios, la macro/script puede identificar la categoría de los datos capturados y moverlos automáticamente a la hoja deseada.
App Scan-IT to Office:
- Añada dos formularios nuevos o edite sus formularios existentes y añada un campo "Static Text" a cada formulario.
- Configure los valores de los campos "Static Text" con los nombres de categoría deseados
(en este ejemplo usamos "Cat1" y "Cat2"). - Asegúrese de que el campo "Static Text" sea el primer campo en sus formularios.
- También puede querer ocultar los campos "Static Text".

Microsoft Excel:
- Descargue la hoja de cálculo de ejemplo y ábrala en Excel.
- Inserte el complemento Scan-IT to Office.
- Seleccione "Insert after last non-empty row" en las opciones del complemento y asegúrese de que "ScanData" esté seleccionado.
- Abra la hoja "Categories" y cambie los valores en "Category" para que coincidan con los valores de los campos "Static Text".
- Si desea cambiar el nombre de sus hojas, también debe cambiar los valores en "Sheet" en consecuencia.
- Nota: no cambie el nombre de las hojas "ScanData" y "Categories" o la macro dejará de funcionar.

Google Sheets:
- Abra nuestra hoja de cálculo de ejemplo.
- Elija Archivo -> Hacer una copia para crear una copia editable del ejemplo.
- Abra el editor de scripts seleccionando Herramientas -> Editor de secuencias de comandos.
- En el editor de scripts, añada un nuevo activador a la hoja
Editar -> Activadores del proyecto actual -> + Añadir activador
Cambie "Seleccionar el tipo de evento" a "Al editar" y guarde los cambios. - Inserte el complemento Scan-IT to Office en la hoja de cálculo o conéctelo a la hoja "ScanData" mediante la conexión de Google Sheets (Drive).
- Si usa el complemento, seleccione "Insert after last non-empty row" en las opciones del complemento y asegúrese de que "ScanData" esté seleccionado.
- Abra la hoja "Categories" y cambie los valores en "Category" para que coincidan con los valores de los campos "Static Text".
- Si desea cambiar el nombre de sus hojas, también debe cambiar los valores en "Sheet" en consecuencia.
- Nota: no cambie el nombre de las hojas "ScanData" y "Categories" o el script de Google dejará de funcionar.