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2 Disclaimer 

The actual version of this product (document) is available as is. TEC-IT declines all warranties 
which go beyond applicable rights. The licensee (or reader) bears all risks that might take place 
during the use of the system (the documentation). TEC-IT and its contractual partners cannot be 
penalized for direct and indirect damages or losses (this includes non-restrictive, damages through 
loss of revenues, constriction in the exercise of business, loss of business information or any kind of 
commercial loss), which is caused by use or inability to use the product (documentation), although 
the possibility of such damage was pointed out by TEC-IT.  

 

 
We reserve all rights to this document and the information contained therein. Reproduction, 
use or disclosure to third parties without express authority is strictly forbidden. 
 

 
Für dieses Dokument und den darin dargestellten Gegenstand behalten wir uns alle Rechte 
vor. Vervielfältigung, Bekanntgabe an Dritte oder Verwendung außerhalb des vereinbarten 
Zweckes sind nicht gestattet. 
 

© 1998-2008  
TEC-IT Datenverarbeitung GmbH  
Wagnerstr. 6 

A-4400 Austria  
t.: +43 (0)7252 72720  
f.: +43 (0)7252 72720 77  
http://www.tec-it.com 
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3 Introduction 

Many thanks for your interest in TFORMer Designer! 

This document provides a quick introduction of TFORMer Designer. It concentrates on the 

following topics: 

 Printing ready-to-use industry templates 
Chapter 4 demonstrates how to print a VDA-4902 industry label. 

 Generating serial letters 
Chapter 5 provides a quick introduction for creating letter-style documents. 

 Tool for simple and fast printing 
Chapter 6 describes how to use TFORMer QuickPrint – a tool for printing layouts instantly. 

 Printing bar code labels 
Chapter 7 is a step-by-step guide for creating bar code labels. 

 

► For a detailed description of the possibilities offered by TFORMer please refer to the addi-

tional documentation. 
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4 Print Ready-to-Use Industry Templates 

TFORMer is shipped with a large number of predefined industry compliant document templates. 
This chapter demonstrates how to print VDA-4902 industry forms (VDA is an abbreviation for 
„Vereinigung Deutscher Automobilzulieferer“ and is a common standard in the Automotive Industry).  

4.1 Start TFORMer  

Start TFORMer Designer using the start-menu of Microsoft
®
 Windows

®
: Start ► All Programs ► 

TEC-IT TFORMer 5.1 ► TFORMer Designer 5.1. 

 
Figure 1: File – New Form... 

4.2 Choose a Form Template 

In order to create a new form press Ctrl+N or use the menu: File ► New Form…. (). 

In the upcoming dialog you can choose between creating a new report, a new label or using one of 
the ready-to-use layouts. 


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Figure 2: Create New Form – Template Selection 

Select the ready-to-use template VDA_4902_EN () in group Automotive/VDA and click Finish (). 

 
Figure 3: Design View 



 


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TFORMer Designer now displays the layout of the VDA-4902 form in design view: 

If required adapt the form to your requirements. Variable fields in the layout (e.g. the customer 
specific part number) are provided via data-fields (e.g. PartNumberCustomer). 

► Data-fields are place-holders for dynamic data. 

► Dynamic data is usually provided by external applications, data-sources or by the user. 

► Do not edit data-fields directly in the layout. The content of data-fields can be changed as 
described below.  

 

4.3 Edit Data 

Open the dialog Edit Data (Press Ctrl+D or use the menu: File ► Edit Data...).  

4.3.1 Select the Data-Source 

 
Figure 4: Edit Data and Select Data-Source 

TFORMer Designer offers multiple ways to provide the dynamic data used in the form layout:  

► Dynamic data used for data-fields may be generated automatically (for test purposes) or it 
may be imported from external data-sources. Besides this the user can enter the input data 
manually. 

In this example we assume that data should be entered manually (). Just click Next (). 



 


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4.3.2 Edit Data Manually 

   
Figure 5: Edit Data Manually  

In  a so-called “record“ is displayed. Per record one VDA-4902 form is printed. The dynamic data 
used in the form layout is contained in this record.  

► TFORMer generates one VDA-4902 form per record. Or more exactly: For each record all 

detail bands of the form layout are printed. 

Open the record by clicking the  symbol ().  



 
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4.3.3 Enter Data-Field Values 

  
Figure 6: Enter or Change Data-Field Values  

Once the record was opened you have the possibility to enter values for data-fields in the right 
column . 

If you need to enter data for another label, just click New Record () and complete the values for 
the data-fields. The printing order of the labels is determined by the order of records. If required 
change this order with the buttons Move Record Up or Move Record Down (). 

Click Finish () after all data-fields show the correct entries. 

4.4 Preview or Print the Form 

► TFORMer uses the term „Printing“ when generating output of any kind.  

► In addition to direct printing to printers TFORMer is also able to generate HTML, Images, 
PostScript

®
, ZPL-II code (for ZEBRA

®
 printers) and even PDF output – without the need for 

additional software like a PDF-printer. 

Open the dialog Form Print (Press Ctrl+P or use the menu: File ► Print...).  



 



 



 


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Figure 7: Print Form  

Select the required output format in  (e.g. Printer). In  choose the appropriate output device (e.g. 
an available printer on your system). 

When clicking OK () printing is started with the data as entered above. If multiple identical copies 
are required adjust the value of Copies in . 

 





 


 


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5 Print Serial Letters 

This chapter demonstrates how to use TFORMer for creating and printing a serial letter.  

5.1 Your Requirements 

Let us assume that this serial letter announces a new store of your company and will be sent to 
existing customers. Customer specific data (like customer number, name, and address) is stored in 
a Microsoft Excel table.  

5.1.1 Serial Letter Layout 

 
Figure 8: Sample of a Serial Letter 

The serial letter is divided into three logical areas. These areas are marked with red frames in the 
figure above: 

 Page Header 
The page header in this example contains only static data and is identical for all letters. 

 Detail Band 
The detail band is used for the body of the letter. It contains some customer specific fields 
like the salutation or the address of the customer (). In addition the current date will be 
printed automatically (). 

 Page Footer 
Beside static data like the greeting formula, an image for the signature and a bar code with 
the encoded customer number () is shown.  

 

Page Header 
 

Detail Area 
 

Page Footer 
 



 


 


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This conceptual partitioning of the letter is not a must – there are also other possible solutions: You 
might as well use one detail band which contains all the required elements. In such a case no page 
header and no page footer are required. 

► TFORMer supports different types of printing areas: also called bands. Bands divide a form 
layout into logical areas. Depending on the type of the band TFORMer maintains its 
occurrence and position in the output automatically. E.g.: page footers are always printed at 
the bottom of a page.  

► Beside detail bands, which are usually used to print the body of the document, TFORMer 
supports report headers and report footers, page headers and page footers, group headers 
and group footers. 

5.1.2 Data to be used in the Serial Letter 

Besides manual data input, TFORMer is able to import CSV files (comma separated values). In this 

example we assume that a work-sheet with customer specific data is maintained with Microsoft 

Excel. Microsoft Excel is able to export data as CSV files.  

The following data-fields are available in the CSV file: 

Column Name in the CSV file Description 

Address Street/Number 

City City 

CustNr Customer Number 

DateValid Valid until date 

Name First and last name of the customer 

Salutation Salutation (Mr., Mrs., ...) 

Zip ZIP-Code 

Table 1: Column Names in the CSV File 

Example of the CSV file used:  

"Address","Salutation","City","CustNr","DateValid","Name","Zip" 

"Main Street 6","Mr.","Nowhere","HS12346","12/31/2006","Jephen Stobs","12334" 

"Side Street 7","Mrs.","Nowhere","HS654321","12/31/2006","Tus Nelda","12334" 

"Some Street 5","Mr.","Nowhere","SO33423","12/31/2006","Silent Bob","12334" 

"Down Street 1","Mr.","Nowhere","JM1234","12/31/2006","Je Me Hendrix","12334" 

"Left Street 1","Mr.","Somewhere","GB1234","12/31/2006","Gill Bates","12334" 

"Straight Street 1","Mr.","Elsewhere","LT4321","12/31/2006","Tinus Lor-Valds","12335" 

► It is important that the first line of the CSV-file contains the column-names. These names are 
used by TFORMer to assign the values to the corresponding data-fields.  

5.2 Create the Serial Letter 

5.2.1 Start TFORMer  

See 4.1 – Start TFORMer. 

5.2.2 Create the Basic Layout 

Create a new form. Therefore press Ctrl+N or use the menu: File ►New Form… 

In the upcoming dialog you can choose between creating a new report, a new label or using one of 
the pre-designed layouts. 
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Figure 9: Create a New Report  

The serial letter as outlined above is a report-style output, therefore choose Custom Report () and 
click Next (). 

 
Figure 10: Adjust the Margins of the Report 

Adjust the page margins as shown below and click Finish. 

TFORMer Designer opens a standard report. 



 


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Figure 11: Standard Report 

This report contains more printing areas (bands) than required. According to 5.1.1 we only need a 
Page Header, a Detail Band and a Page Footer. 

Remove all unnecessary bands (report header and report footer) from this standard report. To do 
this right-click on the headline of the band () and choose Delete () in the pop-up menu. 

Now delete all unwanted printing elements from the remaining bands by selecting them with the 
mouse and pressing the Del key.  

After performing these steps TFORMer Designer displays the following layout: 



 


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Figure 12: Empty Report for the Serial Letter 

5.2.3 Define Data-Fields (Placeholders for Dynamic Data) 

Before you continue with the design work, it is recommended to define all placeholders for dynamic 
data (like the name of the customer or the customer number) which are required in the serial letter. 
Such placeholders are named data-fields. 

► A data-field is a placeholder for dynamic data. When printing a form layout TFORMer up-
dates the values of data-fields with the values provided by a data-source or by the user. 

► A data-source is an external source for data-fields. In this example the data-source will be 
the CSV file mentioned in 5.1.2.  

► A data-field may be used in form layouts in different ways: its content can be printed as text 
as bar code, as picture (filename for dynamic logos) and it can be used for computations 
and for controlling the output behavior. 

► Data-fields must be defined before they can be used in a layout. 

Data-field definitions may be created manually or automatically based on an existing data-source. In 
this example we assume the CSV file serving as data-source already exists. So automatic data-field 
definition is the recommended way: Open the Edit Data dialog by pressing Ctrl+D or use the menu 
File ►Edit Data… Then choose Import data from and select the CSV file containing the customer 
data () and click Next ().  
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Figure 13: Data-Field Import from CSV File 

The CSV-file used in this example is installed by the setup application under this location: 

Windows Vista: 

C:\ProgramData\TEC-IT\TFORMer\5.1\Examples\Command 

Line\SerialLetterPDF\SerialLetterData.csv 

Other Windows versions:  

C:\Documents and Settings\All Users\Application Data\TEC-IT\TFORMer\5.1\Examples\Command 

Line\SerialLetterPDF\SerialLetterData.csv 

TFORMer Designer now analyzes the specified data-source and shows a preview. Adjust the 
separator character for columns (in this example the comma ) and the text qualifier character (“ – 

) to match your input file: 



 


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Figure 14: Data-Field Import – Preview 

When clicking Next TFORMer Designer checks the input file for new data-fields: 

 
Figure 15: Data-Field Import – New Data-Fields 

Clicking Finish imports all of the selected data-fields. 

After importing, these data-fields may be used in the form layout. TFORMer Designer displays all 
data-field definitions in the design tree under the node Data-Fields (). 



 

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Figure 16: Data-Field Import – Imported Data-Fields  

5.2.3.1 Note for defining data-fields manually 

Right-click the node Data-Fields () or an existing data-field in the design tree. Select New Data-
Field () in the pop-up menu. The New Data-Field dialog appears. In this dialog enter the name of 
the data-field () and confirm with OK (). 

► Take care to name the data-fields identical to the column names used in the data-source. 
Only when using identical names TFORMer Designer is able to assign the values of the 
data-fields correctly!  

► TFORMer is able to provide standard values for data-fields. Such default values are espe-
cially useful for the layout development purposes. The default values used for generation of 
test-data can be defined in the New Data-Field dialog or in the property window (). 

 



 



 



 



 



 



 
 

Page 20 of 38 

TFORMer Designer  Tutorial -  F irst  Steps  

5.2.4  Finish the Layout 

For inserting the required elements into the layout select the element type in the toolbar () and 
then click into the suitable area of the layout (). To change the properties of an element (e.g. 
color, font, bar code, ...) select it with the mouse and then use the property window (). 

5.2.4.1 Insert Text Elements 

For text elements TFORMer Designer opens a dialog which allows you to enter the content of the 
element (). You may mix static text with data-fields (like Dear [Salutation] [Name],). Data-fields are 
enclosed in square brackets [].  

 

 
Figure 17: Serial Letter Design 

Click on the button  () to embed a data-field or an expression into your text. When 
inserting an expression the Expression-Builder appears: 



 


 



 



 

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Figure 18: Expression-Builder 

In  select the data-field to be embedded in the text. Insert it into the expression () by clicking . 
Confirm the dialog with OK (). 



 



 



 


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5.2.4.2 Insert the Bar Code 

To insert a bar code into your layout select the bar code tool () and then click into the suitable 
area of the layout (). Because a bar code usually contains no static text, TFORMer will open the 
Expression-Builder () directly. The properties of the bar code element (like the bar code type to be 

used or the rotation) can be changed in the property window (). 

 

 
Figure 19: Insert a Bar Code 



 



 



 


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5.2.5 The Finished Serial Letter 

 
Figure 20: Finished Serial Letter 
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5.3 Preview or Print the Serial Letter 

For printing the serial letter you need to provide data for the data-fields. In this example we use the 
above mentioned CSV file. 

Open the dialog Form Print: Press Ctrl+P or use the menu File ►Print...  

  
Figure 21: Print Form 

In  choose the required output format (e.g. Printer). In  select a suitable output device or output 

file. 

To select the CSV file containing the data-field values, click Edit Data …. (). Select Import Data 
from and locate the CSV file. The steps for importing data are identical to the steps for importing the 
data-field definitions (see section 5.2.3). Close the wizard with Finish. 

Now click OK () in the Form Print dialog and start the output: 





 


 


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Figure 22: Serial Letter – PDF Output 

5.4 Ready-To-Use Example 

The finished example can be opened with the following steps: Start ► All Programs ► TEC-IT 
TFORMer 5.1 ► Examples ► Demo Repository 

  
Figure 23: Open the Serial Letter  

In the tree view open the form MailingFlowerPower located in Projects ► TFORMer_Runtime_Ex-
amples by expanding the tree and by double-clicking item . 


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6 Quick-Print Existing Layouts 

TFORMer comes with a tool which is named TFORMer QuickPrint. This tool allows you to select a 
form layout and to print it on any supported output device. Besides simple output functionality it also 
offers network-wide serial number support. Start TFORMer QuickPrint with: 

Start ► All Programs ► TEC-IT TFORMer 5.1 ► TFORMer QuickPrint 

► TFORMer QuickPrint requires .NET Runtime 2.0!  

The screen-shot below shows how to quick-print the serial letter designed in chapter 5. 

 
Figure 24: The TFORMer QuickPrint Tool 

The button Common… () is used to configure serial number printing. More details regarding this 
functionality are available in the TFORMer QuickPrint manual. 

The button Form… () is used to select the form layout to be printed. TFORMer offers two different 

possibilities for organizing form layouts: 

 Stand-alone form layouts: per default TFORMer Designer creates form layouts which may 
be used on its own. These form layouts are stored with the file extension *.tff. 

 Repository-based layouts: a repository is used for organizing multiple form layouts within a 
structured data-base. A repository is stored on the file system with the file extension *.tfr.  

When using a stand-alone form layout just select the appropriate filename in name in . For 
repository based layouts enter the filename of the repository, the project and the name of the layout. 

The button Output… () is used to select the required printer or output format. Table style () is 
used to switch between the default input dialog or a table-style input dialog. Enter data-values in the 
area  and start printing with Print (). 



 

 

 

 



 


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7 Print Bar Code Labels with Serial Numbers 

This chapter describes how to print bar code labels with serial numbers. 

In contrast to a report (see chapter 5) a label occurs usually multiple times on a page of the output. 
The basic layout of the label remains unchanged, only the dynamic data (in this example the serial 
number) changes from label to label. In order to compute a serial number a data-field must be 
created. A data-field is a placeholder for variable data. It may be used in computations. 

► TFORMer is able to perform computations within a layout. Such computations utilize data-
fields for storing intermediate results. For more information refer to the TFORMer Designer 

Manual 

7.1 Your Requirements 

7.1.1 Bar Code Label Layout 

The layout of the labels in this example is very simple. A serial number should be printed as bar 
code and as text. The bar code encodes the serial number with leading zeros.  

 
Figure 25: Labels with Serial Number  

7.1.2 Serial Numbers 

This example demonstrates how TFORMer can be used to automatically create serial numbers. 
The serial number is computed by TFORMer itself. No external programming is required. 
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7.2 Create the Bar Code Labels 

7.2.1 Start TFORMer  

See 4.1 – Start TFORMer. 

7.2.2 Create the Basic Layout 

► TFORMer unifies the generation of reports and labels. Only the parameters of the layout are 
used to differentiate between the two possible output styles. This very flexible printing 
concept allows the generation of simple labels as well as full-featured reports. For more 
information, please check out the TFORMer Designer user manual.  

Create a new form. Therefore press Ctrl+N or use the menu: File ►New Form… 

In the upcoming dialog you can choose between creating a new report, a new label or using one of 
the pre-designed layouts. 

 
Figure 26: Create a New Label 

The bar code labels as outlined above are a label-style output, therefore choose Custom Label () 
and click Next (). 



 


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Figure 27: Adjust the Margins of the Label 

Set all margins to the values specified above and click Next. 

 
Figure 28: Label-Specific Settings 

Adjust the required label settings. This example uses 3 columns of labels (each 50 mm width) and 5 
rows of labels per page. The horizontal and vertical distance between the single labels is set to 10 
respectively 5 millimeters. When clicking Finish TFORMer Designer opens a standard layout using 
the adjusted basic settings:  
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Figure 29: Standard Label 

The standard layout contains some graphical elements. Most likely they are not needed, so select 
them with the mouse () and press Del.  

Please note: The screenshot above uses a zoom-factor of 300%. You can change the viewing 
zoom factor for your designs in the menu View ►Zoom 


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7.2.3 Create a Data-Field to be used as a Serial Number 

As mentioned we need a data-field to hold the serial number. The name of this field should be 
SerialNumber. To simplify computation with this data-field the data-type will be adjusted as Long 

(an integer number). 

Right-click onto Data-Fields () in the design tree and select New Data-Field () in the upcoming 
pop-up menu. A dialog opens in which you can enter the name of the data-field (SerialNumber –  
) and select Long () as data type. Confirm with OK. 

 

 
Figure 30: Create the Data-Field SerialNumber  

► The type of a data-field can be adjusted: String is the recommended type. When using data-
fields of type string for computations you must convert them to numbers (e.g. with CLng or 
CDbl) 

7.2.3.1 Insert the Bar Code  

In the toolbar select the bar code symbol () and click onto the desired position on the detail band 
(). A bar code will be inserted and the Expression Builder for the bar code data is opened ().  

As bar code data the value of the data-field SerialNumber should be used. Therefore double-click 
the data-field SerialNumber (). It will be inserted automatically in the edit area . Then press OK 

().  



 



 



 
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Figure 31: Insert a Bar Code  

7.2.3.2 Insert the Text Element 

In the toolbar select the text symbol () and click on the desired position on the detail band (). A 
text element will be inserted and the Edit Text dialog is opened.  

The content of the text field is a combination of a fixed text and the actual value of the serial 

number. The fixed text ”Serial:” can be entered directly in .  

The data-field SerialNumber is inserted via the  menu of the dialog. After selecting the entry 

Data-Field  in this menu the Select Data-Field dialog () opens.  

Double-click the data-field SerialNumber () to insert it directly into the text. 

The resulting text is now Serial: [SerialNumber]. Close the Edit Text dialog with OK ().  

► TFORMer displays expressions (or single data-fields) which are embedded into text or bar 
code element with surrounding square brackets [] or angle brackets <>.  

► Angle brackets are used for interpreting the result of an expression as HTML. 

 



 


 


 



 



 


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Figure 32: Insert a static Text and a Data-Field  

7.2.3.3 Format the Text Element 

The newly inserted text element should be printed centered and word-wrap should be disabled. To 
do so select the text element and edit its properties in the property window. The alignment is 
adjusted in  word-wrap is disabled by selecting False in . 

 

Figure 33: Properties window of a text element 



 



 



 



 



 



 



 



 

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7.2.4 The resulting Layout 

 
Figure 34: The resulting Layout  

7.2.5 The Print Preview 

Now generate a print-preview by pressing Ctrl+Space or pressing the symbol  in the toolbar. 
After generating test data TFORMer Designer shows the following output. The bar-codes are 
marked with crosses indicating that no data was encoded. This is because the data-field 
SerialNumber was not provided with values. 

 
Figure 35: Print Preview with empty Data-Field  
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7.3 Printing Serial Numbers with TFORMer QuickPrint 

The simplest way to print serial numbers is to use TFORMer QuickPrint.  

TFORMer QuickPrint is able to maintain a pool of serial numbers. This even works if multiple users 
are printing the same layout and are therefore using the same serial numbers. TFORMer 
QuickPrint takes care that serial numbers are always unique. 

For this purpose a simple configuration file must be created. This configuration file holds the names 
of the data-fields which should be used as serial numbers.  

7.3.1 Create a Serial Number Configuration File 

The configuration file must be named QuickPrint.xml. It is structured as follows: 

<?xml version="1.0" standalone="yes"?> 

<root> 

  <SerialNumber current="1000" stepSize="1" /> 

</root> 

This file contains the name of the data-field SerialNumber along with its current value (1000). The 
value in stepSize is used for incrementing the value of SerialNumber for one print-out.  

Save this file in an arbitrary directory. 

7.3.2 Start TFORMer QuickPrint 

Start TFORMer QuickPrint using the start-menu of Microsoft
®
 Windows

®
: 

Start ► All Programs ► TEC-IT TFORMer 5.1 ► TFORMer QuickPrint 
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7.3.3 Set up TFORMer QuickPrint 

Click on the Common… button and enter the directory containing the QuickPrint.xml file as the 
serial directory () in the following dialog. 

Enter a directory where you want to save the last printed data (by default your My Documents 
folder) in  

Choose an arbitrary username, enter it in  and close the dialog with OK.  

 

Figure 36: QuickPrint – Common Settings 

Next click on the Form… button and enter the directory where you saved your form layout in the 

Repository field. 

Choose the output format (and the filename if you are exporting to a file) in the dialog accessible via 
the button Output... 

You can save this configuration if you want to use it later with File ► Save As… 



 
 

 
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7.3.4 Enter the printing data 

Enter the printing data for your label in the input area. In this case, the label contains only the serial 
number field which cannot be changed (recognizable on the gray-shading). Therefore just set the 
number of instances you want your label to be printed (). 

 

Figure 37: QuickPrint – Printing data 

7.3.5 Print the label 

To start printing simply click the Print button. If you are exporting to a file, TFORMer QuickPrint 
opens the file with the linked Windows

® 
application (e.g. PDF with Acrobat Reader). 

7.3.6 Ready-To-Use Example 

The finished example can be opened after the installation of TFORMer Designer with the following 
steps: Start ► All Programs ► TEC-IT TFORMer 5.1 ► Examples ► QuickPrint – Serial Numbers 

 
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8 Contact and Support Information 

8.1 Free Support 

If you have questions, need help or simply want to tell us about your application, contact: 

Email: support@tec-it.com  

Web: http://www.tec-it.com/support/ 

Don’t hesitate to contact us - let us hear your feedback! If the product does not fulfill your 
requirements, please tell us why. We are highly interested in meeting the requirements of our 
customers. 

8.2 How to unlock the Demo Version 

You can unlock the demo version with a license key. License keys can be obtained from TEC-IT by 
Email, online order form or FAX. 

Email: sales@tec-it.com 

Online: http://www.tec-it.com/order/ 

Fax: +43 / (0)7252 / 72 72 0 – 77 

8.3 Company Contact Information 

TEC-IT Datenverarbeitung GmbH 

Address: Wagnerstr. 6  

AT-4400 Steyr  

Austria/Europe 

Phone: +43 / (0)7252 / 72 72 0 

Fax: +43 / (0)7252 / 72 72 0 – 77 

Email: support@tec-it.com 

Web: http://www.tec-it.com 

 

AIX is a registered trademark of IBM Corporation.  
HTML, DHTML, XML, XHTML are trademarks or registered trademarks of W3C, World Wide Web Consortium, Laboratory for Computer 
Science NE43-358, Massachusetts Institute of Technology, 545 Technology Square, Cambridge, MA 02139.  
JAVA® is a registered trademark of Sun Microsystems, Inc., 901 San Antonio Road, Palo Alto, CA 94303 USA.  
JAVASCRIPT® is a registered trademark of Sun Microsystems, Inc., used under license for technology invented and implemented by 
Netscape.  

Microsoft®, Windows®, Microsoft Word®, Microsoft Excel® are registered trademarks of Microsoft Corporation.  
Navision is a registered trademark of Microsoft Business Solutions ApS in the United States and/or other countries. 
Oracle® is a registered trademark of Oracle Corporation. 
PCL® is a registered trademark of the Hewlett-Packard Company. 
PostScript is a registered trademark of Adobe Systems Inc. 
SAP, SAP Logo, R/2, R/3, ABAP, SAPscript are trademarks or registered trademarks of SAP AG in Germany (and in several other countries).  
 
All other products mentioned are trademarks or registered trademarks of their respective companies. If any trademark on our web site or in this 
document is not marked as trademark (or registered trademark), we ask you to send us a short message (mailto:office@tec-it.com) 
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