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2 Disclaimer

The actual version of this product (document) is available as is. TEC-IT declines all warranties that
go beyond applicable rights. The licensee (or reader) bears all risks that might take place during the
use of the system (the documentation). TEC-IT and its contractual partner cannot be penalized for
direct and indirect damages or losses (this includes non-restrictive, damages through loss of
revenues, constriction in the exercise of business, loss of business information or any kind of
commercial loss), which is caused by use or inability to use the product (documentation), although
the possibility of such damage was pointed out by TEC-IT.

% We reserve all rights to this document and the information contained therein. Reproduction,
use or disclosure to third parties without express authority is strictly forbidden.

B Fuir dieses Dokument und den darin dargesteliten Gegenstand behalten wir uns alle Rechte
vor. Vervielfaltigung, Bekanntgabe an Dritte oder Verwendung auf3erhalb des vereinbarten
Zweckes sind nicht gestattet.

© 1998-2009
TEC-IT Datenverarbeitung GmbH
Wagnerstr. 6

A-4400 Austria

t.: +43 (0)7252 72720

f.. +43 (0)7252 72720 77
http://www.tec-it.com
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3 Introduction

3.1 Whatis TBarCode?

TBarCode is a set of professional tools for the generation of barcodes. More than 80 different sym-
bologies (linear barcodes, 2D barcodes and stacked barcode variants) can be printed or exported
as graphics files. All industry formats are supported. The barcodes can be generated in the highest
possible resolution and quality.

TBarCode is available in several versions for different operating systems, applications and
programming environments. The following versions are included in this setup:

TBarCode OCX A Microsoft® ActiveX® compliant barcode control. It can be used with
Microsoft® Office applications as well as by software developers.

TBarCode .NET A .NET barcode library for software developers. It includes barcode
controls for Windows Forms and ASP.NET 2.0.

TBarCode Library | A DLL for Windows platforms for software developers.

(A DLL for Windows CE/Windows Mobile is available on request. Please
contact us with your platform details.)

3.2 Important Security Notice

» The ActiveX control TBarCode OCX is now a site-locked ActiveX control. This security
enhancement was implemented in response to a reported possible security leak in conjunc-
tion with Internet Explorer and an installed TBarCode OCX. It is strongly recommended to
update all TBarCode installations as soon as possible.

As part of the fix the TBarCode OCX methods Savelmage() and SavelmageEx() now are
restricted to specific internet zones. This happens only if TBarCode OCX runs in Microsoft
Internet Explorer as part of a web-page. The allowed zones can be specified in the registry.
In addition these functions append the correct image filename extension if the file extension
specified by the user does not match the supported image formats.

Please refer to the TBarCode OCX Developer Reference for details.

3.3 Whatis TBarCode OCX?

TBarCode OCX is a Microsoft® ActiveX® compliant barcode control. Such an ActiveX control is
sometimes called OLE control or OCX control. In German it is named "Steuerelement”.

You can use TBarCode OCX in:

= Microsoft® Office: barcodes are embedded into documents, forms or databases easily.

= Development environments: integrate barcodes into your own application(s).

= Report-Generators and Reporting Engines: Enhance the output with barcode functionality.
=  Web Applications: Use barcode technique as part of browser-based applications.

= Most programming and script languages.

3.4 Scope of this Document

This document shows developers how to use TBarCode OCX with various IDEs (integrated
development environments) like Visual Studio.
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3.5 Restrictions of the Demo Version

In the demo version the barcodes will be drawn with a demo-hint. That means that the word “Demo”
or the phrase “www.tec-it.com” is drawn partially over the barcode. The demo-hint does not influ-
ence the readability of the barcode in a negative way.

» In special cases (e.g. very small or high-resolution barcodes) you may want to test the pro-
duct without restrictions. To obtain a temporary license key contact sales@tec-it.com.

» For enabling the full-featured version (without the demo hints) you can obtain a license key
from TEC-IT (http://www.tec-it.com/order/).
» For more information on licensing TBarCode, please refer to section A.2.
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4 |nstallation

4.1 Requirements

The following operating systems are supported:

=  Microsoft Windows 2000

=  Microsoft Windows XP

= Microsoft Windows Server 2003
= Microsoft Windows Vista

4.2 Download and Setup

Download TBarCode from http://www.tec-it.com/Download » TBarCode and execute the setup
application. Depending on your selection one or more of the following components are installed —
along with documentations and sample applications:

= TBarCode OCX
A barcode ActiveX control for Microsoft Office users and for software developers. User
manual and API reference are included in the setup.

= TBarCode Library
A DLL for software developers. Developer manual and API reference are included in the
setup.

= TBarCode .NET
For software developers. Developer manual and API reference are included in the setup.

» Administrative rights are required to install.

» TBarCode OCX is an ActiveX control. ActiveX controls must be registered within the
Microsoft Windows operating system before they can be used. This registration is executed
automatically by the setup application. On demand you can register the OCX file manually
with the command line tool “regsvr32.exe”.
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5 Microsoft Development Environments

5.1 Microsoft Visual Basic 6

In order to insert TBarCode OCX in Visual Basic 6, please execute the following steps:

Open or create your VB Project.

Right-click the Toolbox and select Components from the menu.

Select TBarCode OCX 9.0 Type Library from the list (Insertable Objects) and confirm with

OK.

Now you can use TBarCode as VB Control (it is shown in the Toolbox).
Set the characteristics of the barcode in the VB properties window (“Properties

TBarCode91").

In case you prefer the TBarCode "Property Pages” (instead of the VB properties window),

right-click the object and select Properties from the pop-up menu.

5.2 Microsoft Visual C++ 6.0

5.2.1

In order to use TBarCode OCX in MFC, please follow these steps:

MFC Applications

Open or create your MFC based application.

If you create a new project, make sure, that ActiveX Controls @ is checked (default) on page
3 of the “MFC AppWizard”.

MFEC AppWizard - Step 3 of 6

include?

" Container
" Mini-zerver

" Full-zerver

[~ Automation
v Achives Controls

‘what compound document support would you like to

" Both container and server

‘what ather support would you like ta include?

< Back | Hest > |

Eirish |

Cancel |

Figure 1: Use TBarCode in MSVC++ 6.0 (MFC Application) (1)
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Select Project » Add to Project » Components and Controls... from the menu.
Change to the folder Registered ActiveX Controls.

Select TBarCode from the list and click Insert.
A wrapper class for TBarCode OCX is generated automatically (®). Click OK to confirm.
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Confirm Classes

The checked class(es] will be generated from
the &ctivex Control. Click on a class name to

Choose & component ta insert browsze or edit its attributes.

Cancel

I T Conneckor2 (2)

I TeeChartSvBCH, TeeChart
Teechart ChartEditorPane
g TeeChart ChartGrid w5

ﬁTeeChart ChartiaridMavios

¢ Class name: Baze class
— |C_ITBaCods Cwind
File name: TBarCodebrl o der fie:

TBaiCodeh |_ITBarCade.h

Implementation file:

|_ITBalE0de.cpp

Path to contral:
|C:YProjecthGlobal_wIN3ZADLLATE arCodef. ocx

Figure 2: Use TBarCode in MSVC++ 6.0 (MFC Application) (2)

= The control is thereafter selectable in the control toolbox in the dialog editor (©).

= Work with the assistance of the Class Wizard if necessary.

i [:,mw__g] )
H N E
b 3 =
- d Adjust Properties | <
: B

—: ’Tl Cancel |

MmEECE? o8
HiHEsFid i emfeQ

-=
==
b —

Figure 3: Using TBarCode in MSVC++ 6.0 (MFC Application) (3)

5.2.2 Non MFC Application

For non MFC applications we recommend to use TBarCode DLL.
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5.3 Microsoft Visual Studio .NET 2003

» TBarCode OCX can be used in .NET applications. However, we recommend to use
TBarCode .NET instead. TBarCode .NET includes a .NET barcode class and .NET controls

for Windows Forms and ASP.NET 2.0 applications.

531

Use TBarCode OCX as Control

In order to use TBarCode OCX as a control and to embed it in a form in Visual Studio .NET (e.g. in
a “Windows Application” or in an “ASP.NET Web Application”), please follow these steps:

Open or create a project.
In the Toolbox switch to Components (@).
Right-click inside the Toolbox and select Add/Remove ltems.... A dialog appears.
In the dialog switch to the COM Components tab @.
Select TBarCode9 © (check the checkbox).

Confirm with OK (@).
Now TBarCode OCX is added to the Toolbox (8).
To use the control just drag it from the Toolbox (®) to your form (®).

[+

L [o]x)

File  Edit Wiew

Toolbox
Data
Components

k- Pointer

@L FileSystemiatcher
EventLog
DireckoryEntry
@ DireckorySearcher
fl MessageQueue
PerformanceCounter
Process

B ServiceContraler
Timer

i ReportDocument

I{'H'éarCodas

Windows Farms
Clipboard Ring
General

Cukpuk

Project

n

o

Build Debug Data Tools  wWindow
& Bn @
x Skart Page  Forml.cs [Design]™® |

Help
» Debug

a2

Adiust i
(]

Customize Toolbox

ust Properties
a

6]

\MET Framework Components  COM Components D

v 4 TECBarCode.h

- BE =R,

Mame

| path

| Library

TaskSymbol Class

TEarCodes
) TEarCoded

TConneckar?

TeeChart ChartEditorPanel v5

TeeChart ChartGrid v5

TeeChart ChartGridMavigatar v5

TeeChart ChartPageMavigator v5

TeeChart Commander w5

TeeChart Editor v5
A -

Ready

TBarCodes
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“ersion: 1.0

CHWINDOWSY System 32 mmendmgr ., dil

C:\Prograrn Files\ TEC-IT| TBarCade4. ..

CHiProjectiGloball_WIN3Z\DLL\ TEar ...
C:\Prograrn Files\ TEC-IT| TWwedge\T...

Ci\Program Files! TeeChart Pro w5 Ac...
CH\Program Files| TeeChart Pro »5S Ac...
C:\Prograrn Files\ TeeChart Pro 5 Ac...
Ci\Prograrn Files\ TeeChart Pro 5 Ac...
C:\Prograrn Files| TeeChart Pro 5 Ac...
Ci\Program Files!\ TeeChart Pro w5 Ac...

Language Meutral

ModeMgr 1.0 Ty...
TBarCode 4.0 T..,
TBarCode 6,0 T..,
TConneckar 2.0...
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TeeChart Prao &,
TeeChart Pro &,
TeeChart Pro A,
TeeChart Pro A...
TeeChartPraf...

S

Browse, ..

9 bk x

-

o = |

Cancel |

Resel | Help

Task List Bl Output @ Search Results For Feature dependency

Solution Explorer - Windowsap... & X

2E E &
Q Solution "Windowsapplication2' (1 pro
= E‘H WindowsApplication?
-l =4 References
+3 AxTBARCODEGLD
+3 shdole
<2 System
2 System.Data
=2 System,Drawing
+Z System, Windows Farms
0 System, XML
+3 TBARCODEELD

App.ico

@ AssemblyInfo,cs

Forml.cs
< *
B Solution Explorer 3 Class Yiew
Properties I X

| anTBarCodes1 AxTEARCODEGLL. ~ |

HEEIR] =

Texk Adjust Prope | ~
Textalignment  Default

TextColor Il Black
TextDistance -1 —
TrimSpaces Default {(None} j

Activer -Properties. .., Activey -
License. .., Ackivex - About...

Text
The text contained in the contral,

Propertiss o Dynarmic Help

Figure 4: Using TBarCode in Visual Studio .Net 2003 (as Control)

Microsoft Visual Studio .NET automatically generates a wrapper class for an existing ActiveX
control. You can use it like any other control in .NET.
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5.3.2 Use TBarCode OCX as Library

In order to use TBarCode per code only (without embedding it as ActiveX control in a form), please
follow these steps:

= Open or create a project.

= From the menu select Project » Add Reference...

= In the upcoming dialog switch to the COM tab @.

= Select TBarCode from the list and click Select @®.

= Confirm with OK (®).

= Now TBarCode9Lib is added to the References of your Project (and can be found in the
“Solution Explorer” Window ©).

= The TBarCode class can now be used in your code.

File Edit Wiew Project Build Debug Tools ‘Window Help

5t 2 & ) Detug + | [# TECEarCode.h - B EXIE e R
Tl b 7 x Start Page  Classl.cs EINES M Solution Explorer - Consoledppl.,. B X
Clipboard Ring ‘gg j |§. ﬂ EI =
General woing Sysoem: — | [gA Solution ‘ConsoleApplication 1 (1 proje
k Painter =l (M E‘ﬂtunsulenpplicatiunl
[F namespace Consolelpplicationl = =l References
¢ + stdale
0 System

= J4F <swmmar v
/47 Bummary description for Classl.

+ System,Data
+{ Systemn, XML

Add Reference ( -0 Tearcocestn @)
1 App.ico
JMET  COM ] Projects ] @ AszemblyInfo.cs

Browse... @ Classl.cs

Component Name ‘ Typelib Ver... | Path | »

System_wWindows_Forms 2.0 CAWINDOWSIMicrosoft, MET. .. Select

Tabular Data Contral 1.1 Typ... 1.1 CAWINDOWS System32\kde.. ..

Tahoe Forms Type Library 1.0 Ci\Program Files\Common Fil... F3 | *
TAPI3 Terminal Manager 1.0 ... 1.0 CAOWINDOWS) System3z2\ker .., == —
TBarCode 4.0 Type Library 1.0 C:\Program Files\TEC-IT|TEa. ., &4 Solution Explorer 3 Class Viev

= 65,0 Type Library .0 g

TConneckar 2,0 Type library 1.1 CiiProgram Files\ TEC-ITITW... = Propetties ax
TeeChark Pro Activex Control v5 1,0 C\Program Files\ TeeChart Pr... .

Int .TBARCODEGLIb  Ref
TeeChartSvECH 3.0 CH\Program Files\TeeChart Pr... -~ | " ero.p ! e erenﬂ
TEnum Type Library 10.0 C:\Program Files\Sybase\Sha. .. EE
Liffile 1.0 Type Library 1.0 C:\Program FilesyComman Fil... —
TIMF 1.0 CAWINDOMWS Suatam 3P dati. .. =

Copy Local True

Selected Components:

Component Marne Type | SOUrCE | Remove

Oukput TBarCode 6.0 Type Library oM C:{Project}Globali_WINIZIDLLY... a

wfl

K

J

=

9 (a4 | Cancel Help | {Name)

Display name of the reference.

TaskList B output @ Search Results for Feature dependency [ Properties | @ Dynamic Help

Ready

Figure 5: Using TBarCode in Visual Studio .Net 2003 (as Library)

Sample usage of the TBarCode class in C#:

TBarCode9Lib.TBarCode9Class obj = new TBarCode9Lib.TBarCode9Class () ;
obj.BarCode = TBarCode9Lib.e BarCType.eBC 20F5IL;
obj.Text = "12345";
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5.4 Microsoft Visual Studio .NET 2005/2008

5.4.1 Use TBarCode OCX as Control

In order to use TBarCode OCX in Visual Studio .NET (e.g. in a “Windows Application” or in an
“ASP .NET Web Application”), please follow these steps:

= Open or create a project.

= Right-click inside the Toolbox @ and select Choose ltems.... A dialog appears.
= In the dialog switch to the COM Components tab @®.

= Select TBarCode ® (check the checkbox).

= Confirm with OK (@).

= Now TBarCode OCX is added to the Toolbox (©).

= Drag the control from the Toolbox (©) to your form (G).

[ - windowsApplication? - Microsoft VisualStdio ‘]

File Edit Wiew Project Buld Debug Data Tools Test  Window  Community Help

A-E-E a3 S - = b Debug * by CPU - | @ v | R sk B s
g = +
L |z & S| [T e ik | g 4 A= AR
x— Toolbox - = X | ~ % | Solution Explorer - WindowsApplicationl ~ 1 X
g‘ AII Windows Fnrrlns | =S FEE &
é" ED'T'mDn Controls J Salution "Windowsapplication1' {1 project)
K Painter = [ windowsApplication1
Button o [=d| Propetties

= |_¥ References
<3 AxTEARCODEELD
<3 stdole
«I2 System

CheckBox
87 CheckedListBox

ComboBox

T DateTimePicker 3 System.Data
A Label =~ Syskem, Deployment
~‘_\ LinkLabel Sstam‘Dr.awmg
;. Choose Toolbox ltems N em. windows. Forms
ListBox e
Listhiew JNET Framewark Components | COM Components Lg RCODESLD
[ MaskedTextBox B s
‘.E.:l MonthCalendar Mame Path Library ) 1.Designer.cs
== NotFyicon [ sysColarCirl class CHWINDOWS System32|cic.dl tic 1.0 Type Lib, . Liresx
= ) [ System Information CAWINDOWSPCHealth\HelpChriBin...  msinfo32 1.0 Ty... -Cs
(el MumericLipbown 1 | | O Svstem Mariter Cantrol CAWINDOWS\System32lsysmon.ocx  System Monitor ...
1] Picturegiox [] Tabular Data Contral CHWINDOWS ) System3zttde. ook
@) ProgressBar [ Tasksymbol Class CAWINDOWS System3Zimmendmgr.dl NodeMgr 1,0 Ty,
(&) RadioButton [ TBarCode:
A= TBarCoden (= Global} \DLLYTBar ...
3 RichTextBox L
bl Tethos [] TConnectorz CiiProgram Files\ TEC-IT\Twedge1\T...
i [] Teechart ChartEditorPanel v5 C:\Program Files\TeeChart Pro vS Ac... TeeChartPro ...
‘%_‘—_" ToolTip [ TeecChart Chartarid w5 CiiProgram FilesiTesChart Pro wS Ac...  TeeChartPro A
87 TreeView é_‘ : > - 1 3 —

ﬂ WebBrowser

TEarCodet
T 5)

Language:  Language Meutral
=/ Containers e

R Pointer

&= FlowlayoutPanel
_"_"_; GroupBox o [ Ok 1 [ Cancel ] [ Reset ]

{71 Panel
[ splitcentainer
= TahConkeal b

Ready

Figure 6: Using TBarCode in Visual Studio .Net 2005 (as Control)

Wersion: 1.0

Microsoft Visual Studio .NET automatically generates a wrapper class for an existing ActiveX
control. You can use it like any other control in .NET.

5.4.2 Use TBarCode as Library

Use the same steps as described in 5.3.2.
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5.5 Microsoft Visual FoxPro

5.5.1 Inserting TBarCode into a FoxPro-Project
In order to insert TBarCode in Visual FoxPro, please execute the following steps:

= Open or create a FoxPro Project.
= Open or create a Form.
= Select OLE Container from the Standard Toolbox.

= After drawing the outlet of the OLE container, an "Insert object" dialog is opened. Select
TBarCode (Insert Control) and confirm with OK.

= The characteristics can be modified in the properties window.

= |If you prefer the TBarCode OCX property pages, right-click the control and choose
Properties from the pop-up menu.

=  Within the Project Manager you can add the newly created form to the project.

5.5.2 Reports & Labels

If you want to print barcodes in reports or labels, you need a table with a specific column, in which
TBarCode must be stored as OLE Control (data type “general”). This data field must be initialized
with the data structure of a barcode object before use. For this purpose you need an instance of a
TBarCode object as template (e.g. on a form, it may be invisible).

Example code for the initialization of the data fields of a barcode object:

FOR n = 1 TO 10
INSERT INTO Tablel FROM MEMVAR
APPEND GENERAL Tablel.BC CLASS TBarCode9.TBarCode9
WITH THISFORM. [Name of the TBarCode object instance]
.CONTROLSOURCE = "Tablel.BC"
.REFRESH
.barcode = 20 && Barcode-Type = Codel28
.TEXT = "000070000041"
.printdatatext = .T.
.BACKCOLOR = 16777215
.FORECOLOR = 0 && 16711680 -> (blue)
.REFRESH
ENDWITH

NEXT

After this code has been executed, an OLE Picture/ActiveX Bound Control can be inserted into a
Report or Label Form. In this sample, you have to specify "Tablel.BC" as data source (field).
Please take a look at our FoxPro-Sample, which can be downloaded from http://www.tec-
it.com/Download » TBarCode.
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6 Microsoft ERP Systems

6.1 Microsoft Navision®/ Dynamics® NAV

Under Navision TBarCode OCX cannot be inserted into a report directly. So you have to use the
following workaround:

= Create or open a report and insert a Picture Box.
= Create a barcode image (per code) using the TBarCode OCX Control.
= Load the image to the Picture Box.

Sample code for creating a barcode image:

COM objBC; // this is com object instantiation
objBC = new COM("TBarCode9.TBarCode9.1"); // create class TBarCode9

OobjBC.Text = "121212" // set barcode data
objBC.Barcode = 20; // 20 ... use Code-128

objBC.Savelmage (DateiNameBmp, 4, pxWidth, pxHeight, nXRes, nYRes); // 4 = eIMBmp (Bitmap)

For more detailed information, please take a look at our Navision Tutorial, which can be down-
loaded under http://www.tec-it.com/Download » TBarCode or contact our technical support.
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7 Borland Delphi / Borland C++ Builder

7.1 Using TBarCode OCX in Borland Delphi 6/7

To insert TBarCode OCX in Delphi or Borland C++ Builder, please follow the steps described

below:

= Select Components » Import ActiveX Control from the menu.
= Select TBarCode OCX Type Library from the list.

=  Click the Install button and confirm the following pop-up windows with OK. The TBarCode
control can now be used like a standard component (Toolbar ActiveX).

7.2 Using TBarCode OCX in Borland Delphi 2005 (Delphi for Win32)

To insert TBarCode OCX in Delphi 2005, please follow these steps:

Create Package:

Choose File » New » Package — Delphi for
Win32 from the menu.

Save Package:

Choose File » Save All from the menu.

The Save Package As dialog will open.
Choose the directory for saving the package.
Hint: It is recommended to create a separate
directory for the package.

Then assign a name to package-project (e.g.
TBarCode9).

Confirm with OK.

7.2.1 Create and Save a Package for TBarCode OCX
El Edit Search View Refector Project Run Component Tools StarTeam &
I Mew » I % ASP.NET Web épplication - C#Builder
3 Open... E windows Forms Application - C#Builder
(= Open Project... Ctrl+F11 ) Control Library - C#Builder
Reopen » | %5 windows Form - C#Builder
¥ «* ASP.NET Web dpplication - Delphi for .NET E
H Saveds.. E YCL Forms Application - Delphi for JNET
4 5 J@ ‘windows Forms Application - Delphi for NET I
3 A 3 VCLForms Application - Delphi for Win32
Bl Cose @ackﬂge - Delpi for WinBD |
E‘—‘ Close All [] Form - Delphi fee Win32
{8 Unit - Delphi for win32
‘S Other...
 Exit Customize. ..
7.2.2 Set the Project Options

OLtput diectery: [y Documents|Borland Studic Projects|TBarCodes. v ] -

Uit cutput diectory: | JEa |

Search path: | =l J

Debug source path: | | J

Envirorment Block DCP output dirsctory: | B2
Condtional defines: | =] J

Unit disses: [WinTypes=windons;WinProcs=WindowsiDbiType v ...|

Hamespace prefices: = -

Default Namespace: | |

I~ Default

=3 Cancel Help

WWW.TEC-IT.COM
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Choose Project » Options... from the menu.
The Project Options Dialog will open.

Description:

Select Description in the tree on the left. The
description text can be edited on the right.

Output Directory:

Select Directories/Conditionals in the tree on
the left.

Under Output directory, choose the directory
where you have saved your project.

Confirm with OK.
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7.2.3 Import TBarCode Component

A Import Component @

Type of Component
Select the type of component to import.

" Import a Type Litrary

I Next >> | [ Cancel | Help |

& Import Component El

Registered ActiveX Controls
Select an ActiveX Control that is registered on your system to import.

Descriptian | wersian | Filename [~
RemoveCtrl 1.0T.., Yersion 1.0 CWINDOWSID ..
Setup 1.0 TypeLi.., Wersion 1.0 CAMINDOWSAD, ..
Shockwave Flash  Wersion 1.0 CAWINDOMWSHs, .
System Moritor C... Wersion 3.6 :
Tabular Data Con... ¥ersion 1.1
TCorneckor 2,0 T.., Yersian 1.1
TFormer 4.1 Type... Wersion 1.0 C:\Pragram Fie:
trialoc 1.0 Type Li... Wersion 1.0 Ci\Pragram Fikes...
TSHOGT 3.1 Type... ¥ersion 1.0 CwINDOWSHf...
¥B 6 Application .. Yersion 1.1 CiiProgram Fies...
¥B 6 Data Form W... Yersion 1.0 CiiProgram Fies... =
W8 & MSChart Wiz... Wersion 1.0 C:\Pragram Fikes...
WCI First Impressi.., Wersion 1.0 CAWINDOMWShs, . 3
Add
<< Back ‘ Mext = ‘ | Cancel | Help |

: for the component and the directory for the generated impart: file.

Class Mame(s): |

[~

Unit dir Mame: |c:'l,program filesiborlandbdsh 3. 00 Imports) J

Palette Page:

Search path: |$(BDS)'|,Iib;C:'|,F‘rogram Files\Borland\BDS43 . 00 Imp

& Import Component

Install
Chocse to create a unit or add to the existing package.

|
(¢ Create Unit

/7 ¢ Add unit to TBarCodeS.bdsproj project
&)
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Choose Component » Import Component...
from menu.

The Import Component wizard will open.
In the Wizard, choose Import ActiveX Control.
Then click Next.

Choose TBarCode OCX from the list.
Click Next.

On this page leave all default values.
Click Next.

This is the last page of the wizard.
Choose Create Unit.
Then click Finish.

You will find TBARCODESLIib_TLB in the main
window of Delphi.

Save this Unit in the same directory where the
package-project is located.
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7.2.4 Add Components to the Package

Add Unit ]quuires ]

Search path: |$(ED5)\I\h;C:\Pngram Files\Borland|B0SY3. 0 Imparts el

Help

Unit File name Browse...

7.2.5 Create and Install Package

& Project Options for TBarCodes. bpl 3]

Design packages

| Delphi 1.0 Compatibiity Components ~
! Indy 10 Core Design Time

I Indy 10 Protacels Design Time

| Inkernet Explorer Componerts

W Intraweb 7.2 Design Packags For Delphi Win32

! Microsoft Office kP Sample Automation Server Wrapper Components
I Shell Control Fraperty and Component Editors

v & E
V! TeeChart Components A

C:|Documents and Settings'dothesap|fy DocLments\Borland Studio Projects| TBarCodes| TBarCades. bpl

add... Remove Edit ‘ Components |

Runtime packages

-

[
=1

I~ Default

el | wee |

7.2.6

k¥

+ Standard 48
+ Additional

+ Win32

+ System

+ Win 3.1

+ Dialogs

+ Data Access

+ Data Controls

+ dbExpress

+ DataSnap

+ BD
= ActiveX
TTBarCodes

TPPGGeneral

TPPGAdvanced

TPPGPdf417

TPPGMaxi

TPPGDataMatrix

TPPGQRCode

TPPGCodaBlockF v

& & ESEES
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= Choose Project »Add to Project... from the

menu.
= The Add dialog will open.
= Select the “Add Unit” tab.

=  Click Browse to look for
TBARCODES9Lib_TLB.PAS.

= Click OK to add TBarCode.

Create the package:

= Select Project » Build <ProjectName> from

the menu.

Install the created Package:

= Select Component » Install Packages from

the menu.
= Click Add.

= Choose the created package (here
TBarCode6.BPL) and click Open.

= The package (TBarCode9 OCX) is now listed

in Design Packages.
= Click OK to finish the installation.

Create a new VCL Forms Application

=  Choose File » New » VCL Forms

Application... from the menu.

= |nthe Tool Palette you can find the new

category ActiveX.

= TBarCode OCX was added in this category

and is now ready to use.
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8 Sybase PowerBuilder

8.1 TBarCode OCX in PowerBuilder DatawWindow

In PowerBuilder® the use of ActiveX controls (like TBarCode OCX) is not possible within so-called
DataWindows if the control is bound to the band layer. This limitation is not caused by TBarCode
OCX.

To get dynamic “data driven” barcodes you have to use the following workaround.

Instead of placing the TBarCode OCX control inside the DataWindow, you have to insert it into
the dialog Window. Thus it can be programmed for our workaround as follows.

By using this control you can create a bitmap file for each barcode, save it to disk and load it to a
picture data field in the DataWindow. That has to be done for each data row/record set.

This workaround is described in detail in the following sections.

8.2 Insert TBarCode OCX

To insert TBarCode OCX into a PowerBuilder dialog window, please execute the following steps:

= Select Controls » OLE from the menu.

= Select the page Insert Control from the tab (PowerBuilder 10).

= Select TBarCode from the list.

= If desired, change the properties in the context menu (OCX Properties).

» In PowerBuilder Version 7, 8, 9 and 10 always insert TBarCode with Insert Control because
Create New does not work with scripting.

Insert Object 3]

Create Mew || Create From File | Inserk Control |

Control Type:

W TBarCods+ ~

Register Mew, .,
Y Tewcaces

Erowse, .,

Result

Inserts a new TBarCodes OLE custom control into

wour docurment.,

Ok l l Cancel ] [ Help

Figure 7: Inserting TBarCode in PowerBuilder

* powerBuilder version 7-10
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8.3 Script the Control within PowerBuilder 10

In order to access the properties and methods of the ActiveX control you have to use the following
syntax:

| ControlName.Object.Property

Example:
ole l.object.text = "hello"
ole l.object.barcode = 20 ' 20 = Code 128

» The barcode type (the symbology) is set by assigning a number to the barcode property.
Please refer to the "Barcode Reference" (http://www.tec-it.com » Support » Knowledge
Base) to learn more.

8.4 Generate Barcode Images for the DataWindow

8.4.1 Generate the Barcode Images (from the Dialog Window)

You need a TBarCode OCX object in your dialog window which can be programmed. In our sample
it is called “w_barcode_printing”.

Open your source code. In the section where you prepare the data for the output you have to do
something like the following to save the barcode images:

//Image path and filename
1s image = "C:\ APPS\FeeSystem\bcl.jpg"

//Saves the barcode as a JPEG
w_barcode printing.ole barcode.SaveImageEx (0, ls image, 4, 100, 300, 80, 127, 127)

» Currently PowerBuilder only supports BMP, JPEG, and GIF. You cannot use the EMF file
type.

With the Setltem() function you can finally assign the name of the generated barcode bitmap file to
the column used in the DataWindow (bc_pic).

Using this approach will allow you to simulate the data binding inside the DataWindows.

8.4.2 Insert the Barcodes into your DatawWindow

Inside your DataWindow you have to create a column with a STRING data type. Here we use the
name bc_pic. This column will contain the path and the name for each barcode bitmap file for each
record. Then insert a column control for the created data field.

In the “General” properties of the column control check the DISPLAY AS PICTURE box as shown
below. This will make the control show the picture and not the filename inside the control frame.

For example: If the column contains the value “c:\picture.jpg”, the control will display the picture
and not the text “c:\picture.jpg”.
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be_pic

brtext

SeQ_num

acct_desc

badge_num
"Account # + string( acct_num )

vehicle_iacct_nul

- —

General |P0inter HTML || Position

Mame

| b _pic

Tag

[(Hidesnaked
Alignment

| £ Left ()

Border

MoBarder {0}

%]
™

[V Display As Pickure
L_Protect

I

[ evverride Edic
[CIEquality Required

Figure 8: PowerBuilder DataWindow “Display As Picture”

[CIRightToleft

Instead of using a column control you may also insert a computed field control and use the

BITMAP() function:

Modify Expression

X

Expression:
bitmap {pich

Functions: Columns:

b betext
E] :cgg(xx)) E b;d?;xe_num

asci s wehicle_id
aschl s ) acck_nurn

asing s ) acck_desc

kan( s bc_pi

:\EE ;:x far all ) c;m):Zte_l
bitrnao (5 b

Figure 9: PowerBuilder DataWindow Bitmap function
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9

Oracle Forms / Oracle Reports

9.1 Barcodesin Forms

In order to use TBarCode OCX in an Oracle Form please execute the following steps:

Create a new form.

In the layout editor:

a) Draw an ActiveX control.

b) Right-click with the mouse and select Insert Object.

c) Select TBarCode.

Select Menu » Program OLE Importer from the menu and import the control.

Optional:

Create a button and add a when-button-pressed trigger on the canvas (where you can call
the ActiveX control).

Close the layout editor (This step is VERY IMPORTANT!).

Run the form.

Press the button to run the ActiveX control.

9.2 Barcodes in Reports

» Oracle Reports do not support ActiveX controls.

Workaround: The user can call an executable from within a report. For instance you can generate
barcode bitmaps with the TEC-IT product Barcode Studio which can be executed in command line
mode (without a visible window). Barcode Studio creates and saves a bitmap whenever it is called.
Afterwards the generated bitmap can be loaded into an image inside the report.

Another possibility is to use the TFORMer product family (advanced label and form reporting tool).

Use TFORMer Designer to design your barcode label or report. Thereafter use TFORMer Runtime
(or the command line tool TFPrint.exe) to generate and print the complete report. TFORMer
supports direct printer output, PostScript, PDF and HTML output directly (without any additional
software).
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10 Redistributing TBarCode OCX

This chapter explains what is important when redistributing a custom application that uses the
TBarCode OCX control.

> Please note that in most cases you need a developer license for re-distribution of TBarCode
OCX (except for in-house applications which are bound to one or more sites).

10.1 Dependencies

An application that uses TBarCode OCX requires the following files:

= TBarCode9.ocx
This is the ActiveX component. This file is mandatory.
= TBarCode9.dll
This is a native Win32 library that performs barcode generation. This file is mandatory.
= zlib1.dll
Thisis a 3rd-party library that performs data compression. This file is optional. It is only
required, when data compression in barcodes is enabled.

These files are located in the folder C:\Program Files\TEC-IT\TBarCode9\Bin (or in the folder you
have chosen during setup).

TBarCode OCX requires also the Microsoft VC90 CRT and ATL DLLs. See next section how to
distribute them with your application.

10.2 Redistribution

When redistributing a custom application the files described above need to be redistributed together
with the application. The DLLs should be located in the same folder as the executable.

Other files than those listed above must not be redistributed.

You may have to redistribute the Visual C++ 2008 SP1 runtime components (MS CRT 9.0 and
ATL 9.0 DLLs) with your application and ensure they are installed on the target computer.

There are two options to install them:

= You can install these components with the Microsoft Visual C++ 2008 SP1 Redistributable
Package (x86) available at
http://www.microsoft.com/downloads/details.aspx?familyid=A5C84275-3B97-4AB7-A40D-
3802B2AF5FC2&displaylang=en.
The package installs all required runtime DLLSs.

= |f you use a setup tool and your installer supports merge modules (*.msm files) you can add
the required msm packages to your setup:
- Microsoft VC90_CRT_x86.msm
- policy_9 0 Microsoft VC90_ CRT_x86.msm
- Microsoft VC90_ATL_x86.msm
- policy_9 0 Microsoft VC90_ATL_x86.msm

Please contact TEC-IT Support if you need help.
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11 Contact and Support Information

TEC-IT Datenverarbeitung GmbH

Address:  Wagnerstr. 6
AT-4400 Steyr
Austria/Europe

Phone: +43/(0)7252/72720
Fax: +43/(0)7252/72720-77
Email:  mailto:support@tec-it.com

Web: http://www.tec-it.com

AlX is a registered trademark of IBM Corporation.

HTML, DHTML, XML, XHTML are trademarks or registered trademarks of W3C, World Wide Web Consortium, Laboratory for Computer
Science NE43-358, Massachusetts Institute of Technology, 545 Technology Square, Cambridge, MA 02139.

JAVAR® is a registered trademark of Sun Microsystems, Inc., 901 San Antonio Road, Palo Alto, CA 94303 USA.

JAVASCRIPT® is a registered trademark of Sun Microsystems, Inc., used under license for technology invented and implemented by
Netscape.

Microsoft®, Windows®, Microsoft Word®, Microsoft Excel® are registered trademarks of Microsoft Corporation.

Navision is a registered trademark of Microsoft Business Solutions ApS in the United States and/or other countries.

Oracle® is a registered trademark of Oracle Corporation.

PCL® is a registered trademark of the Hewlett-Packard Company.

PostScript is a registered trademark of Adobe Systems Inc.

SAP, SAP Logo, R/2, R/3, ABAP, and SAPscript are trademarks or registered trademarks of SAP AG in Germany (and in several other
countries).

All other products mentioned are trademarks or registered trademarks of their respective companies. If any trademark on our web site or in this
document is not marked as trademark (or registered trademark), we ask you to send us a short message (mailto:office @tec-it.com).
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Appendix A: FAQ

If you have questions not covered in these FAQ, you can also check our website http://www.tec-
it.com/FAQ or contact our support team: mailto:barcode@tec-it.com.

A.1 How to set a specific Module Width (15 mils) in Web Applications?

Please refer to the "Barcode Reference" (http://www.tec-it.com » Support » Knowledge Base) for
more information.

A.2 License TBarCode in my Application

Assume you got the following license key:

Product ID: 32 (1D Barcodes in V9)
Licensee: Barcode Inc.

License Kind: 2 (Site)

Licenses: 1

License-Key: 12A3B5C6

Now implement a call to the method LicenseMe before you draw a barcode (we suggest at startup
of your application).

Example in Visual Basic (enumerators are used):

| TBarCode91.LicenseMe "Barcode Inc.", eLicKindSite, 1, "12A3B5C6", eLicProdlD

The Product ID depends on the version of TBarCode (see your license data).

A.3 Clipped Barcode Image (Savelmage)

If the ModuleWidth property is set to a specific value the barcode may be clipped because it does
not fit into the image dimensions specified in Savelmage.

A.3.1 Solution
If you need a specific module width for your application (e.g. 3 pixels), use the number of barcode
modules (CountModules property) and multiply this value with 3 (to get 1 module = 3 Pixels wide).

Use this value as horizontal size of the image in Savelmage. Using this method, the image size will
adapt automatically depending on number of horizontal barcode modules.

For 2D symbologies use Get2DXCols and Get2DXRows for finding the best horizontal and vertical
size values.

A.4 Unreadable Barcodes with PrintForm (VB)

In Visual Basic the form objects (like TBarCode) are rendered with (low) screen resolution and not
with the (usually high) printer resolution. Therefore the printed barcode may become unreadable.

To work around this problem adjust the module width of the barcode to the resolution of the screen:

» This can be achieved by using the CountModules property.
> Or use the TBarCode property OptResolution = true
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For details please see our Visual Basic Sample Code, which is installed together with the product
setup. The samples contain also the PrintForm workaround to get a readable barcode.

A.5 Save MaxiCode with a higher Resolution

You have to set the ModuleWidth property to a higher value (as it is by default) — and increase the
values for XSize / YSize when saving the barcode.

Example:
FlName = "Maxicode.bmp"
TBarCode91.Text = "BarCodeText"

TBarCode91.BarCode = eBC_MAXICODE
'Use nRatio to enlarge or reduce image size

nRatio = 2

TBarCode91.ModuleWidth = 1500 * nRatio
DoEvents

YSize 208 * nRatio

XSize = 215 * nRatio

TBarCode9l.SaveImage "C:\Users\User\Documents\" & FlName, TBarCode9Lib.eIMBmp, XSize,
YSize, 72, 72

'Hint : When printing we recommend using the standardized size of MaxiCode
'Height: ~24.4 mms;
'Width : ~25,2 mms

A.6 Savelmage does not work

Please check if you have write permissions to the directory you want to write to (e.g. important in
web applications).

Please check if the internet zone was unlocked when using TBarCode OCX as part of a web page.
See the TBarCode OCX Developer Reference for details.

A.7 Barcodes created with Savelmage are unreadable

Please refer to the "Barcode Reference" (http://www.tec-it.com » Support » Knowledge Base) for
more information.
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