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2 Disclaimer 

The actual version of this product (document) is available as is. TEC-IT declines all warranties 
which go beyond applicable rights. The licensee (or reader) bears all risks that might take place 
during the use of the system (the documentation). TEC-IT and its contractual partners cannot be 
penalized for direct and indirect damages or losses (this includes non-restrictive, damages through 
loss of revenues, constriction in the exercise of business, loss of business information or any kind of 
commercial loss), which is caused by use or inability to use the product (documentation), although 
the possibility of such damage was pointed out by TEC-IT. 

 

 
We reserve all rights to this document and the information contained therein. Reproduction, 
use or disclosure to third parties without express authority is strictly forbidden. 
 

 
Für dieses Dokument und den darin dargestellten Gegenstand behalten wir uns alle Rechte 
vor. Vervielfältigung, Bekanntgabe an Dritte oder Verwendung außerhalb des vereinbarten 
Zweckes sind nicht gestattet. 
 

© 1998-2010  
TEC-IT Datenverarbeitung GmbH  
Wagnerstr. 6 

A-4400 Austria  
t.: +43 (0)7252 72720  
f.: +43 (0)7252 72720 77  
http://www.tec-it.com 
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3 Introduction 

Many thanks for your interest in TFORMer Designer! 

This document provides a quick introduction to TFORMer Designer. It focuses on the following 

topics: 

 Printing ready-to-use industry templates 
Chapter 4 demonstrates how to print a VDA-4902 industry label. 

 Generating serial letters 
Chapter 5 provides a quick introduction for creating letter-style documents. 

 Tool for simple and fast printing 
Chapter 6 describes how to use TFORMer QuickPrint – a tool for printing layouts instantly. 

 Printing bar code labels 
Chapter 7 is a step-by-step guide for creating bar code labels. 

 

► For a detailed description of the user interface, the range of functions and all possible adjust-
ments offered by TFORMer please refer to the additional user manual. 
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4 Print Ready-to-Use Industry Templates 

TFORMer Designer is shipped with a large number of predefined industry compliant document 
templates. This chapter demonstrates how to print VDA-4902 industry forms. (VDA is an 
abbreviation for “Vereinigung Deutscher Automobilzulieferer” and is a common standard in the 
automotive industry.) 

4.1 Start TFORMer Designer 

Start TFORMer Designer using the start menu of Microsoft
®
 Windows

®
: Start ► All Programs ► 

TEC-IT TFORMer 6.0 ► TFORMer Designer 6.0. 

 
Figure 1: File – New Form... 

4.2 Choose a Layout Template 

In order to create a new layout press Ctrl+N or use the menu: File ► New Form... (). 

In the appearing dialog you can choose between creating a new report, a new label or using one of 
the ready-to-use layouts. 
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Figure 2: Create New Form – Template Selection 

Select the template VDA_4902_EN () in group Automotive/VDA and click Finish (). 

 
Figure 3: Layout View 

The VDA-4902 form is now displayed in the layout view. 

You can adapt the layout to your requirements. Variable fields in the layout (e.g. the customer spe-
cific part number) are provided via datafields (e.g. PartNumberCustomer). 
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► Datafields are place-holders for dynamic data. 

► Dynamic data is usually provided by external applications, by external datasources or by the 
user. 

► The content of datafields is provided as described below. 

4.3 Provide Data 

Dynamic data is used as content for datafields. TFORMer Designer offers multiple ways to provide 
the dynamic data used in the layout. It may be entered manually by the user (for test purposes) or it 
may be imported from external datasources (ODBC, CSV, XML, …). 

To edit the data click on the Data tab at the bottom of the window or use the menu Data ►Data 
View. In this example we assume that the data should be entered manually. Therefore the Manual 
Datasource is used. 

4.3.1 Select the Manual Datasource 

For editing the data manually, in  the entry “Edit manually (default)” must be selected (see Figure 
4 below). 

4.3.2 Enter Datafield Values 

This template already contains one record with test data (see line ). One record provides the 
dynamic data which is used for printing one VDA-4902 label. 

 
Figure 4: Edit Data Manually 

For the manual datasource, each record can be edited directly. To assign a new value to a data-
field, first mark the cell with the mouse (see ). Then type in the required value. If you want to 
change an existing value, double-click on the cell or press the F2 key. The cursor can now be 
positioned inside the cell. To confirm your input press the Enter key. Alternatively you can also 
confirm with Tab and therewith jump to the next cell. 

If you want to enter data for another label, insert a new record in the grid. Therefore place the 
mouse in any cell within the last row  (which is marked with a „*‟) and enter the required data. 

If all datafields contain the required values you can continue with printing. 

4.4 Preview or Print the Form 

► TFORMer uses the term ”Printing“ when generating output of any kind. 

► In addition to direct printing (on a physical printer) TFORMer also support the generation of 
HTML, Images, PostScript

®
, ZPL-II code (for ZEBRA

®
 printers) and even PDF output without 

the need for any additional software like a PDF-printer. 

Open the dialog Form Print (Press Ctrl+P or use the menu File ► Print...). 
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Figure 5: Print Form  

Select the required output format in  (e.g. Printer). In  choose the appropriate output device (e.g. 
an available printer on your system). 

By clicking OK () the print job is started. If multiple identical copies are required adjust the value of 
Copies in . 
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5 Print Serial Letters 

This chapter demonstrates how to use TFORMer for creating and printing a serial letter. 

5.1 Your Requirements 

Let us assume that this serial letter announces a new store of your company and will be sent to 
existing customers. All customer data (like customer number, name, and address) is stored in a 
Microsoft Excel table. 

5.1.1 Serial Letter Layout 

 
Figure 6: Sample of a Serial Letter 

The serial letter is divided into three logical areas. These areas are marked with red frames in the 
figure above: 

 Page Header 
The page header in this example contains only static data and is identical for all letters. 

 Detail Band 
The detail band is used for the body of the letter. It contains some customer specific fields 
like the salutation or the address of the customer (). In addition the current date will be 
printed automatically (). 

 Page Footer 
Besides the static data like the greeting formula and the image for the signature the page 
footer also contains a bar code which encodes the customer number (). 

 

Page Header 
 

Detail Area 
 

Page Footer 
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This conceptual partitioning of the letter is not a must – there are also other possible solutions: You 
might as well use one detail band which contains all the required elements. In such a case no page 
header and no page footer are required. 

► TFORMer supports different types of printing areas called bands. Bands divide a layout into 
logical areas. Depending on the type of a band, TFORMer maintains its occurrence and 
position in the output automatically. E.g.: Page footers are always printed at the bottom of a 
page. 

► Beside detail bands, which are usually used to print the body of the document, TFORMer 
supports report headers and report footers, page headers and page footers, group headers 
and group footers. 

The layout which is used in this tutorial is the MailingFlowerPower example, which can be found in 
our demo repository. For details on how to open this example see section 5.4. 

5.1.2 Data to be used in the Serial Letter 

In this example we assume that a worksheet with customer specific data is maintained in Microsoft 

Excel. In order to use this data in TFORMer the excel spreadsheet is saved as CSV file (file with 
comma separated values). This file format can be exported in Microsoft Excel and it can be 
imported in TFORMer. 

In this example we use the file “SerialLetterData.csv” as included in TFORMer (see also section 

5.2.4.1). The following datafields are available in the CSV file: 

Column Name Description 

Address Street/Number 

City City 

CustNr Customer Number 

DateValid Valid until date 

Name First and last name of the customer 

Salutation Salutation (Mr., Mrs., ...) 

Zip ZIP Code 

Table 1: Column Names in the CSV File 

Content of the CSV file:  

"Address","Salutation","City","CustNr","DateValid","Name","Zip" 

"Main Street 6","Mr.","Nowhere","HS12346","12/31/2006","Jephen Stobs","12334" 

"Side Street 7","Mrs.","Nowhere","HS654321","12/31/2006","Tus Nelda","12334" 

"Some Street 5","Mr.","Nowhere","SO33423","12/31/2006","Silent Bob","12334" 

"Down Street 1","Mr.","Nowhere","JM1234","12/31/2006","Je Me Hendrix","12334" 

"Left Street 1","Mr.","Somewhere","GB1234","12/31/2006","Gill Bates","12334" 

"Straight Street 1","Mr.","Elsewhere","LT4321","12/31/2006","Tinus Lor-Valds","12335" 

► If the first line of the CSV file contains the column names, TFORMer can create the corres-

ponding datafields automatically using the auto import feature (see section 5.2.4.2). 

5.2 Create the Serial Letter 

5.2.1 Start TFORMer Designer 

See section 4.1. 

5.2.2 Create the Basic Layout 

Create a new layout. Therefore press Ctrl+N or use the menu File ►New Form…. 
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In the appearing dialog you can choose between creating a new report, a new label or using one of 
the pre-designed layouts. 

 
Figure 7: Create a New Report  

The serial letter as outlined above is a report style output, therefore choose Custom Report () and 
click Next (). 

 
Figure 8: Adjust the Margins of the Report 

Adjust the page margins as shown below and click Finish. 

TFORMer Designer opens a standard report. 
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Figure 9: Standard Report 

This report contains more printing areas (bands) than required for our example. According to 
section 5.1.1 we only need a page header, a detail band and a page footer. 

Remove all unnecessary bands (report header and report footer) from this standard report. To do 
this right-click on the headline of the band ()and choose Delete () in the pop-up menu. 

Now delete all unwanted printing elements from the remaining bands by selecting them with the 
mouse and pressing the Del key. 

After performing these steps TFORMer Designer displays the following layout: 
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Figure 10: Empty Report for the Serial Letter 

5.2.3 Define Datafields (Placeholders for Dynamic Data) 

Before we can continue with the design work, we must define datafields for the serial letter (e.g. the 
name of the customer or the customer number). 

Datafield definitions may be created automatically or they may be created manually. 

Here we will use the automatic generation of datafields. This method uses the columns names 
contained in the CSV file and creates equally named datafields. Therefore we first have to specify 
the datasource. So TFORMer can read all column names of this datasource and create datafields 

for each of the columns automatically. For detailed information see sections 5.2.4 and 5.2.4.2. 

Information on how to create datafields manually, please refer to section 5.2.5, if required. 

Please note: 

► A datafield is a placeholder for dynamic data. When printing a layout TFORMer updates the 
values of datafields with the values provided by a datasource or by the user. 

► A datafield may be used in layouts in different ways: Its content can be printed as text as bar 
code, as picture (filename for dynamic logos) and it can be used for computations and for 
controlling the output behavior. 

► Datafields must be defined before they can be used in a layout. 

5.2.4 Create New Datasource 

To create a new datasource switch to the Data tab and select <Create New Datasource…> from the 
drop down menu (see  in Figure 11 unterhalb). Alternatively you can right-click on the 
“Datasources“ entry in the design tree and select New Datasource… from the pop-up menu or click 

on the “New Datasource” icon  in the data toolbar. The New Datasource dialog will appear: 
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Figure 11: Create a new Datasource 

In our example we want to use the CSV file “SerialLetterData.csv” as datasource. Therefore select 
“Flat Text File (CSV, TSV, …)” as datasource type in . In  enter an appropriate name for the 
datasource (e.g. “SerialLetter_CSV”). Then confirm with OK. 

The Edit Datasource dialog will appear. 

5.2.4.1 Specify CSV File 

In the File tab you have to specify the name and the location of the CSV file: 

 
Figure 12: Datafield Import from CSV File 
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In  specify the CSV file that want to use. Press the  button to select the required file from your 
file system. Depending on your operating system you will find the example file in one of the follow-
ing locations: 

Windows Vista: 

C:\ProgramData\TEC-IT\TFORMer\6.0\Examples\Command 

Line\SerialLetterPDF\SerialLetterData.csv 

Other Windows versions: 

C:\Documents and Settings\All Users\Application Data\TEC-IT\TFORMer\6.0\Examples\Command 

Line\SerialLetterPDF\SerialLetterData.csv 

In  specify the character, which is used as column separator (in our example a comma ,). In  
adjust the text qualifier character to match your input file (in our example a quotation mark “). The 
text qualifier is used to enclose single values within the text file. 

Since the file “SerialLetterData.csv” contains the column names in the first line make sure that the 
checkbox  is checked. 

The preview  allows you to check if the data from the source file is read correctly. If no columns 
are recognized, or if any data is shifted to a wrong column, the parameters  to  were not ad-
justed correctly. 

5.2.4.2 Specify Field Bindings 

In the next tab, Field Bindings, you provide the basis that the data from the source file can be used 
in the layout. In this step you associate all required sourcefields of the external datasource with 
datafields. Only datafields can be used as placeholders within text boxes, barcodes, images etc. 
Sourcefields are not directly available in the layout. 

► Here you set the bindings for all datafields. If you do not have created any datafields yet you 
have the possibility to create them in this dialog automatically. 

 

 
Figure 13: Bind Datafields Automatically 

Currently no datafields are available (only sourcefields). So we have to create datafields and bind 
them to the sourcefields. 
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In list  you see all sourcefields which are available in the CSV file. To create a datafield for each 
of these sourcefields automatically click on the Auto… button . TFORMer will prompt you if you 
want to bind them to datafields automatically (see ). Confirm this dialog with Yes. 

However, currently there are no datafields available, yet. Therefore, in the next dialog, press Yes to 
All to instruct TFORMer to create new datafields for all existing sourcefields. 

As result for each sourcefield in list  an equally named datafield is assigned. 

In the Preview tab you can check the bindings. If all sourcefields were bound correctly you should 

see the screenshot below: 

 
Figure 14: Preview of Data 
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5.2.5 Note for Defining Datafields Manually 

If you followed the instructions above there is no need to create datafields manually. However, 
instead of automatic datafield generation you may also create datafields manually. To do this follow 
the steps below. 

 
Figure 15: Create a Datafield Manually 

Right-click on the node Datafields  or on any existing datafield in the design tree. Select New 
Datafield…  in the pop-up menu. Alternatively select Data ►New Datafield… from the menu or 

click on the “New Datafield“ icon  in the toolbar. 

The dialog New Datafield appears. In this dialog enter the name of the datafield  and confirm with 
OK. 

► Generally it is recommended to use datafield names which are identical to the column 
names in the datasource. 

► Speaking field names will help you to identify the use of each datafield when creating the 
layout. 

► TFORMer is able to provide standard values for datafields. Such default values can be 
useful as test data during the development process. The default values are defined in the 
New Datafield dialog in  or in the property window . 

Once the datafield is inserted you will find the appropriate entry in the design tree. 
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5.2.6  Finish the Layout 

Now start to insert the required elements into the layout. To insert an element first select the 
element type in the layout toolbar  and then click on the suitable area of the layout in . To 
change the properties of an element (e.g. color, font, bar code, ...) select it with the mouse and then 
use the property window . 

5.2.6.1 Insert Text Elements 

For text elements TFORMer Designer opens a dialog which allows you to enter the content of the 
element (see ). You may mix static text with datafields (like Dear [Salutation] [Name],). Datafields 
are enclosed in square brackets []. 

 
Figure 16: Serial Letter Design 

► Always use the button   to embed a datafield or an expression into your text. 

► If you enter the expression markers [] (or <>) directly, they will be printed as typed on the 
keyboard. The expression will not be evaluated in such a case! 

When inserting an expression via  the Expression Builder appears: 
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Figure 17: Expression Builder 

In  select the datafield to be embedded in the text. Insert it into the expression  by clicking . 
Confirm the dialog with OK . 

5.2.6.2 Insert the Bar Code 

To insert a bar code into your layout select the bar code tool  and then click into the suitable area 
of the layout (). Because a bar code usually contains no static text, TFORMer will open the 
Expression Builder  directly. The properties of the bar code element (like the bar code type to be 
used or the rotation) can be changed in the property window . 

 
Figure 18: Insert a Bar Code 
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5.2.7 The Finished Serial Letter 

If all required elements have been inserted, then you should see the following layout: 

 
Figure 19: Finished Serial Letter 

5.3 Preview or Print the Serial Letter 

To get a preview of the resulting output simply click on the Preview tab. TFORMer will instantly 
render the serial letter in the main window. This output uses the data from the CSV file as described 
above. However, if you want to use different data you can create additional datasources and switch 
between them as required. 

To print the serial letter on a printer or to create an output file (e.g., a PDF file) open the print dialog. 
Therefore press Ctrl+P or use the menu File ►Print.... 

 
Figure 20: Printing 
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In  choose the required output format (e.g. Printer). In  select a suitable output device or output 

file. 

If you want to add a filter  click the button . The expression builder will appear. 

Now click OK  and start the output: 

 
Figure 21: Serial Letter – PDF Output 

5.4 Ready-To-Use Example 

The finished example can be opened with the following steps: Start ► All Programs ► TEC-IT 
TFORMer 6.0 ► Examples ► Demo Repository 
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Figure 22: Open the Serial Letter  

In the tree view open the layout MailingFlowerPower located in Projects ► TFORMer_Runtime_Ex-
amples by expanding the tree and by double-clicking item . 
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6 Quick-Print Existing Layouts 

TFORMer comes with a tool which is named TFORMer QuickPrint. This tool allows you to select a 
layout and to print it on any supported output device. Besides simple output functionality it also 
offers network-wide serial number support. Start TFORMer QuickPrint with: 

Start ► All Programs ►TEC-IT TFORMer 6.0 ►Tools ►Print Tool QuickPrint 

► TFORMer QuickPrint requires .NET Runtime 2.0! 

The screenshot below shows how to quick print the serial letter designed in chapter 5. 

 
Figure 23: TFORMer QuickPrint Tool 

The button Common…  is used to configure serial number printing. More details regarding this 
functionality are available in the TFORMer QuickPrint manual. 

The button Form…  is used to select the layout to be printed. TFORMer offers two different 

possibilities for organizing layouts: 

 Stand-alone layouts: Per default TFORMer Designer creates layouts which may be used on 
its own. These layouts are stored with the file extension *.tff. 

 Repository-based layouts: A repository is used for organizing multiple layouts within a 
structured database. A repository is stored on the file system with the file extension *.tfr. 

When using a stand-alone layout just select the appropriate filename in . For repository based 
layouts enter the filename of the repository, the project and the name of the layout. 

The button Output…  is used to select the required printer or output format. 

Table style  switches between the default input dialog and a table-style input dialog. 

Enter data values in the area  and start printing with Print . 

In  a preview of the selected layout (MailingFlowerPower example) is displayed. 
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7 Print Bar Code Labels with Serial Numbers 

This chapter describes how to print bar code labels with serial numbers. 

In contrast to a report (see chapter 5) a label is usually printed multiple times on a page of the 
output. The basic layout of the label remains unchanged, only the dynamic data (in this example the 
serial number) changes from label to label. In order to compute a serial number a datafield must be 
created. A datafield is a placeholder for variable data. It may be used in computations. 

► TFORMer is able to perform computations within a layout. Such computations utilize data-
fields for storing intermediate results. For more information refer to the TFORMer Designer 

manual. 

7.1 Your Requirements 

7.1.1 Bar Code Label Layout 

The layout of the labels in this example is very simple. A serial number should be printed as bar 
code and as text. The bar code encodes the serial number with leading zeros. 

 
Figure 24: Labels with Serial Number 

7.1.2 Serial Numbers 

This example demonstrates how TFORMer can be used to automatically create serial numbers. 
The serial number is computed by TFORMer itself. No external programming is required! 
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7.2 Create the Bar Code Labels 

7.2.1 Start TFORMer Designer 

See section 4.1. 

7.2.2 Create the Basic Layout 

► TFORMer Designer unifies the generation of reports and labels. Only the parameters of the 
layout are used to differentiate between the two possible output styles. This very flexible 
printing concept allows the generation of simple labels as well as full-featured reports. For 
more information, please check out the TFORMer Designer user manual. 

Create a new layout. Therefore press Ctrl+N or use the menu File ►New Form… 

In the appearing dialog you can choose between creating a new report, a new label or using one of 
the pre-designed layouts. 

 
Figure 25: Create a New Label 

The bar code labels as outlined above are a label-style output, therefore choose Custom Label () 
and click Next (). 
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Figure 26: Adjust the Margins of the Label 

Set all margins to the values shown above and click Next. 

 
Figure 27: Label-Specific Settings 

Adjust the required label settings. This example uses 3 columns of labels (each 50 mm width) and 5 
rows of labels per page. The horizontal and vertical distance between the single labels is set to 10 
respectively 5 millimeters. When clicking Finish TFORMer Designer opens a standard layout using 

the adjusted basic settings: 
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Figure 28: Standard Label 

The standard layout contains some graphical elements. Most likely they are not needed, so select 
them with the mouse () and press Del. 

► Please note: The screenshot above uses a zoom factor of 200%. You can change the 
viewing zoom factor for your layouts in the menu View ►Zoom. 

7.2.3 Create a Datafield to be used as a Serial Number 

As mentioned before, we need a datafield to hold the serial number. The name of this field should 
be SerialNumber. To simplify computation with this datafield, the data type will be set to Long (an 

integer number). 
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Figure 29: Create the Datafield SerialNumber  

Right-click onto Datafields () in the design tree and select New Datafield… () in the pop-up 
menu. In the following dialog enter the name of the datafield (SerialNumber – ) and select Long 
() as data type. Confirm with OK. 

► The default data type is String. This type is generally suitable for all kinds of applications 
unless you want to perform computations. For computations strings must be converted to 
numbers (e.g. with CLng or CDbl). Alternatively use the data type Long or Double. 
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7.2.3.1 Insert the Bar Code  

 
Figure 30: Insert a Bar Code  

In the layout toolbar select the bar code symbol () and click onto the desired position on the detail 
band (). A bar code will be inserted and the Expression Builder for the bar code data is opened 

automatically (). 

As bar code data the value of the datafield SerialNumber should be used. Therefore double-click 
the datafield SerialNumber (). It will be inserted in the edit area . Then press OK (). 

Tip: In order to provide a fixed number of digits in the serial number (add leading zeros), you can 
use the Format() function. For example, if you want to receive six digits, use the expression 

Format(SerialNumber, "000000"). 

In the property window () you can adjust all barcode properties (e.g. barcode type, color, …). 
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7.2.3.2 Insert the Text Element 

 
Figure 31: Insert a Static Text and a Datafield  

In the layout toolbar select the text symbol () and click on the desired position on the detail band 
(). A text element will be inserted and the Edit Text dialog is opened. 

The content of the text field is a combination of a fixed text and the actual value of the serial 

number. The fixed text ”Serial:” can be entered directly in . 

The datafield SerialNumber is inserted via the  menu of the dialog. After selecting the entry 

Datafield  the dialog Select Datafield () opens. 

Double-click the datafield SerialNumber () to insert it directly into the text. 

The resulting text is now Serial: [SerialNumber]. Close the Edit Text dialog with OK (). 

► TFORMer displays expressions (or single datafields) which are embedded into text or bar 
code element with surrounding square brackets [] or angle brackets <>. 

► Angle brackets are used for interpreting the result of an expression as HTML. 

7.2.3.3 Format the Text Element 

The newly inserted text element should be printed centered. Word-wrap should be disabled. To do 
so select the text element and edit its properties in the property window. The alignment is adjusted 
in  word-wrap is disabled by selecting False in . 
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Figure 32: Properties Window of a Text Element 

7.2.4 The Resulting Layout 

 
Figure 33: The Resulting Layout  

7.2.5 The Print Preview 

The print preview is opened by pressing the keyboard shortcut Ctrl+Space or by clicking on the 

symbol  in the toolbar. TFORMer Designer shows the following output. The bar codes are 
marked with crosses indicating that no data was encoded. This is because the datafield 
SerialNumber is not provided with any data yet. 
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Figure 34: Print Preview with Empty Datafield 

7.3 Printing Serial Numbers with TFORMer QuickPrint 

The simplest way to print serial numbers is to use TFORMer QuickPrint. 

TFORMer QuickPrint is able to maintain a pool of serial numbers. This even works if multiple users 
are printing the same layout and are therefore using the same serial numbers. TFORMer 
QuickPrint takes care that serial numbers are always unique. 

For this purpose a simple configuration file must be created. This configuration file holds the names 
of the datafields which should be used as serial numbers. 

7.3.1 Create a Serial Number Configuration File 

The configuration file must be named QuickPrint.xml. It is structured as follows: 

<?xml version="1.0" standalone="yes"?> 

<root> 

  <SerialNumber current="1000" stepSize="1" /> 

</root> 

This file contains the name of the datafield SerialNumber along with its current value (1000). The 
value in stepSize is used for incrementing the value of SerialNumber for one print-out. 

Save this file in an arbitrary directory. 

7.3.2 Start TFORMer QuickPrint 

Start TFORMer QuickPrint using the start-menu of Microsoft
®
 Windows

®
: 

Start ► All Programs ►TEC-IT TFORMer 6.0 ►Tools ►Print Tool QuickPrint 
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7.3.3 Set up TFORMer QuickPrint 

Click on the Common… button and enter the directory containing the QuickPrint.xml file as the 
serial directory () in the following dialog. 

Enter the directory where you want to save the last printed data (by default your My Documents 
folder) in . 

Choose an arbitrary username, enter it in  and close the dialog with OK. 

 
Figure 35: QuickPrint – Common Settings 

Next click on the Form… button and enter the directory where you saved your layout in the 
Repository field. 

Choose the output format (and the filename if you are exporting to a file) in the dialog accessible via 
the button Output.... 

You can save this configuration if you want to use it later with File ► Save As… 

With the Save Data button you can save the data which you have entered manually. The data is 
stored in the XML file. It is available at the next start of TFORMer QuickPrint. 

The Reset to default button resets all datafields in the current record to their default values.  

The Clear Data button clears the current record. 
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7.3.4 Enter the Printing Data 

Enter the printing data for your label in the input area. In this case, the label contains only the serial 
number. This field cannot be changed (read-only fields are marked with gray background color). 
The field Count of Serials  specifies how many serial numbers should be created. For each serial 
number one label is printed. If you want to print more than one label for each serial number adjust 
the number of copies. 

 
Figure 36: QuickPrint – Printing Data 

7.3.5 Print the Label 

To start printing simply click the Print button. If you are exporting to a file, TFORMer QuickPrint 
opens the file with the linked Windows

® 
application (e.g. PDF with Acrobat Reader). 

7.3.6 Ready-To-Use Example 

The finished example can be opened after the installation of TFORMer Designer with the following 
steps: 

Start ► All Programs ►TEC-IT TFORMer 6.0 ►Examples ►QuickPrint ►Serial Numbers 
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8 Contact and Support Information 

8.1 Free Support 

If you have any questions, please contact us: 

Email: support@tec-it.com  

Web: http://www.tec-it.com/support/ 

Don‟t hesitate to tell us your feedback! If the product does not fulfill your requirements, please tell us 
why. We are highly interested in meeting the requirements of our customers. 

8.2 How to Unlock the Demo Version 

You can unlock the demo version with a license key. License keys can be obtained from TEC-IT by 
Email, online order form or FAX. 

Email: sales@tec-it.com 

Online: http://www.tec-it.com/order/ 

Fax: +43 / (0)7252 / 72 72 0 – 77 

8.3 Company Contact Information 

TEC-IT Datenverarbeitung GmbH 

Address: Wagnerstr. 6  

AT-4400 Steyr  

Austria/Europe 

Phone: +43 / (0)7252 / 72 72 0 

Fax: +43 / (0)7252 / 72 72 0 – 77 

Email: support@tec-it.com 

Web: http://www.tec-it.com 
 
 
 
 
 
 
 
 
 
 
 
AIX is a registered trademark of IBM Corporation.  
HTML, DHTML, XML, XHTML are trademarks or registered trademarks of W3C, World Wide Web Consortium, Laboratory for Computer 
Science NE43-358, Massachusetts Institute of Technology, 545 Technology Square, Cambridge, MA 02139.  
JAVA® is a registered trademark of Sun Microsystems, Inc., 901 San Antonio Road, Palo Alto, CA 94303 USA.  
JAVASCRIPT® is a registered trademark of Sun Microsystems, Inc., used under license for technology invented and implemented by 
Netscape.  
Microsoft®, Windows®, Microsoft Word®, Microsoft Excel® are registered trademarks of Microsoft Corporation.  
Navision is a registered trademark of Microsoft Business Solutions ApS in the United States and/or other countries. 
Oracle® is a registered trademark of Oracle Corporation. 
PCL® is a registered trademark of the Hewlett-Packard Company. 
PostScript is a registered trademark of Adobe Systems Inc. 
SAP, SAP Logo, R/2, R/3, ABAP, SAPscript are trademarks or registered trademarks of SAP AG in Germany (and in several other countries).  
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