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2 Disclaimer 

The actual version of this product (document) is available as is. TEC-IT declines all warranties 
which go beyond applicable rights. The licensee (or reader) bears all risks that might take place 
during the use of the system (the documentation). TEC-IT and its contractual partners cannot be 
penalized for direct and indirect damages or losses (this includes non-restrictive, damages through 
loss of revenues, constriction in the exercise of business, loss of business information or any kind of 
commercial loss), which is caused by use or inability to use the product (documentation), although 
the possibility of such damage was pointed out by TEC-IT. 

 

 
We reserve all rights to this document and the information contained therein. Reproduction, 
use or disclosure to third parties without express authority is strictly forbidden. 
 

 
Für dieses Dokument und den darin dargestellten Gegenstand behalten wir uns alle Rechte 
vor. Vervielfältigung, Bekanntgabe an Dritte oder Verwendung außerhalb des vereinbarten 
Zweckes sind nicht gestattet. 
 

© 1998-2012  
TEC-IT Datenverarbeitung GmbH  
Wagnerstr. 6 

A-4400 Austria  
t.: +43 (0)7252 72720  
f.: +43 (0)7252 72720 77  
http://www.tec-it.com 

 

http://www.tec-it.com/
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3 Introduction 

3.1 Professional Documents Created With Ease 

Many thanks for evaluating TFORMer! 

The TFORMer product family represents a complete, lean and powerful solution for generating 
arbitrary documents. It combines the features of barcode labeling tools with the characteristics of 
report generators into a unified printing-solution. It provides professional layout and output capa-
bilities, an integrated barcode generator, full-featured UNICODE support and it supports direct PDF 
generation. It can be used on client and on server side and it is available for all major operating 

systems. 

 

                      

 

The functionality of TFORMer is available for end-users as well as for software developers: 

End-Users benefit from the graphical layout editor with instant output capabilities: TFORMer 
Designer offers outstanding design and printing features for reports, tables, lists, serial letters, 
industry forms, vouchers and barcode labels. Furthermore the numerous ready-to-use label and 
report templates for industry and logistics (e.g., VDA-4902, Odette, GALIA, AIAG, …) will be a valu-
able assistance. 

Software developers use TFORMer SDK as reporting tool for direct printing, PDF generation, 
PostScript-, HTML, image or ZPL-II output. Layouts are designed graphically with TFORMer 
Designer. The TFORMer SDK is then used to provide dynamic data for the layouts and to generate 

the output. This core functionality for printing and output is available for all major operating systems. 

3.2 TFORMer Basics 

In contrast to a word processor which is mostly used for static content, TFORMer generates output 
based on dynamic data. Examples for dynamic contents are article-numbers used in product labels 

or addresses used in serial letters. 

Dynamic content is provided by an external data source like a database, a file, an arbitrary appli-
cation or by the user. Such an external data source is read by TFORMer during printing. So-called 
data fields are used to access the external data. They serve as placeholders for dynamic content in 
the layout. To simplify usage, TFORMer provides a mapping mechanism to bind external data to 

the data fields used in a layout. 
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This data-centric output scheme is maintained in all cases. Even when printing pure static 
documents (like personal address labels without any dynamic data) a data source is required for 
controlling the number of printed labels. 

Data

Output

Design (.ttf, .tfr)

Preview

Enter manually

Import from File

Import from Database

Printer PDF HTML Text

Generate automatically

PostScript
®

 
Figure 1: Architectural Overview 

Layouts created with TFORMer Designer are able to perform computations and to react on the 
values of datafields. Thus, TFORMer enables you to embed the complete output logic of a 
document into the layout. 

3.3 Output Formats 

Once a layout was designed it produces identical results across printer models, operating systems 
and formats. The following formats are supported: 

 Direct Printing 
Print layouts directly on all printers supported by Microsoft

®
 Windows

®
. 

 PDF 
PDF export with full-featured barcode support, Unicode and font embedding. 

 PostScript
®
  

Used for printing under Linux/UNIX and for pre-press applications. 

 HTML
1
 

The built-in HTML output is ideal for previewing and for web-based applications. 

                                                      
 
 
1
 Due to the nature of HTML some output features may be limited or not available. 
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 Image Formats  
The built-in image output supports BMP, GIF, JPG, PCX, TGA, PNG and TIF formats 
(including multipage TIF). 

 ZEBRA
®
  

Print to ZEBRA
®
 printers without any additional driver. ZPL-II output is generated directly. 

 ASCII  
Pure ASCII output without any graphics for special purpose requirements. 

3.4 System Requirements 

3.4.1 Operating Systems 

TFORMer Designer requires one of the operating systems listed below. It works with 32-bit and 64-

bit operating systems. 

 Microsoft
®
 Windows 2000 

 Microsoft
®
 Windows XP 

 Microsoft
®
 Windows Vista 

 Microsoft
® 

Windows 7  

 Microsoft
®
 Windows Server 2003 (including Terminal Server) 

 Microsoft
®
 Windows Server 2008 (including Terminal Server) 

TFORMer Designer includes the output kernel of the TFORMer SDK. This output kernel is 
available for Linux

®
 and UNIX

®
 as well. For details check out the Developer Manual. 

3.4.2 Memory 

512 MB RAM is the recommended minimum (1 GB for Windows Vista or higher). Actual memory 
requirements depend on the type and size of the generated output. 

3.4.3 Disk Space 

TFORMer needs approximately 30 MB on disk. When using the .NET based API of the TFORMer 
SDK or the printing utility TFORMer QuickPrint please also consider .NET 2.0 requirements. 
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4 User Interface 

This chapter will give you an overview of the TFORMer user interface. 

4.1 Main Window 

 
Figure 2: User Interface 

The main window is divided into the following areas: 

 Menu (see 4.2). 

 Toolbars (see 4.3). 

 Layout View, Data View and Preview (see 4.4). 

 Design Tree Window (see 4.5). 

 Properties (see 4.6). 

 Status Bar (see 4.7). 

 Layout Tabs (see 4.8). 

 














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4.2 Menu 

The menu gives you access to the following functions: 

4.2.1 File 

New Form… Creates a new layout. Choose a template and adopt it to your needs. 

Shortcut: Ctrl+N 

Open… Opens an existing layout (or repository). 

Shortcut: Ctrl+O 

Save Saves the current layout. 

Shortcut: Ctrl+S 

Save as… Saves the current layout with a new name. You can also save layouts as ZIP-files. 

Close Form Closes the current layout. 

Shortcut: Ctrl+W or Ctrl+F4 

Templates Templates can be used as basis for new layouts. 

 Save as Template… Save the current layout as template. 

 Organize Templates… Organize the templates in a hierarchical structure. 

Layout View Switches to the layout view (see section 4.4.2). 

Shortcut: Ctrl+L 

Data View Switches to the data view (see section 4.4.3). Use this view to manually edit or import 
data from external data sources. 

Shortcut: Ctrl+D 

Preview Switches to the print preview (see section 4.4.4). 

Shortcut: Ctrl+Space 

Page Setup… Adjusts the page layout:  
Layout type, paper format, orientation, margins, as well as the page layout for printing 
on label paper. 

Print… Prints the layout on a printer of your choice or generate file output (PDF, PostScript
®
, 

HTML, Text). 

Shortcut: Ctrl+P 

Repository A repository is a central location which references multiple layouts in a structured way 
(see chapter 16). 

 New Repository…  Create an empty repository. 

 Open Repository… Open an existing repository. 

 Close Repository Close an open repository. 

Exit Exit TFORMer. 

4.2.2 Edit 

Undo Reverts the last change. 

Shortcut: Ctrl+Z 

Redo Reverts the last Undo. 

Shortcut: Ctrl+Y 

Cut Copies all selected objects (rectangles, texts, printing bands, datafield definitions, ...) to 
the clipboard and remove them from the layout. 

Shortcut: Ctrl+X 

Copy Copies all selected objects to the clipboard. 

Shortcut: Ctrl+C 

Paste Inserts the content of the clipboard. 

Shortcut: Ctrl+V 

Delete Removes all selected objects. 

Keyboard: Del 

Element-Content… Edits the content of a text, barcode or picture element. 

Shortcut: Double-Click the Element or press F2 

Printing-Condition… Edits the printing condition for the selected band or element (see also section 12.2). 

Group-By… Edits the group-by expression for the selected “group header” or “group footer”. 
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Pre-Evaluation… Edits the pre-evaluations for the selected band (see also section 12.4). 

Post-Evaluation… Edits the post-evaluations for the selected band (see also section 12.4). 

4.2.3 Insert 

Project Inserts a new project into the repository.  

Form… Inserts a new layout into the repository.  

Data Inserts a new 

 Datafield…  Create a new datafield (see also section 10.2.1.1). 

 Datasource… Create a new data source (see also section 13.3.2.1). 

 Source-Parameter… Create a new source parameter (see also section 13.5.2.1). 

Tray-Mapping Inserts a new tray mapping (see also section 12.6). 

Layer… Inserts a new layer (see also section 12.3). 

Band Inserts a new band (page header, detail band, …) – see also chapter 7. 

Element Inserts a new element (text, barcode, line, …) – see also chapter 8. 

4.2.4 Layout 

Layout View Switches to the layout view (see section 4.4.2). 

Shortcut: Ctrl+L 

Z-Order Changes the order of overlapping elements. The selected element can be brought to the 
front or to the back (see also section 8.2.10.3). 

Align Aligns two (or more) selected elements (see also section 8.2.10.1). 

Size Adjusts two (or more) selected elements in size (see also section 8.2.10.2). 

Horizontal Spacing  Enlarges or reduces the horizontal distance between elements within a selection (see 
also section 8.2.10.4). 

Vertical Spacing Enlarges or reduces the vertical distance between elements within a selection (see also 
section 8.2.10.4). 

Band Order Re-arranges the order of selected bands (see also section 7.3.6). 

Shortcuts: Alt+ and Alt+ 

4.2.5 Data 

Data View Switches to the data view (see section 4.4.3). Use this view to manually edit or import 
data from external data sources. 

Shortcut: Ctrl+D 

Refresh Reloads the data from the data source. 

Shortcut: F5 

New Datafield… Inserts a new data field (see also section 10.2.1.1). 

New Datasource… Creates a new data source (see also section 13.3.2.1). 

Edit Datasource… Edits the current data source (see also section 13.3.2.3) 

New Source-Parameter… Inserts a new source-parameter (see also section 13.5.2.1). 

Edit Source-Parameter… Edits a source-parameter (see also section 13.5.2.3). 

Edit Filter… Edits the filter (see also section 13.6.1). 

Apply Filter Filters the print data (see also section 13.6.2). 

4.2.6 Tools 

Customize… Customizes the toolbar (not available in this version). 

Options… Opens the options dialog window (see chapter 17). 

4.2.7 View 

Layout Switches to the layout view (see section 4.4.2). 

Shortcut: Ctrl+L 

Data Switches to the data view (see section 4.4.3). Use this view to manually edit or import 
data from external data sources. 
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Shortcut: Ctrl+D 

Preview Switches to the print preview (see section 4.4.4). 

Shortcut: Ctrl+Space 

Layer Colors Toggles the display color of the elements between layer colors and element colors (see 
also section 12.3.3). 

Status Bar Shows or hide the status bar (see Figure 2, ). 

Application Look Selects the appearance of the user interface. Choose between Office XP, Windows XP 
and Office 2007 (blue, black, aqua, silver) styles. 

Properties Shows or hide the properties window (see Figure 2, ). 

Design Tree Shows or hide the design tree window (see Figure 2, ). 

Toolbar Shows or hide single toolbars (see Figure 2, ). 

Zoom Selects the zoom factor. You will find the selected zoom factor shown next to the zoom 
symbol in the status bar:  

 
Shortcut: Ctrl++, Ctrl+– or Ctrl+Mousewheel 

4.2.8 Window 

Close All Documents Closes all opened documents. 

Document List At the bottom of the Window menu all open documents are listed with their names. To 
select one of the documents, click at the appropriate menu entry. 

4.2.9 Help 

TFORMer Help Displays the TFORMer manual. 

Keyboard: F1 

Online FAQ Opens the default browser and navigate to the TFORMer Designer frequently asked 
questions web page. 

TEC-IT Website Opens the default browser and navigate to http://www.tec-it.com. 

Buy TFORMer Online Opens the default browser and navigate to the online order form. 

License… Opens the License dialog for TFORMer Designer (see chapter 18). 

Check for Update… Checks if an update of TFORMer Designer is available. 

About TFORMer… Displays information about TFORMer Designer and the program version. 

 

http://www.tec-it.com/
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4.3 Toolbars 

The most commonly used program functions are accessible via toolbars. Each of the toolbars can 
be shown or hidden (menu View ► Toolbar). 

The following toolbars are available: 

Default 
 

(New Form, Open Form, Save Form, Layout View, Data View, Preview, Page setup, Print, …)  

  

Layout 
 

(Alignment, Size, Z-Order, Spacing) 

  

Content and 
Expressions  

(Element-Content, Printing Condition, Group-By, Pre-Evaluation, Post-Evaluation) 

  

Format 
 

(Font and Font size) 

  

 
 

(Font style, Text Alignment, Colors, Line styles, …) 

  

Layer 
 

(Assign Elements to a Layer, Add Layer, Layer Colors)  
  

Barcode 
 

(Choose Barcode Symbology) 
  

Data 
 

(Refresh, New Datafield, New Datasource, New Source-Parameter, Edit Datasource, Edit Source-
Parameters, Edit Filter, Apply Filter)  

  

Repository 
 

(New Printer, New Project, New Datafield) 

  

Elements 
 

(Insert Graphical Elements) 
  

Bands 
 

(Insert different kinds of Bands: Report Header, Page Header, Detail Band, …) 
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4.4 Layout View, Data View and Preview 

4.4.1 Introduction 

TFORMer offers three different views for a single form. 

The default view is the layout view (). It is used to create the layout. The layout usually utilizes 
datafields (like [Printed Items] in the layout below) as placeholders for the actual data. For details 

regarding datafields, please refer to chapter 10. 

The data for the datafields is provided by a datasource. It can be edited in the data view (). 

TFORMer also offers a preview, which instantly renders the resulting output using the layout and 

the data of the adjusted datasource (). 

 
Figure 3: Layout View 

You can switch between the views by pressing the corresponding tabs or by using the File or View 

menus (see 4.2.1 and 4.2.7). 

  
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4.4.2 Layout View 

The layout view is used to create layouts: 

 
Figure 4: Layout View 

On the worksheet  you can place all kinds of graphical elements like text elements, lines, rect-
angles, barcodes and images. Such elements can be moved, resized or deleted. Furthermore, you 
can add and remove single print areas like page headers and page footers. These areas are called 
bands (see chapter 7). 

On the left and on the top of the layout there are rulers () which assist you when positioning 
elements. After starting TFORMer Designer for the first time, the measuring unit is set to ”System 
(Default)”. You can change this value in the options dialog (menu Tools ► Options…). 

It is possible to zoom the layout using the menu View ► Zoom or the hotkeys Ctrl++ and Ctrl+-. You 
can also adjust the zoom factor by holding down the Ctrl key and by simultaneously turning the 

mouse wheel. 

For more information on how to design layouts, please refer to chapters 6 to 12. 






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4.4.3 Data View 

The data view is used to administrate datasources. You can create, switch and modify datasources. 
Furthermore, the content of the active datasource is shown. This is the data which is used for 
printing the layout. 

 
Figure 5: Data View 

The data view mainly consists of a data grid showing the current data (). Use the navigation 
buttons in  to select rows or to jump to a specific row in the datasource. In  you will find func-
tions for manipulating and selecting datasources. When checkbox  is activated all datafields which 
are not used in the layout will be hidden. 

By default TFORMer assigns a manual datasource to a newly created layout. This means that you 
can enter values for datafields manually in the grid. It is also possible to create and edit other types 
of datasources (e.g., ODBC database access) in this view. For more information regarding the data 
view, please refer to section 13.2. 

4.4.4 Preview 

This tab shows an instant preview of the output using the selected datasource. 

 
Figure 6: Preview 







 
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Use the functions in  to change the zoom factor, switch between single page or double-page 
preview, show/hide label boundaries, navigate between pages or to jump to a specific page. For 
details, please refer to chapter 14. 

4.5 Design Tree Window 

4.5.1 Layout Tree 

The design tree window shows a structured view of the layout. It lists all objects in a single place 
and allows the selection of objects per mouse click. Even such elements, which are occluded in the 
design view, can be selected in the design tree easily.  

 
Figure 7: Design Tree Window 

 
Figure 8: Delete a Datasource 

The design tree window  lists all objects in a hierarchical tree structure. You can expand single 
branches of the tree by clicking the  symbol and you can collapse them by clicking the  symbol. 

To select an object, click on it with the left mouse button. Hold down the Shift key or the Ctrl key for 
multiple selection. Figure 7 shows a selected text element (), which is located in the page header 
of a layout called “PickList_10.tff”.  

If you right-click on a tree item a context menu will appear (see Figure 8, ). The context menu 
offers various functions for the selected object. 

If TFORMer encounters an error in a user defined computation, the affected item is drawn red. For 

more information, please refer to section 10.4. 

4.5.2 Repository Tree 

If a repository is used, a second tab will be shown next to the Design tab . Clicking tab  switches 
to the tree view of the repository. A repository is a central database for layouts, datafield definitions 
and tray-mappings. For details, please refer to chapter 16. 







 





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4.6 Properties 

The complete layout structure in TFORMer is based on objects (bands, text boxes, datasources, 
etc.). To adjust the properties of such objects the properties window is used. For a completive list of 
all object properties, please refer to Appendix A. 

The properties of the following objects can be modified: 

 Forms 

 Bands 

 Elements (graphical design elements) 

 Datasources and Source-Parameters 

 Datafields 

 Layers 

 Tray-Mappings 

 Projects (Repository) 

 

 
Figure 9: Properties Window 

All properties are grouped into categories (like “Common”, “Advanced” or “Position”, see ). The 

categories help you to locate properties more easily. 

Properties are accessible as “field:value” pairs. E.g., the property “Text” is currently set to “Ex-
press”. The color (“Fore Color”) is set to red. 

The area  shows information on the selected property. 

Button  is used to turn the auto-hide feature of the properties window on or off. Click the  symbol 
once to make the window slide away. To recover its previous state, hover with the mouse over the 

 button. By clicking the auto-hide button again, the window will be fixed in its previous posi-
tion. 

Button  closes the properties window. 

► TFORMer Designer supports multiple object selection. This can be used to change the pro-
perties of multiple objects simultaneously. A change will be applied to all objects within the 
selection. 








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4.7 Status Bar 

The status bar displays information about position and measurement of the selected design 
element. Furthermore the zoom factor of the layout view is shown. 

 
Figure 10: Status Bar 

 shows the coordinates of the upper left corner of the selected element (or of the element with the 
mouse focus). 

 shows the dimensions of the selected element (or of the element with the mouse focus). The 
measuring unit used for displaying positions or dimensions can be adjusted in the options dialog 
(menu Tools ► Options…). 

 shows the current zoom factor used for displaying the content of the layout view. The zoom factor 
can be adjusted via the menu (View ► Zoom) or by holding down the Ctrl key and by simulta-

neously turning the mouse wheel. 

4.8 Layout Tabs 

When working with multiple layouts, each of these layouts is represented by a tab (see ). To 
switch between layouts click on the corresponding tab in  or use the layout picker . To close the 
current layout click on the  symbol inside the tab. 

 
Figure 11: Change layouts quickly by using tabs 

  

 
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5 Printing Concept and Workflow 

5.1 Introduction 

TFORMer uses one universal output concept to produce all different kinds of outputs like: 

 Reports – a table, a list or a letter usually spanning multiple pages. 

 Label sheets – a layout which is printed repeatedly in multiple rows and columns on each 
page. 

 Single labels (Label Printer) – a layout which is printed once on each page. One page is one 
label. 

 Hybrid Layouts – a mix of the first two variants. 

The output concept is based on the logical separation of the layout () into different printing areas 
(e.g., report header, page header, detail area, page footer and report footer). Such a printing area is 
called band. 

Each of these bands fulfills a specific purpose. By combining bands and by adjusting their proper-
ties, different layout schemes can be produced. The figure below illustrates the printing of a simple 
report (). 

Layout Output Input Data with Datafields

 
Figure 12: Printing Concept 

In contrast to a word processor which is mostly used for static content, a report generator like 
TFORMer generates output based on dynamic data. Good examples for dynamic contents are the 

article numbers on product labels, the addresses in serial letters and the order positions in invoices. 

The dynamic content is usually provided by an external datasource (). This is either a text file, a 

database, an arbitrary application or user specified data. 

5.2 Rendering the Layout 

Each print-out is based on the form layout. The form layout uses different design elements like text 
elements, barcode elements, shapes and pictures which are placed on bands (see Figure 13, ). 

When generating the output, each of the bands will be rendered repeatedly: Usually a detail band is 
rendered for each single record (see Figure 13, ) of the datasource. Page header and page footer 



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are rendered at the top respectively bottom of each page automatically (see Figure 13, ). The 
report header and the report footer are printed at the beginning and at the end of the report (see 
Figure 13, ). In this way the output is assembled. 

BarcodeText PictureShape

Layout Output Input Data with Datafields

Reference Datafields

in Text, Barcode or Image Elements

(e.g. [ArticleNo])

...

 
Figure 13: Rendering the Layout 

For providing the content you have various possibilities: Text, barcode and image elements can be 
filled with fixed data. Aside from that they can also reference the fields in a datasource. Such 
references will be resolved during print time and the actual data is inserted (see Figure 13, ). 
However, not only the fields in the datasource may be used to provide dynamic data. TFORMer 
also provides system fields (e.g., the current page number) and functions (e.g., the current date), 
and you can perform your own arbitrary computations. Besides that, you can easily create your own 
serial numbers and use them in the layout. 

5.3 Datasource Concept 

For generating output TFORMer requires data. The records and the datafields control the content 
and the appearance of the output. As a rule of thumb TFORMer prints one detail band per record of 
the datasource. 

Please note, that this data-centric output scheme is maintained in all cases, even when printing 
pure static documents like personal address labels. In this case the number of records (or the copy 
counter for records) controls the number of printed labels. 

A datasource can be seen as a simple table, which is read row by row (record by record) by 
TFORMer during printing. Each record (each row) provides the values for one or more datafields 

used in the layout (e.g., “ArticleName”, “ArticleNo” and “ArticlePrice”). 




















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Figure 14: Datasource Concept 

5.4 Reading a Datasource and Printing Bands 

TFORMer processes an output request in the following way: 

A datasource is read record by record in the native order of the datasource. TFORMer does not 
change the order of the records. 

After starting a print-job the first data record is loaded. If no record exists TFORMer does not pro-
duce any output. 

Then, for each available data record, TFORMer internally iterates through all bands in the layout. 
Whether a band should be printed on the current printing position on the output page depends on 
the following rules: 

 If the current record is the first record of the input data, all defined report headers are 
printed. 

 If the current record is the first record within a group, all defined group headers are printed. 

 All defined detail bands for the current record are printed. 

 If the current record is the last record within a group, all defined group footers are printed. 

 If the current record is the last record of the input data, all defined report footers are printed. 

 Printing page headers and page footers is triggered automatically. It works completely 
independent from the current record. 

 

► Keep in mind that TFORMer supports multiple bands of the same type in one layout (e.g., 
multiple page headers). 

► Whether a specific band is printed or not can be controlled via printing conditions. 

For more information on bands, please refer to chapter 7. 
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5.5 Typical Workflow 

The typical workflow when designing a new layout is outlined below. 

5.5.1 Identify Dynamic Data  

The first step before creating a layout is to identify the static and dynamic content of the layout. 
Dynamic content is usually provided by the user or by external datasources via placeholders. These 
placeholders are called datafields and are filled with current values during print-time. 

5.5.2 Layout Design 

To create the layout, you either modify one of the numerous available templates, or you create your 
own layout. 

Layouts are composed of different logical areas called bands. When designing a layout you can 
combine different bands to create different layouts schemes. Each band can contain different 
graphical elements (text elements, barcode elements, shapes and images). Dynamic features (e.g., 
printing conditions) give you additional control over the output. 

For more information on designing layouts, please refer to chapters 6 to 12. 

5.5.3 Provide Data 

Before you can generate any output you have to specify the data to be printed. The data can be 
provided in different ways: 

 It can be edited manually. 

 It can be imported from an external file or from a database. 

 It can be provided programmatically via the TFORMer SDK. 

For more information on providing data, please refer to chapter 13. 

5.5.4 Generate Output 

Once you have designed your layouts you can assign different datasources to generate output with 
different content. For details, please refer to chapter 15. 
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6 Forms 

6.1 Introduction 

TFORMer files are called forms. A form contains the graphical design (the layout), which consists of 
one or more vertical areas holding all graphical design elements. Furthermore the form contains all 
datafields, datasources, tray mappings and layers. 

6.2 Basic Operations 

6.2.1 Open an Existing Form 

To open an existing form select File ► Open… from the menu (or press the “Open” icon  in the 
toolbar). You can also press the keyboard shortcut Ctrl+O. Then select the requested file and press 
OK to confirm. 

Alternatively you can also double-click on the .tff file in the Windows
®
 Explorer, or drag the file from 

the Explorer to the TFORMer window. 

6.2.2 Create a New Form 

To create a new form select File ► New Form… from the menu (or press the “New” icon  in the 
toolbar). You can also press the keyboard shortcut Ctrl+N. The following wizard will appear: 

 
Figure 15: Create a New Layout 

Select the template that you want to start with. Choose between: 












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 Custom report (see section 6.2.2.1). 

 Custom label (see section 6.2.2.2). 

 Ready-to-use label or report templates for industry, logistics and the medical branch. 

 Sample and overview layouts, demonstrating the functionality of TFORMer. 

Select the desired item and confirm your selection with Next respectively with Finish (see ). If all 

required input is done the according layout will be opened in the design window. 

The layout can be adapted to your needs by adding, removing or modifying bands and design ele-
ments. 

6.2.2.1 Custom Report 

If you want to design your own report, choose <Custom Report> and click Next. The following 

wizard will appear: 

 
Figure 16: Simple Report – Page Settings 

Choose the desired layout type in . Normally this is the type Simple Report. 

Then specify the page size, the orientation and the page margins in . 

Click Finish  to open the layout. 

The following layout was created with the settings as shown above. Reports typically have a report 
header, a page header, followed by a list of data records (detail bands), a page footer and a report 
footer. Upon creation of the new report 10 records are inserted automatically. For each of these 
records TFORMer generates one “row” in the report. 






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Figure 17: Simple Report – Layout View 



 
Figure 18: Simple Report – Print Preview 

6.2.2.2 Custom Label: Label Sheet 

If you want to design your own label for laser or inkjet printers (e.g., Avery
®
 standard label formats), 

choose <Custom Label> and click Next. The following wizard will appear: 

 
Figure 19: Label Sheets – Page Settings 

Choose the layout type Label Sheets  (= print multiple labels on one output page). 








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In  you specify the paper size, the page orientation and the page margins. Furthermore you can 
specify the label dimensions, the number of rows and columns (= the number of labels per page),  
the row- and column-spacing and the printing order for the labels. 

 

In order to select one of the predefined label 
templates use the button Select Template… . 
The selection dialog shows a list of all available 
format definitions (see figure to the left). Use the 
filter  to narrow down the selection. After you 
have chosen the desired format in  confirm with 
OK. 

Click Finish  to open the layout. 

The following layout was created using the settings as shown above (3 columns, 5 rows, label 
dimensions of 6 cm x 5 cm, row-and column-spacing each 2 mm). Labels typically use the detail 
band only. No page headers or footers are used by default. Upon creation of the new label some 
records are inserted automatically. For each of these records TFORMer generates one label. 

 
Figure 20: Label Sheets – Layout View 



 
Figure 21: Label Sheets – Print Preview  

6.2.2.3 Custom Label: Label Printer 

For printing labels with label printers (e.g., thermo transfer printers), choose <Custom Label> and 
click Next. The following wizard will appear: 




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Figure 22: Label Printer – Page Settings 

Choose the layout type Label Printer  (= the output page is the label). 

In  you specify the label size and the page orientation. 

 

In order to select one of the predefined label 
templates use the button Select Template… 
. The selection dialog shows a list of all 
available format definitions (see figure to the 
left). Use the filter  to narrow down the 
selection. After you have chosen the desired 
format in  confirm with OK. 

 

Click Finish  to open the form 

The following layout was created using the settings as shown above (label dimensions of 6 cm x 5 
cm). Labels typically use the detail band only. No page headers or footers are used by default. 
Upon creation of the new label one record is inserted automatically. Unless you insert more records 
TFORMer will generate exactly one label. 











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Figure 23: Label Printer – Layout View 



 
Figure 24: Label Printer – Print Preview 

6.2.3 Page Setup 

If you want to adjust the page setup for the opened layout select File ► Page Setup… from  the 
menu. Alternatively you can also double-click on the gray area around the layout. The following 
dialog appears: 

 
Figure 25: Page Setup 

On this dialog you can do all necessary page adjustments. You can change 

 the layout type, 

 the paper format and the page orientation 

 and the page margins. 

 For labels you can additionally adjust the row- and column- settings and the print order 
(“Across, then Down”, “Down, then Across”).  

 

► For labels you can access a large amount of predefined formats by clicking Select Tem-
plate…. 

Using the page setup dialog you specify the exact page layout: 
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Figure 26: Page Setup for Standard Reports, Label Sheets, and Label Printers 

For more information about different layout variations please refer to Appendix D. 

6.2.3.1 Paper 

Property Description 

Format The paper format (e.g., DIN A4, DIN A5, …, <Custom Format>). 

Width The paper width. 

Height The paper height. 

6.2.3.2 Margins 

Property Description 

Top The page margins are used to confine the printing area on the output page. They are specified 
with respect to the physical borders of the output page. 

Bottom 

Left 

Right 

6.2.3.3 Orientation 

Property Description 

Orientation The page orientation: 

 Portrait 

 Landscape 

 Printer Default (uses the orientation, which is adjusted in the printer driver) 

6.2.3.4 Output 

Property Description 

Rotation Output rotation (0, 90, 180 or 270 degrees, counter clockwise). 
Instead of rotating the output page (portrait, landscape) you can also rotate the output on the 
page. 

6.2.3.5 Label Settings 

In order to print multiple labels on one output page (e.g. business cards on an A4 page) you have to 
specify the size of the labels and the desired number of labels per page: 



 
 

Page 35 of 139 

TFORMer Designer  User Manual  

Property Description 

Width The width of the label. 

Height The height of the label. 

Columns The number of labels which is printed besides each other.  
(If set to auto, the maximum number of columns that fit on the output page will be selected 
automatically.) 

Rows The number of labels which is printed underneath each other. 
(If set to auto, the maximum number of rows that fit on the output page will be selected 
automatically.) 

Spacing X The horizontal spacing between the labels. 

Spacing Y The vertical spacing between the labels. 

Print Order The print order defines the order (“Across, then Down” or “Down, then Across”) in which the labels 
are printed on the output page.  

This setting is only available when printing multiple rows and columns (see also 6.2.3.4). 

6.2.4 Save a Form 

To save an open layout select File ► Save or File ► Save as… from the menu. 

File ► Save saves the layout with the current file name. Instead of selecting File ► Save you can 
also press the “Save” icon  in the default toolbar or you can press the keyboard shortcut Ctrl+S. 

Choosing Save as… allows you to specify a file name before saving the file. 

6.2.5 Switch between Forms 

To switch between open forms just click on the corresponding tab in the layout window. Alterna-
tively you can also use the layout picker  or the menu Window. Using the keyboard shortcut 
Ctrl+Tab you will switch to the next layout tab. Ctrl+Shift+Tab switches to the previous tab. 

6.2.6 Close a Form 

There are different ways to close an open form: 

 Click on the small  in the layout window tab (see section 4.8, ). 

 Select File ► Close Form from the menu. 

 Click with the right mouse button on the form (either in the layout window or in the design 
tree window) and select Close Form from the pop-up menu. 
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6.3 Form Properties 

Using the properties window you can adjust some form related settings (see also Appendix A.1). 
Among others you can: 

 apply a background image (watermark), 

 specify a name for the output or spool file. 

First select the form. Thereafter the layout properties can be adjusted. 

6.3.1 Form Selection 

 
Figure 27: Form Selection 

A form can be selected by clicking with the left mouse button in the upper left corner of the layout 
view  or by clicking inside the gray area . Alternatively you can select the form by clicking on the 

top level element in the design tree (see ). A square (under XP: ; under Vista: ) in  will 
indicate, that the form is selected. 

6.3.2 Watermark 

The Watermark is an image which is used as background for each page. The image file name (or 
an expression which computes the file name during print-time), the output size and the output 
position can be adjusted in the Watermark group. 

6.3.3 Document Name 

The Document Name is used as name for the generated output file or spool file. If left blank, the file 
name of the form is used. The document name can be adjusted in the Advanced group. 






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7 Bands 

7.1 Introduction 

A layout consists of one or more bands. Each band is a vertical section, which contains graphical 
elements like text elements, lines or barcodes. Each band fulfills a specific purpose and is printed in 
a clearly defined position and sequence. 

Besides that, bands may be used for computations, and they can be used to control the output 
behavior (see chapter 12). 

7.2 Band Types 

TFORMer supports the following band types: 

 Report Header 
This band is printed at the top of the first page of the output. Alternatively it can also be 
printed at the top of the first label. This band is optional. 

 Page Header 
This band is printed at the top of each page (on the first page after the report header). 
Alternatively it can also be printed at the top of each label. This band is optional. 

 Group Header 
This optional band is printed before a group starts. A group is defined by the “Group-By” 
property in this band. Whenever the “Group-By” expression changes, a new group is started. 

 Detail Band 
This band is printed for each single record. 

 Group Footer 
This optional band is printed after a group. A group is specified by a “Group-By” expression. 

 Page Footer 
This band is printed at the bottom of each page (on the last page before the report header). 
Alternatively it can also be printed at the bottom of each label. This band is optional. 

 Report Footer 
This band is printed on the last page of the report (after the last data record). Alternatively it 
can also be printed at the bottom of the last label. This band is optional. 

 

Page Header

Page Footer

Group Header

Detail Band

Detail Band

Detail Band

Group Footer

Page Header

Page Footer

Detail Band

Detail Band

Detail Band

Detail Band

Detail Band

Page Header

Page Footer

Group Footer

Group Header

Detail Band

Detail Band

Group Footer

Detail Band

Detail Band

Detail Band

Group Header

Detail Band

First page Last pageIntermediate pages

Report Header

Report Footer

 
Figure 28: Rendering Scheme for Bands (Report) 
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The figure above shows the printing of a report. When printing labels, typically no page- and report 
headers/footers are required. The detail bands will be arranged differently (see also section 
Appendix D). 

7.3 Basic Operations 

7.3.1 Insert a Band 

 
Figure 29: Layout 

To insert a band click on the appropriate icon in the toolbar  or select Insert ►Band from the 

menu. The selected band will be inserted as a vertical section on the worksheet. 

 
New Report Header Add a new report header to the layout. 

 
New Page Header Add a new page header to the layout. 

 
New Group Header Add a new group header to the layout. For each group header you have to define a 

group-by expression. 

 
New Detail Band Add a new detail band to the layout. 

 
New Group Footer Add a new group footer to the layout. For each group footer you have to define a 

group-by expression. 

 
New Page Footer Add a new page footer to the layout. 

 
New Report Footer Add a new report footer to the layout. 

7.3.2 Band Selection 

To select a band, click on the band header  or on an empty area inside the band. You can also 
select a band in the design tree. Once a band is selected, it can be copied, deleted or its properties 
can be adjusted. 








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7.3.3 Expanded/Collapsed View of Bands 

Bands can be displayed in expanded or in collapsed view. The collapsed view is used to hide a 
band during the layout design. The resulting output is NOT influenced!  
Click on the  symbol to expand, and on the  symbol to collapse the band view (see ). 

7.3.4 Adjust Band Properties 

To adjust the band properties, first select the band. Then the properties can be edited in the proper-
ties window. For a list of available properties, please refer to Appendix A.2. 

7.3.5 Change Size 

7.3.5.1 Width 

The width of bands is usually defined by the page setup (see 6.2.3). Each band gets the maximum 
available space which is available (= paper width minus the page margins). 

For complex layouts certain bands can also be adjusted directly in the layout. 

7.3.5.2 Height 

For labels the height of detail bands, group headers and group footers is preset and fixed according 
to the label size (see 6.2.3). 

For reports the height of bands is freely adjustable. It can be changed with the mouse by clicking 
and dragging the lower band margins (see Figure 29, ). Alternatively you can also adjust the 
height in the group Position in the properties window. 

7.3.6 Change Band Printing Order 

If your layout contains more than one band of the same type (e.g., three detail bands), TFORMer 
processes them from top to bottom. 

This printing order of bands can be changed: Select the band that you want to move and choose 
Layout ► Band Order from the menu. You can also right-click on the band and then select Band 
Order from the pop-up menu. Alternatively use the keyboard shortcuts Alt+ and Alt+. 

7.3.7 Delete a Band 

Select the band that you want to delete, and then press the Del key. Alternatively click on the  icon 
in the ”Default” toolbar or press the right mouse button and select Delete from the pop-up menu. 

7.3.8 Printing Conditions 

For each band you can specify a printing condition. A printing condition decides at print-time whe-
ther a band is printed or not. 

For more details on printing conditions, please refer to section 12.2. 

7.3.9 Pre- and Post-Evaluations 

For each band you can specify pre-evaluation and post-evaluation expressions. These expressions 
will be evaluated before and after the band is printed. 

For more details on pre- and post-evaluations, please refer to section 12.4. 



 
 

Page 40 of 139 

TFORMer Designer  User Manual  

8 Elements 

8.1 Introduction 

Elements (or graphical design elements) are all sorts of printable shapes like texts, barcodes, lines, 
rectangles, circles and pictures. They are placed on the bands to create the layout. 

8.2 Basic Operations 

8.2.1 Insert an Element 

 
Figure 30: Layout View 

To insert an element (e.g., a barcode) into your layout, first click on the appropriate symbol in the 
toolbar (). Then place the element on one of the bands inside the layout (). You can place 

elements in two different ways: 

 A single mouse click on the worksheet will insert the element with its default size. 

 If you click and drag a frame with the mouse pointer (while holding down the mouse button), 
the element is inserted in the given dimensions upon release of the mouse button. 
Please note that the modifier keys which are described in section 8.2.3 will apply here as 
well. 

 

 Select Elements Select existing elements (or bands) in the layout view. This tool is enabled by default. 

 New Text Create a new text element. 

A text element provides formatted text. The content may consist of static and dynamic 
data (see also section 8.3.1). 

 New Barcode Create a new barcode. 

A barcode encodes the given data in a machine readable form. The content may 
consist of static and dynamic data (see also section 8.3.2). 

 New Line Create a new line. 

 New Rectangle Create a new rectangle. 

 New Rounded-Rectangle Create a new rectangle with rounded corners. 

 New Ellipse Create a new ellipse. 

 New Picture Embed a picture. 

A picture element renders the specified image file. The name of the image file may be 
specified as fixed text or computed (see also section 8.3.3). 

For a list of element properties, please refer to Appendix A.3. 




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8.2.2 Element Selection 

In the layout view you can select elements in various ways: 

 Click with the left mouse button on an element. 
Hold down the Shift key or the Ctrl key for multiple selection. 

 Click with the left mouse button in an empty area of the layout view and (while holding the 
mouse button pressed) drag a selection frame around the required elements. Then release 
the mouse button. Depending on the direction, in which you have dragged the selection 
frame, different selection criteria are used: 

­ Drag frame from left to right: 
Only objects that are entirely overlapped by the frame will be selected. 

­ Drag frame from right to left: 
All objects that are entirely or partially overlapped by the frame will be selected. 

A thin border with small rectangles (= sizing handles) on its corners and on its sides indicates that 
the element is selected. 

► To start a selection frame over an existing graphical element try to hold down the Shift or the 
Ctrl key. This will prevent other elements (which might be under the mouse pointer) from 
being moved. 

8.2.2.1 Examples 

 
Figure 31: Element Selection 

 This element has the mouse focus (bold outline). If you click your left mouse button, it will 
be selected. 

 This element is part of a selection. Because it does not have the selection focus its sizing 
handles are drawn as outline ( ). 

 This element is part of a selection and has the selection focus. This is indicated by solid 
sizing handles ( ).  
If you adjust the size or the alignment of two or more elements (see sections 8.2.10.1 and 
8.2.10.2), the focused element will act as “master”. This means its properties (or property 
changes) will be applied to the rest of the selection. The last element that is added to the 
selection always receives the selection focus.  
You can set the focus within a selection by clicking on the required element. Do NOT hold 
down any modifier keys, like Shift or Ctrl! 



 






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 This element is not selected. 

8.2.3 Change Element Size 

After selecting an element, you can change its size by clicking and dragging the sizing handles. 
While changing the size you can use the following modifier keys: 

Modifier Key Description 

Shift Square/Circle.  
The width and the height of the element are set to the same value. 

Ctrl Centered.  
The element center is maintained. The change is applied with respect to the center. 

Alt Fine positioning.  
Allows a positioning off the grid. (For setting up the grid see section 17.2.3.) 

Alternatively you can also edit the element size in the properties window. 

► Please note: If the selection contains more than one element, all selected elements will be 
resized simultaneously. 

8.2.4 Move an Element 

An element can be moved by clicking and dragging. While dragging you can use the following 
modifier keys: 

Modifier Key Description 

Shift Snap to axis.  
The movement of the element will be restricted to the horizontal and vertical axis. 

Ctrl Copy mode.  
A copy of the original element(s) will be created on the release position. In copy mode the mouse 

pointer changes its shape to .  

Alt Fine positioning.  
Allows a positioning off the grid. (For setting up the grid see section 17.2.3.) 

8.2.5 Element Properties 

To change the properties of a selected object, you can either: 

 Edit the desired properties in the properties window. 

 Use the format toolbar (see section 4.3) to change frequently used settings like font style, 
background color, etc. 

8.2.6 Positioning and Measuring 

The rulers and the status bar assist you with measuring and positioning of inserted elements. 

When entering measurement values manually TFORMer interprets such values as specified in mm 
or in inch (depending on your system settings). For your convenience you may also append com-
mon abbreviations for measurement units (mm, cm, inch, mil) to the numeric input. 

8.2.7 Delete an Element 

You can delete selected elements in various ways: 

 Press the Del key on the keyboard. 

 Right-click on the element. Then select Delete from the pop-up menu. 

 Select Edit ► Delete from the menu. 

 Click the delete symbol  in the toolbar. 
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8.2.8 Printing Conditions 

For each element you can specify a printing condition. A printing condition decides at print-time 
whether the element will be printed or not. For more details, please refer to section 12.2. 

8.2.9 Assign Elements to a Printing Layer 

A printing layer gives you the possibility to use one single printing condition for multiple elements. It 
lets you control whether all elements assigned to this layer are printed or not. 

By default, only one layer (the “Base” layer) is available. Newly created elements are assigned to 
the “Base” layer by default. 

The printing layer does NOT affect the z-order, in which the elements are printed!  

For more details on printing layers, please refer to section 12.3. 

8.2.10 Design Functions for Elements 

These functions simplify the creation of layouts. You can make all selected elements the same size, 
you can adjust the spacing between selected elements, and more. 

The following properties can be adjusted: 

 Alignment 

 Size 

 Z-Order 

 Spacing (horizontal and vertical) 

The design functions are available through the toolbar (see Figure 32) or through the Layout menu. 

 

 
Figure 32: Layout Toolbar 

► When changing the alignment or the size of selected elements, the element with the 
selection focus (see 8.2.2.1, ) acts as master: all selected elements will be changed ac-
cording to its values! 

8.2.10.1 Alignment 

Select at least two elements. Then choose one of the following functions. The element with the 
selection focus acts as master. 

 
Align Left The selected elements will be aligned left. 

Shortcut: Ctrl+ 

 
Align Right The selected elements will be aligned right. 

Shortcut: Ctrl+ 

 Align Bottom The selected elements will be aligned at the bottom. 

Shortcut: Ctrl+ 

 Align Top The selected elements will be aligned at the top. 

Shortcut: Ctrl+ 

 
Align Vertically The selected elements are center-aligned vertically. 

 
Align Horizontally The selected elements are center-aligned horizontally. 

Alignment Size Z-Order Spacing 
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8.2.10.2 Size 

Select at least two elements. Then choose one of the following functions. The element with the 
selection focus acts as master. 

 Make same Width The same width is applied to all selected elements. 

  Make same Height The same height is applied to all selected elements. 

 Make same Size The same size is applied to all selected elements. 

8.2.10.3 Z-Order 

Select at least one element. Then choose one of the following functions. 

 Move to Top The selected elements are moved to the front of all other elements. 

 Move to Bottom The selected elements are moved to the back of all other elements. 

 
Move Up The selected elements are moved up one level. 

 
Move Down The selected elements are moved down one level. 

8.2.10.4 Spacing 

Select at least two elements. Then choose one of the following functions. The element with the 
selection focus acts as master. 

 Make Horizontal Spacing 
Equal 

Ensure equal horizontal spacing between the selected elements. 

 Increase Horizontal 
Spacing 

Increase the horizontal spacing between the selected elements. 

 Decrease Horizontal 
Spacing 

Decrease the horizontal spacing between the selected elements. 

  
Make Vertical Spacing 
Equal 

Ensure equal vertical spacing between the selected elements 

 
Increase Vertical 
Spacing 

Increase the vertical spacing between the selected elements. 

 Decrease Vertical 
Spacing 

Decrease the vertical spacing between the selected elements. 

8.3 Elements with Content 

8.3.1 Text Elements 

Text elements are used for printing formatted text. Single phrases, words and characters can be 
formatted individually. Datafields and expressions can be embedded within the text. 

 
Figure 33: Text Element 

In the example above static and dynamic content is mixed. The embedded expressions for the 
current date [Now ()], the current page number [Page] and the total number of pages [NumPages] 
are placed in-line with the static text. During print-time these expressions will be replaced by the 
actual values automatically. Such dynamically provided content is always displayed between square 
brackets “[]” (see ) or angle brackets “<>”: 


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 Square brackets indicate that the content of the datafield respectively the result of the 
expression will be inserted as is. 

 Angle brackets indicate that the content of the datafield respectively the result of the 
expression will be interpreted as HTML. This allows you to specify dynamic content with 
additional formatting (see also section 9.3.3)! 

For information on how to edit the content of text fields, please refer to chapter 9. 

8.3.2 Barcode Elements 

Barcode elements encode the given data in a machine readable form. 

 
Figure 34: Barcode Elements 

The barcode data can contain static content (e.g., the fixed string “AaBb12”, see ), dynamic con-
tent (e.g., the datafield, see ), or a combination of both. Dynamically provided content is always 

displayed between square brackets “[]”. 

For information on how to edit the barcode data, please refer to chapter 9. 

► Please note: The barcode symbol in the layout view is just a sample. It does not encode the 
actual data! The correct barcode is computed during print-time. 

The Barcode Type and other barcode specific settings are adjusted in the properties window. You 
can choose from 1D, 2D and composite barcode symbologies. Depending on the selected barcode 
type different property groups are available 

For more information on available barcode types and their possible adjustments, please refer to the 
“Barcode Reference” which is available for download on www.tec-it.com. 

8.3.3 Picture Elements 

Picture elements are used to embed images in a layout. Supported image formats are BMP, GIF, 
JPG, PCX, PNG, TGA and TIF. 

 
Figure 35: Picture Elements 

The actual image is usually specified through a fixed file name (see ). If you want to use different 
images for different records (dynamic logos) you can also compute the file name dynamically (e.g., 
based on a datafield value, see ). 

For information on how to edit the image file name, please refer to chapter 9. 

 



http://www.tec-it.com/
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► You can use absolute file names (e.g., “C:\sample.jpg”) or relative file names (e.g., 
“sample.jpg” or “img\sample.jpg”). Relative file names are treated relative to the base path of 
the layout file. 
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9 Element Content 

9.1 General 

All text, barcode and picture elements are filled with specific content. This content can be edited 
using the following dialog. 

When inserting a new element or when double-clicking an existing element the editing dialog will be 
opened automatically. Alternatively select the element and press F2, or right click on the element 
and select Element-Content… from the pop-up menu. 

 
Figure 36: Edit Dialog for Element Contents 

First choose the type of content that you want to assign. The following options are available: 

 Datafield (see 9.2)  

 Formatted Text (for text elements, see 9.3)  
Simple Text (for barcode elements, see 0)  
File (for picture elements, see 9.5) 

 Expression (see 9.6) 

If you want to assign a datafield (dynamic data) with no additional text or whatsoever your choice 
will be option . This option is typically used for output as barcode or as simple text element. 

If you want to assign a fixed text or if you want to combine the content of a datafield with additional 
text, other datafields and/or expressions, your choice will usually be option . This option is the 
standard choice for text elements and barcodes. It can be used for the creation of simple and 
complex contents. 

Option  will be your favorite choice only, if you want to compute the content of an element, based 
on the provided functions, constants and datafields. An example would be use of dynamic picture 
file names. 

Depending on your selection (,  or ) one of the following dialogs is shown: 






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9.2 Datafield 

 
Figure 37: Edit Dialog – Datafield 

If the content of the selected element is supposed to be a datafield, select the Datafield option . 
Then select the desired datafield in list  and confirm with OK. 

The creation of a new datafield is also possible. When double-clicking on “<New Datafield…>” an 
appropriate dialog will be opened (see section 10.2.1.1). 

9.3 Formatted Text (Text Elements) 

  
Figure 38: Edit Dialog – Formatted Text 

If the content of the selected text element is supposed to be a formatted text, select the Formatted 
Text option . You can now edit the text in . The toolbar  may be used to apply different 
formatting (single phrases, words and characters can be formatted individually – see section 9.3.1). 
Using the buttons  and  you can insert datafields and expressions (see section 9.3.2). When 
you are done with editing confirm with OK. 











 
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9.3.1 The Toolbar 

Toolbar  provides the following functions: 

 
Undo Revert the last change. 

Shortcut: Ctrl+Z 

 
Redo Revert the last Undo  

Shortcut: Ctrl+Y 

 
Font Name Select the typeface. 

 
Font Size Select the font size (in points). 

 
Bold Toggle bold text on/off.  

Shortcut: Ctrl+B 

 
Italic Toggle italic text on/off. 

Shortcut: Ctrl+I 

 
Underline Toggle text underline on/off. 

Shortcut: Ctrl+U 

 
Strike Through Toggle text strike through on/off. 

 
Superscript Toggle text superscript on/off. 

 
Subscript Toggle text subscript on/off. 

 
Font Color Select the font color. 

 
Align Left Align the text left.  

This alignment is applied to the whole text element and not for single lines 
or paragraphs. (Same as the Text Alignment property “Top, Left”.)  

 
Center Center the text.  

This property is applied to the whole text element and not for single lines or 
paragraphs. (Same as the Text Alignment property “Top, Center”.) 

 
Align Right Align the text right.  

This alignment is applied to the whole text element and not for single lines 
or paragraphs. (Same as the Text Alignment property “Top, Right”.) 

 Highlight Expressions Highlight all embedded datafields and expressions. 

 
HTML Source TFORMer internally uses a subset of HTML (see Appendix B) for storing 

formatted text. With this button you can toggle between the WYSIWIG view 
and the HTML source view. 

9.3.2 Datafields and Expressions 

In order to provide dynamic content you have the possibility to insert datafields and expressions in 
line with the formatted text. Use the following buttons for inserting. For more information on 
datafields and expressions see chapters 10 and 11. 

 Insert Datafield Opens the dialog Select Datafield (analogous to section 9.2).  
In this dialog select the desired datafield from the list and confirm with OK. 

 Insert 
Expression 

Opens the Expression Builder (see sections 9.6 and 11.2).  
In this dialog compose your desired expression using the available func-
tions, constants and datafields. Then confirm with OK. 

The datafield respectively expression will be inserted at the current cursor position. Datafields and 
expressions are always marked with square brackets “[]” (or angle brackets “<>” in case of HTML 
content – see section 9.3.3): 

Please note: 

► Datafields and expressions must always be inserted using the appropriate buttons! 

► If you try to enter the expression start- and end-markers [] (or <>) via keyboard, the text be-
tween will not be evaluated as an expression! 
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To format an in-line expression (font size, color, etc.) – or rather the text which is returned as result 
– use the format toolbar  as you would do for the rest of the formatted text. For dynamic 
formatting you can also use HTML formatted expressions (see below). 

To edit an existing datafield or expression place the cursor between the square brackets and click 
on the Insert Datafield… or Insert Expression… button. The appropriate dialog will be opened. Alter-
natively you can also double-click on the datafield (or expression) which will always open the ex-
pression builder. 

Hint: The functions Insert Datafield… and Insert Expression… are also available via context menu 

when right clicking inside the text area. 

9.3.3 HTML Formatted Expressions 

In order to provide dynamic text formatting you can use HTML formatted expressions. 

This feature allows you to control the appearance of a text element during print-time. 

If the  button is pushed inside the expression builder (see Figure 49, ), the result of the expres-
sion will be interpreted as HTML content. This means, all supported HTML tags that are found in the 
result of the expression are directly applied. For a list of supported HTML tags, please refer to 
Appendix B. 

 
 

In this example the datafields “ColorOn” and 
“ColorOff” are utilized for dynamic text format-
ting. 

 
 

In order to apply different font colors the ap-
propriate HTML tags (<font color=xxx> and 
</font>) are inserted in the Data window. In 
this case this is done for the first two records. 
The following eight records are printed with 
default formatting (as applied in the Edit Text 
dialog). 

 

 

When printing, TFORMer reads the content 
of the fields in the datasource. The contained 
font tags are directly applied to the output. 
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9.4 Simple Text (Barcode Elements) 

  
Figure 39: Edit Dialog – SimpleText 

If the content of the selected barcode element is supposed to be a simple text, select the Simple 
Text option . You can now edit the text in . Using the buttons  and  you can insert datafields 
and expressions (analogous to section 9.3.2). When you are done with editing confirm with OK. 

The button  turns expression highlighting on or off. 

9.5 File (Picture Elements) 

 
Figure 40: Edit Dialog – File 

If the selected picture element is supposed to show a statically defined image (no different images 
for different records), select the File option . Then specify the file name in  and confirm with OK. 

The button  opens a file selection dialog. 

For dynamically assigned image files use either the option Datafield or Expression. 





 




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9.6 Expression 

 
Figure 41: Edit Text Dialog – Expression 

If the content of the selected element is supposed to be the result of an expression, select the 
Expression option . 

However, the use of pure expressions is only required in special cases (e.g., calculating the file 
names for dynamic picture content). For all common applications it is recommended to use the 
option Datafield or Formatted/Simple Text. Expressions can be embedded in-line with such text 

content. 

For more information on expressions see chapter 11. 


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10 Datafields 

10.1 Introduction 

For providing dynamic content TFORMer uses so called datafields. These datafields serve as 
placeholders for the actual data. They can be used in text, barcode and picture elements (dynamic 
logos). 

A datafield must be defined before it can be used. This definition takes place directly in the layout 
(see below) or in a repository (see chapter 16). One layout can use an arbitrary number of data-
fields (0..n). 

BarcodeText PictureShape

Layout Output Input Data with Datafields

Reference Datafields

in Text, Barcode or Image Elements

(e.g. [ArticleNo])

...

 
Figure 42: Datafields as Part of the Printing Concept 

In the layout TFORMer displays each datafield in square brackets “[]” (or angle brackets “<>” for 
HTML content) – see . The current value of a datafield is available on the print-out only (). The 
value of a datafield is either 

 provided manually (see section 13.3.1), 

 provided by an external datasource (e.g., imported from a database – see section 13.3.2), 

 a serial number (see section 10.3.3), 

 computed per record (see section 10.3.2), 

 computed for specific bands (pre- and post-evaluation – see section 12.4) or 

 provided programmatically by a software developer (see section 15.3). 

If no value was loaded (or computed), the datafield returns its default value (see section 10.3.1), its 
start-value (see section 10.3.3) or zero (see section 10.3.2). 

► In order to provide the data from an external datasource, the datafield has to be bound to the 
required field in the datasource (to the so called sourcefield). Please note: Datafield and 
sourcefield need not necessarily have the same name (see section 13.4). 






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10.2 Basic Operations 

10.2.1 Create Datafield Definitions 

Datafield definitions can be created manually, or they can be imported from a datasource. 

10.2.1.1 Create Datafield Definitions Manually 

To create a datafield definition, the dialog below is used. You can open this dialog using one of the 
following methods: 

 Right-click in the gray area of the layout or on the “Datafields” entry in the design tree and 
select New Datafield… from the pop-up menu. 

 Click on the “New Datafield” icon  in the toolbar. 

 Select Insert ► Data ► Datafield… from the menu. 

 Select Data ►New Datafield… from the menu. 

 

 
Figure 43: New Datafield Dialog 

Depending on its purpose, choose the kind of datafield that you want to create. The following 
options are available: 

 Datafield (see 10.3.1)  
A conventional datafield provides values from a datasource. 

 Computed (see 10.3.2)  
A computed datafield provides values, which are computed via an expression. 

 Serial (see 10.3.3)  
A serial number field provides consecutive numbers. 

 

 

Once the datafield is inserted you will find the appropriate entry in the 
design tree: Normal datafields are listed directly under the branch 
“Datafields” (see ). Computed fields and serials are listed in the corres-
ponding subfolders. 

 

Used datafields are displayed in black (= the datafield is used in the 
layout, within a computation or in a printing condition). Unused datafields 
are displayed in gray. 








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10.2.1.2 Create Datafield Definitions Automatically 

When editing a datasource all datafield definitions can be created automatically (see section 13.4). 
TFORMer suggests to create and assign a new datafield for each field in the datasource which is 
not already used in the current layout (or repository). The data type “Text” is assigned automatically. 

Using this function you can create numerous datafield definitions automatically. All field names 
of an existing datasource are imported. 

10.2.2 Datafield Properties 

The datafield properties can either be edited in the properties window, or in the “Edit Datafield” 
dialog. 

For a description of datafield properties, please refer to sections 10.3 and A.5. 

10.2.3 Use Datafields in Layouts 

Once a datafield was defined it can be used 

 as element content in 

­ text elements – see section 8.3.1, 
­ barcode elements – see section 8.3.2 and 
­ picture elements (dynamic logos) – see section 8.3.3, 

 in control expressions (e.g., printing conditions – see sections 12.2 and 12.3) and 

 in computations (e.g., as operand for additional computed fields – see section 10.3.2). 

10.2.3.1 Element Content 

To assign a datafield as element content use either of these two methods: 

1. Double-click on the element. An edit dialog will be opened (see chapter 9). In this dialog 
select the desired datafield from a list. 

2. Drag and drop the datafield from the design tree to the layout view (see  below). The left or 
the right mouse button may be used for the drag and drop operation. When using the right 
mouse button a few insert options can be selected. 

 

 
Figure 44: Drag and Drop a Datafield 

10.2.4 Edit a Datafield 

To edit an existing datafield double-click it in the design tree. The “Edit Datafield” dialog will appear 
(see section 10.3). Modify the required settings and then confirm with OK. Alternatively use the 

properties window for editing the datafield properties. 


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10.2.5 Rename a Datafield 

To rename a datafield select it in the design tree and thereafter press F2 (or click again on the 
datafield with the left mouse button). Now you can directly edit the datafield name. Alternatively use 
the properties window or the Edit Datafield dialog to rename a datafield. 

► Attention: When renaming a datafield TFORMer will NOT automatically update all referen-
ces to this datafield (e.g., in text elements, pre-/post-evaluations, printing-conditions, …). 
This has to be done manually (see also section 10.4). – Invalid references will throw an error 
and are marked with red color! 

10.2.6 Delete a Datafield 

You can delete a datafield in various ways: Select the datafield in the design tree and press the Del 
key on the keyboard. Alternatively use Delete in the pop-up menu, the delete symbol  in the tool-
bar or Edit ► Delete from the menu. 

► Attention: When deleting a datafield, TFORMer will produce an error in all bands and ele-
ments where the datafield is used (e.g., in text elements, pre-/post-evaluations, printing-
conditions, …). Affected elements are marked with red color (see section 10.4). 

10.3 The Edit Datafield Dialog 

10.3.1 Standard Datafields 

 
Figure 45: Edit Datafield Dialog – Datafield 

If the datafield is supposed to reference the fields in a datasource, select the Datafield option . 

In  enter a name for the datafield. Depending on the field type in your datasource you may adjust 
a suitable type in  (Text, Number, Floating-point). However, for most cases the type “Text” will be 
fine. In  you can specify a default value. This value will always be used if no other value is 
computed respectively provided by the datasource. In  you can add an arbitrary description text. 

► Please note: Before you can use the datafield to access the data from an external data-
source you have to create the necessary field bindings (see section 13.4)! 








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10.3.2 Computed Fields 

 
Figure 46: Edit Datafield Dialog – Computed 

If the datafield is supposed to return the result of a computation, select the Computed option . 

In  enter a name for the datafield. In  select the datafield type. The computed value can either 
be a text, an integer or a floating-point number. The field value is calculated by evaluating the 
expression in . In  you can choose, whether the expression is computed for every record or for 
every record copy. 

Example: 
If you set the expression in  to “NumRecordCopies” the datafield will return the number of copies, 
which is adjusted in the datasource. 

A typical application for computed fields is the aggregation / summation of other datafield values. In 
 you can select one of the following aggregation types: 

Selection Description 

None Do not calculate any sums. 

Running 
Average 

Calculate the arithmetic average for all values within each enclosed region  up to the current record. 
– This means, the expression  is calculated for each record respectively record copy (see ). The 
result is then added to the series of values within region . The datafield provides the average for 
these values. 

Pease note: The average of all(!) records is not available before the last record! 

Running Sum Calculate the sum for all values within each enclosed region  up to the current record. – This 
means, the expression  is calculated for each record respectively record copy (see ). The result is 
then added to the series of values within region . The datafield provides the sum of these values. 

Pease note: The sum of all(!) records is not available before the last record! 

 

► Please note: These functions are only available for numeric data types (integer, floating-
point) and not for text! 

For Running Sums and Running Averages specify the region in which the values shall be evaluated 
(see ): 









  






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Selection Description 

All Do one aggregation within the whole range of the print-job. 

Page Do a separate aggregation within the range of each new page. 

Label Do a separate aggregation within the range of each new label. 

Group Do a separate aggregation within the range of each new group. 

In order to identify the group enter the same condition as for the group header/footer (property “Group 
By”) in field . Whenever the result of the expression changes a new group is started. 

When using a filter in field , single values will only be considered if the expression returns true. 
Thus you can define, which values are considered for the aggregation, and which not. 

In  you can add an arbitrary description text. 

10.3.2.1 Example: Calculate Sum 

In the following example we will summarize all listed prices in a report. The result is printed 
underneath the last detail band. 

 
 
 
 
 

Figure 47: Calculate Sum 

First create a new computed datafield (e.g., “Sum_ArticlePrice”). Set the data type to “Floating-
point” (prices are usually given with decimal digits). As expression enter the name of the datafield, 
that you want to sum up (in this case “ArticlePrice”). Choose the aggregation type “Running Sum” 
and confirm with OK. 

The newly created datafield “Sum_ArticlePrice” can now be used in the layout. Place it in the report 
footer to print the sum underneath the last list item. You can print the sum directly, or you can 
format it. Use the following expression to create a number with up to eight digits before the decimal 
point and exactly two digits after the decimal point: 

[Format (Sum_ArticlePrice, "#######0.00")] 

If you want to, you might also use additional digit grouping: 

[Format (Sum_ArticlePrice, "##,###,##0.00")] 
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10.3.3 Serial Numbers 

 
Figure 48: Edit Datafield Dialog – Serial Number 

If the datafield is supposed to be a serial number calculated by TFORMer, select the Serial option 

. 

In  enter a name for the datafield. In  select the datafield type. A serial number can either be an 
integer or a floating-point number. Enter the start value in  and the increment in . If you want 
TFORMer to remember the last value which was printed you have to select option . In this case 
TFORMer will continue with the next serial number on the next print-out. 

Instead of making TFORMer remember the last serial value you can also provide each starting 

value via an expression (compute it, read it from a datafield). To do this, click button . The 
expression editor will open. 

In field  you can specify, whether the serial number should be incremented for each new 

 Document, 

 Label, 

 Page, 

 Record (default) or 

 Record copy. 

When using an update condition in  the serial number will only be incremented if this condition re-
turns true. 

In  you can add an arbitrary description text. 

After you are done with editing close the dialog with OK. The serial number can now be used in the 
layout. You can print the counter directly, or you can format it. Use the following expression to 
create an eight digit number with leading zeros: 

Format (MySerial, "00000000") 



 


 






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10.4 Faulty Datafield References 

When renaming or deleting a datafield, all references to this datafield will become invalid imme-
diately (e.g., in a text element, in the printing condition of a band, etc.). The concerned bands and 
elements are marked as corrupted in red. In order to fix the problem all broken references have to 
be replaced manually. 

 
 

In this example the datafield ”Quantity”  was 
renamed to “Quantity_renamed”. 

 

The original datafield name is still in use in various 
bands and elements. For this reason some errors 
are displayed (). 

 

When hovering the mouse over one of the red 
objects a short error description is displayed (). 

 
 

 














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11 Expressions 

11.1 Introduction 

Expressions are used for computing element content or controlling output behavior during print-
time. Expressions can be used  

 as dynamic content in text, barcode and image elements (see section 8.3). 

 as printing conditions for bands and graphical elements (see section 12.2). 

 as printing conditions for layers (see section 12.3). 

 for computed fields and serial numbers (see sections 10.3.2 and 10.3.3). 

 for pre- and post-evaluations in bands (see section 12.4). 

 to compute the name of the generated output or spool file (see section 6.3.2). 

 to filter the input data (see section 13.6). 

 

The syntax used by TFORMer is similar to the programming language C. 

Example: 

 
 

This text element contains formatted text. In line 
with the text the expression “Now()” was inserted. It 
will return the current system date. 

Date: 02.05.2009 During print-time the expression is evaluated: 
Instead of [Now()] the current date is printed. 

11.2 Expression Builder 

Expressions are edited using the Expression Builder: 
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Figure 49: Expression Builder 

Field  shows the current expression. To extend the expression in  you can select one of the 
predefined 

 Datafields 
The datafields available in your layout. 

 Constants 
True, False and Linefeed (“\n”). 

 System Datafields 
Datafields that are maintained by TFORMer automatically (the current page number, the 
band name, …) 

 Functions 
Mathematical functions, conversion functions, string manipulation, … 

 Formats 
Common formats for numbers, date and time values. 

 Common Expressions 
Frequently used expressions like page numbering (“Page N of M”), the current date and 
time, currency formatting, … 

First select the category in . Then mark the required item in  and click Insert  (or just double-
click on the list item). The item will be inserted at the actual cursor position in . The text area  
shows additional information on selected items. 

If you click OK the expression will be validated. Only expressions with a correct syntax are accep-

ted. 

A list of all available functions, constants, system datafields, formats and common expressions is 
available in Appendix C. 

For text elements, additionally the  button  is available. When pushed, the evaluated expres-
sion in  will be interpreted as HTML. Thus you can provide additional format specifications within 
the text. HTML-formatted expressions are marked with angle brackets “<>” (see section 9.3.3). 










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11.3 Evaluation Order 

The over-all evaluation order for expressions is defined as follows (see also figure below): 

1. Printing Condition of the band 

2. Pre-Evaluation of the band 
(Can be used for computing datafields) 

3. Printing Conditions of layers 
(These are computed for every band, the results are used later when printing the elements) 

4. Printing Condition of elements in the band 

5. Dynamic contents for elements 

6. Post-Evaluation of the band 

Steps 2 to 6 will only be performed if the band is printed – in other words: if the printing condition of 
the band is true. 

 

Printing 

Condition of 

Band

Printing 

Condition of 

Layer 
Do

Pre-Evaluation(s)

Printing 

Condition of 

Element

Print Element

Do

Post-Evaluation(s)

False

Process Band

Evaluate

Printing Conditions 

of Layers

Unprocessed 

Elements left?

Calculate Dynamic 

Content of Element

Band finished

False 

False

False

True 

True 

True 

Process all Elements of Band

True 

 
Figure 50: Evaluation Order 
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12 Smart Layouts 

12.1 Introduction 

TFORMer offers a number of features, which give you additional flexibility for formatting the output:  

 Printing Conditions 
(Control whether single bands or elements are printed) 

 Printing Layers 
(Assign elements to layers and control the printing of the layers via printing conditions) 

 Pre- and Post-Evaluations 
(Perform computations which are specific to a certain band) 

 Invisible Bands 

(Control special document layout features) 

 Tray Control 
(Switch printer trays – even within a print job!) 

12.2 Printing Conditions 

Printing conditions are used to control the visibility of elements, layers or bands during print-time. 

A printing condition is an expression (see chapter 11) which returns either true or false. Printing 
conditions can be assigned to elements (text elements, lines, …), to entire bands and to printing 
layers (see below). If a printing condition returns false the corresponding object will not be printed. 

► Please note: The result of a printing condition will be converted to the data type ”Integer” 

(numerical value) if required. A value of 0 is interpreted as false. 

12.2.1 Edit a Printing Condition 

 
 

If you want to edit a printing condition first select 
the object (e.g., the page header). Then go to the 
properties window. 

 

 
 

Activate the Control group and click anywhere in  

(or on the  button) to open the Expression Builder 

(see section 11.2). Alternatively use the  icon in 
the toolbar, or right-click on the element and select 
Printing Condition… from the pop-up menu. 

 

Use the Expression Builder to edit the printing 
condition. When you are done confirm with OK. 

 


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12.2.2 Visual Cues for Printing Conditions 

If you have applied a printing condition, the band or the element will be marked with a small red dot: 

 

 

Bands are marked in the layout view and in the 
design tree (). Graphical elements are marked in 
the design tree only (). 

 
 

12.2.3 Examples 

12.2.3.1 Different Headers or Footers 

To print different headers and footers create at least two bands of the same type. Then use the prin-
ting condition to decide which band shall be printed. E.g., create one page header for odd pages 
and one page header for even pages. The expressions “IsOdd(Page)” respectively “IsEven(Page)” 
will serve as printing condition. 

12.2.3.2 Alternating Background Colors  

To print rows with alternating background colors draw a filled rectangle in the background of the 
detail band. Then set the printing condition to “IsOdd(Record)”. 

12.3 Printing Layers 

Printing layers are used to control the visibility of multiple elements with a single printing con-
dition. The printing condition of the layer decides whether all elements assigned to that layer will 

be printed or not. 

By default only one printing layer, the “Base” layer, is defined. Newly inserted design elements are 
always added to this layer. 






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Please note: 

► One element can be assigned to one printing layer only. 

► Layers do NOT influence the z-order of elements! 

► Elements assigned to a printing layer may still use additional element-specific printing condi-
tions. 

12.3.1 Create a New Layer 

You can create a new printing layer using either of the following methods: 

 
 

 Select Insert ► Layer… from the menu. 

 Click on the “Add Layer“ icon  in the 
toolbar. 

 Right-click on the form, on a band, or on the 
“Layers“ entry in the design tree and select 
New Layer… from the pop-up menu. 

 

The “New Layer“ dialog will appear. 

 

In this dialog enter the name (), the color () and 
the printing condition () for the layer. In  you 
can enter an arbitrary description text. 

 

 
 

Once the printing layer is inserted you will find the 
appropriate entry in the design tree (). 

 

For a description of all layer properties, please refer 
to Appendix A.4. 

12.3.2 Assign Design Elements to a Layer 

To assign design elements to a specific layer, perform the following steps: 

 

First select all elements that you want to assign to the printing layer. Then select the layer in . 
Alternatively right-click on the selection and select Assign Layer ► MyLayer from the pop-up menu. 

12.3.3 Display Layer Colors 

If you want to see which design elements are assigned to which layer, you can turn on the display 
of layer colors: 



 










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By default all design elements are displayed in their 
printing color (see left). 

Click on the icon “Toggle Display Color”  in the 
toolbar, or select View ► Layer Colors from the 
menu to change the display mode. 

 

 
 

If the display of layer colors is enabled, all design 
elements are drawn in the color as adjusted in the 
layer properties (see  on page 66). 

Click the  icon again to switch back to normal. 

12.3.4 Hide Layer Contents 

To hide all elements which are assigned to one layer, first select the layer in the design tree and 
then use one of the following methods: 

 Right-click on the layer in the design tree and deselect Visible in the pop-up menu. 

 Double-click on the layer in the design tree. 

 In the properties window go to the Common group and set the property Visible to “False”. 

12.4 Pre-Evaluation and Post-Evaluation 

The pre- and the post-evaluation can be used to compute datafields during print-time. 

With this type of evaluation each band can perform arbitrary computations. You have the choice 
between computations before a band is printed (Pre-Evaluation) and computations after a band was 
printed (Post-Evaluation). If the band is not printed at all (if the printing condition of the band returns 

false), no evaluations are performed. 

Usually pre- and post-evaluations are used for 

 implementing computations which are specific to a band, 

 implementing counters, 

 formatting data prior printing. 

For example, the pre-evaluation in the report header may be used to evaluate one or more expres-

sions at the “beginning” of the report.  

Please note: 

► When assigning a value to a datafield during print-time (computed field, pre-/post-evalua-
tion), this datafield will be excluded from data import. It will no longer be filled with any 
values from the datasource. – A datafield which provides the data from a datasource (which 
is bound to a sourcefield) may therefore never be filled with computed values. Always use a 
separate datafield for computations! 
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12.4.1 Edit Pre- and Post-Evaluations 

 
 

Right-click on the required band and select Pre-
Evaluation… or Post-Evaluation… from the pop-up 
menu. Alternatively use the toolbar icons  and .  

 

The following dialog will appear: 

 

 
 

First select the datafield that you want to compute 
in . Then enter an expression in . Click on the 

 button to open the Expression Builder (see 
section 11.2). 

 

The computations are evaluated in the order as 
they appear in the dialog (from top to bottom). If 
you want to change the computation order or if you 
want to delete a computation, use the buttons in . 

 
 

The Common group in the properties window of the 
band shows all datafields calculated in the pre- 
evaluation . 

The post-evaluation  is empty. No datafields are 
computed. 

12.4.2 Visual Cues for Pre- and Post-Evaluations 

 
 

If you have entered a pre- or a post-evaluation 
expression, the band will be marked with a small 
red sigma symbol in the layout view  and in the 
design tree . 

 

 









 






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12.5 Invisible Bands 

Invisible bands are used to perform computations or to control the output behavior of the layout. 

An invisible band is a band with zero height. It does not contain any graphical elements like text or 
lines, and therefore nothing is being printed. 

Invisible bands can be used for: 

 Computations (pre- and post-evaluation). 
You can initialize a datafield in the report header (at the beginning of the printing process). 

 Feed Control (insert page- or column-breaks, triggered by printing conditions). 

 Tray Control (see section 12.6). 

 

Please note: 

► If the printing condition for the band returns false, it will not be printed. This means, no pre- 
and post-evaluations are performed, no page- or column breaks are inserted and no tray will 
be selected. 

► If the height of the band is not adjustable use the menu File ► Page Setup… to change to 
the layout type Complex. 

12.6 Tray Control 

The tray control is used to select or switch printer trays during print-time. 

For every single page of the output, you can dynamically select a tray on the target printer. This is 
useful for printing the first page of an invoice on a letterhead, or for adding an envelope to a print-
out. You could also print a number of labels, and add a cover sheet which is printed on non-sticky 
paper. In TFORMer all this can be done in one single print-job. The selection of the trays is 

performed during print-time. 

The tray selection works completely device-independent: TFORMer uses logical tray numbers (tray 
1 to tray 10). Thus it is possible to select the trays without having to take care for the actually used 
hardware or printer driver. A tray is always selected by its logical number. 

The mapping of the device-dependent printer trays to the logical tray numbers is done in the Tray 
Mappings. These tray mappings have to be configured beforehand. Then, for each print-job, you 

can select the appropriate mapping. 

Example: 

Assume you are printing one layout on two different printer models (Printer A and Printer B): 

Name Tray Mappings for 
Printer A 

Tray 1 Automatically Select 

Tray 2 Upper Paper Tray 

Tray 3 Manual Paper Feed 

Tray 4 Envelope, Manual Feed 

…  

Tray 10 A4 
 

 
Name Tray Mappings for 

Printer B 

Tray 1 Auto 

Tray 2 Tray 1 

Tray 3 Tray 1 (Manual) 

Tray 4 Envelope Feeder 

…  

Tray 10 A4 
 

The first page of the layout should be printed using the manual paper feed which is named diffe-
rently on both printers (due to different printer drivers). Using the tray mappings as shown above, 
the tray number 3 can be assigned in both cases. When printing, take care to select the appropriate 
tray mapping for the actual output device. 
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The following steps are necessary for tray control: 

 Create and configure the required tray mappings. 

 Perform the tray selection in the band properties. 

 Select the correct tray mapping for printing. 

 

Please note: 

► The “_Default_” tray mapping is always available. 

► You can define as much tray mappings as required (this is useful when printing one layout 
on different printers). 

► When using form names (e.g., A4 or Letter) in the tray mappings, be careful to configure 
your printer drivers correctly. Otherwise the mapping between a form name and the printer 
tray will not work. 

12.6.1 Create a New Tray Mapping 

 

To create a new tray mapping, right-click on the 
folder “Tray Mappings” in the design tree and select 
New Tray Mapping from the pop-up menu (see ). 
A new entry “New_Tray_Mapping_0” will be 
created. 

 

To rename the tray mapping select it in the design 
tree and thereafter press F2 (or click again on the 
item with the left mouse button). Now you can 
directly edit the name. Alternatively use the 
properties window to rename a tray mapping. 

12.6.2 Configure Tray Mappings 

Each tray mapping has ten logical trays which can be filled with device specific physical trays. The 
trays are assigned as follows: 

 
 

Enter the name of the logical tray directly in  or 
select it from the list provided by the printer driver. 

Click on the  button to open the dialog below. 




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First select the target printer in . Then select one 
of the listed items: You can choose a ”Tray Name” 
() or a ”Form Name” (). 

In order to refresh the try list for manually entered 
printer names, use the button . 

 

Click OK to assign the selection. 

12.6.3 Tray Selection in the Layout 

 
 

To select a tray in the layout select the required 
tray number (1 to 10) in the Tray property. 

By default “Tray 0 - (Default)” is pre-selected for 
each band. This means, the settings of the current 
printer driver are used for printing. 

 

► Tray 0 (default) uses the settings of the current printer driver. 

► Tray 1 to 10 can be pre-configured in the tray mappings. 

► The first band that is printed on a page (e.g., the page header) does the tray selection. Tray 

settings of subsequent bands which are printed on the same page are ignored.  

12.6.3.1 Example 

If you want to print the first page of a report on a letterhead, assign the required tray to the report 
header. After the first page you have to switch back to normal paper. Therefore enter the number 
for the default tray in the page header. 

12.6.4 Select the Tray Mappings for Printing 

 
Figure 51: Select Tray Mappings in the Print Dialog 










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On the print dialog choose Advanced Settings . Then select one of the pre-configured tray 

mappings in . For a more information on the print dialog, please refer to chapter 15. 
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13 Providing Data 

13.1 Introduction 

As mentioned in chapter 5 TFORMer requires data in addition to the layout for printing. The follow-

ing datasource types are supported: 

 Manual Datasource  
The default datasource allows you to edit every single data value manually 
(see section 13.3.1). 

 ODBC Datasource 
The data will be imported from an ODBC connection (see section 13.3.3). 

 Flat Text File  
The data will be imported from a text file (CSV, TSV,…) (see section 13.3.4). 

 XML File 
The data will be imported from a XML file (see section 13.3.5). 

 TFORMer SDK API  
This datasource is not selectable in the user interface. The data will be provided program-
matically from outside TFORMer Designer. This method can be used by software deve-
lopers. For details see section 15.3. 

 

► For each layout you can create multiple datasources and switch between them as required. 
So you have the possibility to print one single layout with data from different datasources 
without modifying the layout. 

13.2 The Data View 

For managing datasources TFORMer offers a separate view, the data view. In the data view you 

can… 

 inspect the data which is provided by the currently selected datasource, 

 create, edit, rename and delete datasources, 

 switch between different datasources, 

 reload a datasource, 

 set parameters for a datasource, 

 bind sourcefields (the fields provided by a datasource) to datafields (the placeholders, which 
are used in the layout), 

 and apply a filter to the current datasource. 

To switch to the data view click on the ”Data” tab  at the bottom of the application window (see 
Figure 52 below) or select Data ► Data View from the menu. Alternatively press the keyboard 
shortcut Ctrl+D. 
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Figure 52: Data View 

The data view is divided into the following areas: 

 Datasource Selection 

 Data Grid  

 Record Navigation 

 Data Toolbar 

In the drop-down list  you can set the active datasource or you can create new datasources (see 
section 13.3.2). By default, the manual datasource is selected. This datasource is used for entering 
data within TFORMer directly. 

The design tree  gives you an overview over all available datasources. The active datasource is 
displayed in bold. Right click on a datasource to open the context menu. The context menu allows 
you to perform various operations on a datasource (e.g., set it as active datasource). 

The data grid  shows the data which is provided by the active datasource. The grid is divided into 
rows and columns. The rows represent the data records, the columns represent the datafields 
(ArticleName, ArticleNo etc…). 

The first column in the data grid is the “Copies” column. This column is always available. It tells 
TFORMer how often each single record should be printed. 

The datafield columns are ordered alphabetically by default. Using the datafield property “Display 
Order” (see section A.5) a custom display order can be specified. 

The record navigation  allows you to navigate to the next, previous, first or last record, or to a spe-
cific data record directly. 

The data toolbar  provides the following functions for manipulating datasources: 















 
 

Page 75 of 139 

TFORMer Designer  User Manual  

 Refresh Reload the current data. 

 New Datafield Insert a new datafield. 

 New Datasource Create a new datasource. 

 New Source-Parameter Create a new source-parameter. 

 Edit Datasource Edit the datasource. 

 Edit Source-Parameter Edit the source-parameters. 

 Edit Filter Edit the current filter expression. 

 Apply Filter Apply the current filter expression.  

 

► TFORMer Designer always uses the active datasource for printing. 

► TFORMer Designer only prints the records which are shown in the data grid. This is usually 
the content of the active datasource, but the number of records may be reduced by a filter 
(see section 13.6). 

► Sorting the records in the data grid is not supported. If the printing order has to be changed, 
please re-arrange the records manually or adjust the appropriate datasource definition (e.g., 
by inserting an ORDER BY instruction in the SQL statement). 

13.3 Datasources 

13.3.1 Manual Datasource (Default) 

For each layout TFORMer provides a manual datasource (see ). This datasource is always avail-
able. It allows you to enter the required data directly into the data grid. 

 
Figure 53: Edit Data Manually 

To insert a new record move the cursor to the last data row  (which is marked with a ” *“), enter 
the required data and confirm with enter. If a default value was assigned to a datafield, this default 
value is displayed as gray text (see ). It will be used, if no other value is entered. 

To change an existing value in the data grid, select the required cell with the mouse and press F2 
(or double-click on the cell). This allows you to place the cursor at the required position inside the 
cell and to edit the content. 

A new line within a cell is inserted by pressing Ctrl+Enter. Please note that this line break is not 

visualized in the data grid view. Though, it will be inserted on the print-out. 

To select a row click on the record number in the first column “#”. It is possible to select more than 
one row by holding down the Shift or the Ctrl key. The selection can be deleted (press the Del key) 
or it can be copied and pasted into any of the other rows (Ctrl+C and Ctrl+V). 

► Only the manual datasource allows you to edit the data within TFORMer Designer directly. 

For all other datasources (ODBC, flat text files and XML) the data grid is read-only. 





 


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► Read-only cells are marked with gray background color. 

► Inserting new records is only possible in the last row . You cannot perform an insert opera-
tion between two existing rows. 

If required, you can create a new datafield by using the toolbar icon  or by clicking in the column 
<New Datafield…> . 

 For the manual datasource the content of the new datafield can be edited immediately. 

 When using an external datasource (e.g., ODBC) you need to provide the content for the 
new datafield via sourcefield binding (see section 13.4). 

 

► The field “Copies”  is not an actual datafield. It is used to determine how often a record is 

printed in the output. 

13.3.2 External Datasources 

In addition to the manual datasource you can specify one or more of the following external data-
sources: 

 ODBC Datasource (see section 13.3.3) 

 Flat Text File (CSV, TSV, …) (see section 13.3.4) 

 XML File (see section 13.3.5) 

For managing these datasources use the operations described below: 

13.3.2.1 Create a New Datasource 

 

 

Create a new datasource using either of the 
following methods: 

 

 Select <Create New Datasource…> 
from the drop-down list . 

 Right-click on the “Datasources“ entry 
in the design tree and select New 
Datasource… from the pop-up menu 
. 

 Click on the “New Datasource” icon 
 in the data toolbar. 

 
 

The dialog “New Datasource“ will appear: 






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Choose one of the available datasource 
types in . Specify a name () and an op-
tional description () for the datasource. 
Then confirm with OK. 

 

A dialog for setting up the respective data-
source will appear. Setting up the different 
types of datasources is described in sections 
13.3.3 to 13.3.5. Additional adjustments 
(which apply to all of these datasources) are 
discussed subsequently in sections Fehler! 
Verweisquelle konnte nicht gefunden 
werden. to 13.6. 

 

Once the datasource is inserted and set up 
you will find an appropriate entry in the 
design tree. 

A newly created datasource is set as the 
active datasource automatically. 

13.3.2.2 Loading Data and Progress Bar 

For all external datasources TFORMer caches the data locally in order to provide a stable set of 
data for printing (you see the cached data in the data view). This means that the datasource is 
read completely, before a print-job or the rendering of the print preview is started.  

Whenever a new datasource is created or when switching to an existing datasource (see sections 
13.3.2.1 and 13.3.2.6) the data from this source is read automatically. However, it is also possible to 
manually force the reloading of the data (see section 13.3.2.7). 

For large amounts of data, sometimes the loading may take several minutes. While loading the 
records TFORMer displays a progress bar: 

 
 

This bar shows you the progress of the loading 
operation. 

 

By clicking Cancel you have the possibility to cancel 
the operation: 

 

Yes aborts loading immediately. All data read so far 
is kept in the data cache. This results in an incomp-
lete data cache. Note  below will be displayed at 
the bottom of the data view or preview. 

 

No aborts loading immediately. All data read so far is 
discarded. This results in an empty data cache. Note 
 below will be displayed at the bottom of the data 
view or preview. 

 

Cancel continues loading. 

 











 
 

Page 78 of 139 

TFORMer Designer  User Manual  

 

13.3.2.3 Edit a Datasource 

To edit an existing datasource, open the “Edit Datasource” dialog using either of the following 
methods: 

 Click on the “Edit Datasource” icon  in the toolbar or use Data ► Edit Datasource… from 
the menu (only available in the data view and in the preview). 

 Right-click on the datasource entry in the design tree and select Edit Datasource … from the 
context menu. 

 Select the appropriate datasource from the drop-down list in the data view and click the 
Edit… button. 

13.3.2.4 Rename a Datasource 

To rename a datasource select it in the design tree and thereafter press F2 (or click again on the 
datasource with the left mouse button). Now you can directly edit the datasource name. Alterna-
tively use the properties window to rename a datasource. 

13.3.2.5 Delete a Datasource 

Datasources can be deleted in various ways: 

 Select the datasource in the design tree and press the Del key. 

 Select the datasource and press the delete symbol  in the toolbar or choose Edit ► Delete 
from the menu. 

 Right-click the datasource and select Delete from the context menu. 

13.3.2.6 Switch between Datasources 

To switch to the required datasource the following methods can be used: 

 Use the drop-down list to switch to the appropriate datasource (see Figure 52, ). 

 Right click on the appropriate datasource in the design tree and select Set as Active 
Datasource in the context menu. 

13.3.2.7 Reload a Datasource 

You can refresh the cached data any time by pressing the  icon in the data toolbar or by pressing 
the Reload button in the data view. 


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13.3.3 ODBC Datasource 

ODBC datasources are used to retrieve data from a database (Microsoft Access, SQL Server, 
Oracle,…). Each database with a suitable ODBC driver is supported. On Microsoft Windows the 
drivers for Microsoft Access and SQL Server are pre-installed. For more information on how to 
install additional ODBC drivers please refer to the documentation of the database system in 
question. 

13.3.3.1 DSN (Database Selection) 

In the DSN tab specify the ODBC connection: 

 
Figure 54: Data Source (DSN) 

 Data Source (DSN)  
Enter the connection string which identifies your required ODBC connection. You can select 
from a list of available datasources as defined under Microsoft Windows (Control Panel ► 

Administrative Tools ► Data Sources (ODBC)) by pressing the button . Or you can enter 

the string manually by pressing the button . 

 Username 

Enter a username for the database connection by pressing the button . 

 Password  

Enter a password for the database connection by pressing the button . 

 Test Connection  
Use this button to test the connection settings. 

 

► For advanced users: With the help of expressions and source-parameters you have the 
possibility to build dynamic connection strings (e.g., use a variable data source (DSN), user 

name and/or password). First open the expression builder for ,  or  by clicking the  
button, then use the corresponding button Insert Source-Parameter… or Insert Expres-
sion…. For details on expressions and source-parameters see chapter 11 and section 

13.5.2. 








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13.3.3.2 SQL-Query 

In the SQL-Query tab you specify the SELECT statement for fetching the data:  

 
Figure 55: SQL-Query 

 Available Tables 
This window lists all available tables for the ODBC connection specified in the DSN tab.  

 SELECT Query  
The SQL query is used for data selection. This statement can be typed manually. Alterna-
tively you can also generate a “Select *” statement by double-clicking on the table name in 
 (or by selecting the table and clicking on the button ). 

 Preview 
A preview of the selected data is displayed. To update this preview press the button . 

 

► For advanced users: With the help of expressions and source-parameters you have the 
possibility to build a dynamic SQL SELECT statement. First place the cursor in  on the 
required text position, then use the Insert button  to insert an expression or a source-
parameter. For details on expressions and source-parameters see chapter 11 and section 
13.5.2. 

13.3.3.3 Field Bindings 

To complete the setup of the datasource adjust the required field bindings (see section 13.4). 



 







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13.3.4 Flat Text Files (CSV, TSV, …) 

Text file datasources are used to retrieve data from a file (CSV, TSV, …). 

13.3.4.1 File 

In the File tab specify the text file to be loaded: 

 
Figure 56: File Datasource 

 File  
Enter the name of the file which you want to use as datasource. You can select a file by 

pressing the button  or you can enter the file path manually by clicking the button . 

 Field separator  
The field separator specifies the character used to separate the fields in the text file. Select a 
predefined separator character from the list or enter a custom separator character. 

 Text qualifier  
The text qualifier specifies the character which is used to enclose data values in the file 
(e.g., data values may be enclosed in quotes). This may sometimes be necessary to 
differentiate field values from the separator character. Select a predefined text qualifier cha-
racter from the list or enter a custom character. 

 First line contains column names  
Specify whether the first line in the text file contains the column names or not. If selected 
TFORMer does not treat data in the first line as data values. Instead these names are used 
as the names of the sourcefields. 

 Preview  
A preview of the datasource values is displayed. 

 

► For advanced users: With the help of expressions and source-parameters you have the 
possibility to build a dynamic file path and/or file name. First open the edit dialog for  by 

clicking the  button, then use the corresponding button Insert Source-Parameter… or 
Insert Expression….. For details on expressions and source-parameters see chapter 11 and 

section 13.5.2. 



 



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13.3.4.2 Field Bindings 

To complete the setup of the datasource adjust the required field bindings (see section 13.4). 

13.3.5 XML File 

XML file datasources are used to retrieve data from a well-formed XML file. In addition to the XML 
file you can specify an optional transformation file (XSLT file). This file may be used to transform a 
custom XML file into a structure accepted by TFORMer. 

13.3.5.1 File 

 
Figure 57: XML Datasource 

 File  
Select the XML file which you want to use as datasource. You can select a file by pressing 

the button  or you can enter the file path manually by clicking the button . 

 Optional transformation file (.xslt)  
Select an optional transformation file which should be applied to the XML file. Select the 

XSLT file via  or enter the file path manually by clicking the button . 

 Test Connection  
Use this button to check if the XML file exists and if the transformation was successful. 

 

► For advanced users: With the help of expressions and source-parameters you have the 
possibility to build a dynamic file path and/or file name for the XML file and for the XSLT file. 

First open the edit dialog for  or  by clicking the  button, then use the corresponding 
button Insert Source-Parameter… or Insert Expression….. For details on expressions and 
source-parameters see chapter 11 and section 13.5.2. 

13.3.5.2 Field Bindings 

To complete the setup of the datasource adjust the required field bindings (see section 13.4). 






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13.4 Field Bindings 

Whenever you edit an external datasource it is essential to specify the field bindings. In this step 
you associate the required sourcefields of the external datasource with datafields. Only datafields 
can be used as placeholders within text boxes, barcodes, images etc. Sourcefields are not directly 
available in the layout. 

► All sourcefields that you want to use in the layout must be bound to datafields. 

To edit the field bindings switch to the Field Bindings tab in the “Edit Datasource” dialog. There you 
see all available sourcefields and their datafield bindings. Directly after the creation of a new data-
source no bindings are specified by default. 

 
Figure 58: Field Bindings Settings 

 Sourcefields  
This list shows all available sourcefields and their assigned datafields. One sourcefield can 
be associated with one or more datafields. Using the buttons in  the field bindings can be 
edited or deleted: 

­ Edit 
This button opens dialog . In this dialog select one or more datafields, which you want to 
bind to the selected sourcefield.  

­ Delete 
This button deletes the bindings for the selected sourcefield. Alternatively press the Del 
key on the keyboard. 

­ Auto 
This button is used to create field bindings automatically. It binds all sourcefields to 
existing, equally named datafields. If no appropriate datafield exists, TFORMer prompts 
you, if you want to create a new datafield with a suitable name. 

­ New Datafield 
This button creates a new datafield. A newly created datafield is automatically bound to 
the currently selected sourcefield. 









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 Sourcefield for number of copies  
The drop-down list  specifies which sourcefield is used as “Copies” column. This column 
specifies how often each record is printed. If no sourcefield is specified, TFORMer prints 
each record once. 

 Escape sequences  
This option tells TFORMer whether escape sequences should be translated or not. An 
escape sequence is an in-text placeholder for special characters. It always starts with a 
backslash (“\”) followed by a character or character code. 
Example: The escape sequence “\n” is a placeholder for a newline character. 

 

► Please note: If escape sequences are activated you must use the sequence “\\” in the data-
source to encode a single backslash “\”! 

13.5 Advanced Options 

When enabling the Show Advanced Options checkbox at bottom of the “Edit Datasource” dialog the 

following additional tabs will be shown: 

 Computed Fields (see section 13.5.1) 

 Source-Parameters  (see section 13.5.2) 

13.5.1 Computed Fields 

A computed field adds an additional column to a datasource. The content of this column is either 
specified as a constant value or it is computed using an arbitrary expression. In the expression you 
may refer to other sourcefields and computed fields as basis for calculation. 

The usual purpose of a computed field is to compute values which are based on sourcefields or 
other computed fields. For example, you might convert the content of an existing sourcefield to 
uppercase, or remove leading and trailing spaces. You can also concatenate multiple sourcefields 
into a single sourcefield. Or you can perform numerical computations (e.g., add the Value Added 
Tax, VAT). For examples, see section 13.5.1.1.1. 

In addition, computed fields support aggregation functions. Thus it is pretty simple to calculate run-
ning sums and averages which are not directly available as fields in the datasource. However, 
please note: If the aggregation value is not necessarily required as sourcefield, you may also 
calculate it via a computed datafield in the layout (see section 10.3.2).  
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Figure 59: Computed Fields 

 Computed Fields  
The list of computed fields is empty by default. Use the buttons in  to create, edit and 
delete computed fields: 

­ New… 
Create a new computed field (see next section). 

­ Edit… 
Edit the computed field which is selected in . 

­ Delete 
Delete the computed field which is selected in  

 Computation Order 
TFORMer computes the fields from top to bottom (as listed in ). To change this computa-
tion order use the buttons in . Setting the correct computation order is essential if compu-
ted fields depend on each other. 

­ Up 
Move the selected item up one position. 

­ Down 
Move the selected item down one position. 

 

► After a computed field was created, it is treated exactly like every other sourcefield. It has to 
be bound to a datafield before it can be used in the layout (see section 13.4). 

► Computed fields are not available in the manual datasource. 

13.5.1.1 Create a Computed Field 

When clicking the New… button the following dialog will appear: 





 
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In  you specify a name for the computed 
field. The name is used to identify the field. 
It has to be unique within the datasource. 

 

In  an optional comment can be entered. 

 

The expression in  provides the values for 
the computed field. You can enter the 
expression directly or you can open the 

expression builder by pressing button . 
For details see section 13.5.1.1.1. 

 

The aggregation function  allows you to 
build running sums and running averages. 
For details see section 13.5.1.1.2. 

 

The filter expression  can be used to ex-
clude records from the computation. For 
details see section 13.5.1.1.3. 

13.5.1.1.1 Expression 

 

The expression in  specifies the content of the computed field. This expression may return a 
constant value (e.g., to simulate a sourcefield which is not available in the current datasource), or it 
can perform arbitrary computations. 

The expression can be entered directly in , or you can open the expression builder by pressing 

the  button. For more information about the expression builder, please refer to section 11.2. 

Common applications are: 

 Modify a sourcefield (convert it to uppercase, remove leading and trailing spaces, …). 
Example: Trim (GetDSField("ArticleName")) 

 Concatenate multiple sourcefields into a single sourcefield. 
Example: "Group:" + GetDSField("ProductGroup") + "Desc: " + GetDSField("Description") 

 Perform computations based on a sourcefield (like evaluating the Value Added Tax, VAT). 
Example: GetDSField("UnitPrice") * 0.2 

 










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Figure 60: Example of an expression for a computed field 

► To access a sourcefield from within an expression use the function GetDSField(“Sourcefield-
Name”). 

► Accessing datafields is not possible. 

13.5.1.1.2 Aggregation 

For more advanced applications (like computing totals for the whole report) TFORMer supports 
aggregation functions. The following aggregation methods are available. You can choose from the 
drop-down list . 

 None (default) No aggregation function is used. 

 Running Average TFORMer computes the mean value of all expression results up to the current record. For the 
first record the running average is the value itself. For the fifth record the running average is the 
average of the first five records. 

Example: 
If you want to provide the running average for the sourcefield “ArticlePrice”, use   
Expression: GetDSField(“ArticlePrice”)  
Aggregation: Running Average 

 Running Sum TFORMer computes the sum of all expression results up to the current record. For the first 
record the running sum is the value itself. For all subsequent records the values are added. 

Example: 
If you want to provide a serial number which is incremented by “1” for each record, use  
Expression: 1  
Aggregation: Running Sum 

13.5.1.1.3 Aggregation Filter 

When using a filter in field , single values will only be considered if the expression returns true. 
Thus you can define, which values are considered for the aggregation, and which not. 

Example: 

GetDSField("ArticlePrice") > 100 

This filter instructs TFORMer to consider only records where the “ArticlePrice” is greater than 100. 
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13.5.2 Source-Parameters 

Source-parameters provide a possibility to implement dynamic datasource definitions. Thus you do 
not have to change the datasource definition each time for fetching different data. Source-
parameters can be used to parameterize ODBC datasources and file-based datasources. Besides, 
they can be used in computed fields. 

One good example for the use of source-parameters is to insert them in the SQL SELECT state-
ment of an ODBC datasource. Thus the user (or developer) has the possibility to instruct TFORMer 

to fetch only specific records or to change the sorting order per parameter. 

Using source-parameters requires the following steps: 

 Create the source-parameter (see section 13.5.2.1) 

 Assign the source-parameter (see section 13.5.2.2) 

 Set a value for the source-parameter (see section 13.5.2.3) 

In the following sections we demonstrate the use of source-parameters by means of the picking list 
example as included in the TFORMer setup. Please note: This sample already includes all the 
adjustments as described below! To open the sample select File ► New Form… from the menu. 
Then open the folder “(6) Samples” and select “Picking List”. 

13.5.2.1 Create a Source-Parameter 

To create a new source-parameter use one of the following methods: 

Select the datasource in the design tree and click on the “New Source-Parameter” icon  in the 
data toolbar or select Data ► New Source-Parameter… from the menu. Alternatively right-click on 
datasource in the design tree and select New Source-Parameter… from the pop-up menu. A third 
method is to open the “Edit Datasource” dialog and then click on the New… button in the source-

parameter tab. 

The following dialog will appear: 

 

In  enter the name for the source para-
meter. 

 

The Default Value  is used to initialize 
the source-parameter after the layout was 
loaded. 

 

In  you may enter an optional descrip-
tion. 

13.5.2.2 Assign the Source-Parameter 

Now that you have created a source-parameter it can be used 

 as placeholder in an ODBC datasource (in the DSN, username, password and SQL 
SELECT statement), 

 as placeholder in a file-based datasource (in the file name and file path), 

 in computed fields. 








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In this example we use the source-parameter to parameterize the SELECT Query in an ODBC 
datasource. Assuming the ODBC datasource is already created (see also sections 13.3.2 and 
13.3.3), open the “Edit Datasource” dialog (e.g., by double clicking the datasource in the design 
tree) and switch to the SQL-Query tab. 

 
Figure 61: SQL-Query tab 

To insert a source-parameter in the SQL query place the cursor on the required position in  and 
then click on  Insert ► Source-Parameter…. The following dialog will appear: 

 
Figure 62: Select a Source-Parameter 

Select the required source-parameter and confirm with OK. 

In this case the source-parameter “PickingListParameter” will be used in the WHERE clause of the 
SQL query to retrieve the data for a specific picking list only. When TFORMer is fetching data from 
the datasource the expression [GetDSParam(“PickingListParameter”)] is substituted with the actual 
value of the source-parameter. Thus, the resulting SQL SELECT fetches only records from the 
database which match the specified picking list number. 

E.g., if the “PickingListParameter” is set to 1, the SQL Query 

SELECT * FROM tbl_PickingList WHERE PickingListNo = [GetDSParam("PickingListParameter")] 

will internally be evaluated as: 




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SELECT * FROM tbl_PickingList WHERE PickingListNo = 1 

13.5.2.3 Set a Value for the Source-Parameter 

For correct substitution of the source-parameters you have to assign the required parameter values. 

Therefore click on the “Edit Source-Parameter” icon  in the toolbar or select Data ► Edit Source-
Parameter… from the menu. Alternatively you can also click on the button Parameter… in the 
design view or right-click on the datasource entry in the design tree and select Edit Source-Para-
meter… from the pop-up menu. The following dialog will appear: 

 
Figure 63: Edit a Source-Parameter Value 

Enter the required value for the source-parameter in . Then confirm with OK. 

Using the settings as shown above, TFORMer will only fetch records where the PickingListNo is 
equal to ‘1’. 

 
Figure 64: Data for PickingListNo = 1 

Changing the source-parameter to ‘2’ results in different data: 

 
Figure 65: Data for PickingListNo = 2 


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► Source-parameters can also be used by software developers via the API or with the com-
mand line utility TFPrint. Please refer to the appropriate documentation for details. 

13.6 Filter 

The filter is used to limit the records in the active datasource. The filter criterion is specified with a 
Boolean expression (see also chapter 11): Only records for which the filter expression returns true 
remain visible in the data view. All other records are masked out. Masked out records are neither 
used for the preview nor for printing. 

The filter functions are available in the data view and in the preview. 

This section covers the following topics: 

 Create a filter (see section 13.6.1) 

 Apply a filter (see section 13.6.2) 

 Print with a filter (see section 13.6.3) 

13.6.1 Create a Filter 

To create a filter select Data ► Edit Filter… from the menu or click on the  icon in the data toolbar. 
Alternatively use the button Filter… in the data view. 

 
Figure 66: Edit a Filter 

In the appearing dialog enter the required expression in . Then confirm with OK. The filter will be 
applied to the current datasource automatically. An active filter can be identified by the activated 

filter icon  in the toolbar. 

Example: 
When using the filter expression below, only records with an ArticlePrice greater than 100 will be 
printed. 

CLng(ArticlePrice) > 100 


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13.6.2 Apply a Filter 

To apply or to cancel a previously defined filter click on the  icon in the data toolbar or select Data 
► Apply Filter from the menu. 

13.6.3 Print with a Filter 

To start the printing process press Ctrl+P or select File ► Print… from the menu. The dialog below 

will appear. On the printing dialog select the required printer, the datasource, etc. 

 

If you have already adjusted the filter in 
the data view or in the print preview, no 
additional adjustments are required. 
However, you have the possibility to 

 enable/disable () or to 

 modify () 

the current filter expression . 

 

To edit the filter expression click on the 

button . The expression builder (see 
section 11.2) will open. 

 

Confirm with Print to start printing. 

For general information on printing, please refer to chapter 15. 

Example: 

For the following screenshot we use the picking list example (File ► New Form… ► (6) Samples ► 
Picking List). To print only items in the product group “HARD DISC” use the following filter expres-

sion: 

ProductGroup = "HARD DISC" 

TFORMer will only print data records where the content of the field ProductGroup is equal to the 

string “HARD DISC”: 

 
Figure 67: Picking List, filtered for ProductGroup = ”HARD DISC” 

  
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14 Preview 

14.1 Introduction 

TFORMer offers a preview which instantly renders the resulting output using the current layout and 

the active datasource. This view offers functions for page navigation, filtering the data, and more. 

 
Figure 68: Preview 

To switch to the preview click on the Preview tab . Alternatively press Ctrl+Space or select File ► 
Preview respectively View ► Preview from the menu. 

14.2 Page Navigation 

The page navigation  allows you to zoom, to switch between single page or double-page preview, 
to show/hide label boundaries, to navigate between pages and to directly jump to a user-defined 
page. 

14.3 Additional Functions 

Most functions, which are available in the data view (apply a filter, change a source-parameter, 
switch the datasource) can also be applied in the preview (see ). The result is displayed imme-
diately. 

► Please note: When applying a filter (see section 13.6) or when switching between data-
sources (see section 13.3.2.6), TFORMer reloads the data. This ensures that the most 

actual data is used. 






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15 Printing 

15.1 Introduction 

The term printing in the context of this document incorporates generating output in general. 

Besides direct printing (via a printer-driver in Microsoft Windows), TFORMer also supports the 
creation of PDF documents, HTML files, PostScript files, images, ZPL-II output (for ZEBRA printers) 
and ASCII output. 

All output formats are generated directly. There is no need for third party software. This might 
particularly be interesting for PostScript or ZEBRA output (see below). 

15.2 Printing Manually 

To open the print dialog press Ctrl+P or select File ► Print… from the menu. The following dialog 

will appear: 

  
Figure 69: Print Dialog (with Advanced Settings enabled) 

In this dialog specify all output parameters as discussed below. When finished click Print to send 
the job to the printer (or to create the output file). 

15.2.1 Output Format and Device 

 Output to Selects the output device respectively format: 

 Printer (via a printer driver) 

 PDF 

 PostScript 

 HTML 

 Text (pure ASCII) 

 BMP, GIF, JPG, PCX, PNG, TGA, TIF or multipage TIF 

 ZEBRA (ZPL-II) 

 Printer Depending on your selection in  you can select one of the Windows printers and/or 
the target file. 

 





 












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15.2.1.1 Printing on PostScript and ZEBRA printers 

TFORMer generates PostScript or ZEBRA output directly. This means that you can use such 
printers without any proprietary printer driver – you have two options: 

 Print via a generic ASCII printer driver 

 Print via a PostScript or ZEBRA driver 

In both cases the printer driver is used to send the data which was generated by TFORMer to the 
required device (comparable to pass through mode). No driver functionality is used. 

15.2.2 Pages 

 Pages Here you specify the range of output pages. 

Examples: 

 All (prints all pages) 

 From: “1” to: “1” (prints the first page only). 

15.2.3 Copies 

 Copies Specifies the number of copies. 

Collate If enabled, always the complete range of pages will be printed at once (one complete 
printout for each copy). 

If disabled, all copies of the first page are printed, then all copies of the second page 
are printed, and so on. 

Simulate Copies If enabled, the number of copies is not passed as printer commend but each page is 
repeatedly sent to the printer. 

Choose this option if the printer driver does not support copies. 

15.2.4 Data 

 Datasource Select the datasource to be used for printing. 

Please note: Before printing TFORMer always reloads the data from the adjusted 
datasource. This guarantees that the actual data is used. 

 Filter Here you can optionally apply a filter expression. If a filter is set, only the records for 
which the filter expression returns true are printed. All other records are ignored. In 
order to apply the filter the checkbox “Filter” must be activated. 

Examples for filter expressions: 

 Record <= 3  

Prints the first three data records only. 

 ProductGroup = "HARD DISC"  

Prints only data records, where the datafield “ProductGroup” has the value “HARD 
DISC”. 

For a more detailed example see also section 13.6.3. 

 Save serial values after 
printing 

If you are using TFORMer for generating persistent serial numbers (see section 
10.3.3, ), you can use this checkbox to suspend the saving for the current print-out 
(e.g., for a test print). 

If enabled (=default), TFORMer will remember the values from the current print-out 
and it will continue with the first unused number when printing the next time. 

15.2.5 Additional Settings 

 Tray Mapping Here you can select one of the predefined tray mappings (see also section 12.6). If 
you want to print on the default printer tray, this selection is obsolete. 

 SDK Options Here you can enter additional TFORMer SDK options (e.g., printing offset, …). For 
more detailed information, please contact TEC-IT. 

 Start Row, 

Start Column 

For label printing the “Start Row” and the “Start Column“ can be specified. Use this 
setting if you want to leave the first labels on the sheet blank. 

Example: 

 Start Row=2 

 Start Column=0 
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Columns

R
o

w
s

 

Print order “Down, 
then Across:. The 
first two labels in 
the left column will 
be left empty. 

Columns

R
o

w
s

 

Print order 
“Across, then 
Down”: The first 
two rows will be 
left empty. 

15.3 Printing Programmatically 

Software developers can print layouts created with TFORMer Designer as part of their applications 
using TFORMer SDK. 

TFORMer SDK is available for Microsoft Windows and for almost all Linux and UNIX platforms. 
The following kinds of integration are possible: 

 Command line based printing application (TFPrint)  

 Software component (DLL, COM component, .NET component and shared library)  

For details, please refer to the Developer Manual or to the API References of the TFORMer SDK. 
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16 Repositories 

16.1 Introduction 

TFORMer offers two different possibilities for organizing layouts: 

16.1.1 Stand-Alone Forms 

► Stand-alone forms are the simplest way to create and to print layouts. Each stand-alone 
form designed with TFORMer can be used on its own. 

A stand-alone form contains all the necessary information which is required for printing. Images are 
not embedded but stored as file references. As long as no repository is used, TFORMer always 
creates stand-alone forms when selecting File ► New Form… from the menu. 

A stand-alone form is using the file extension *.tff. Organizing multiple stand-alone forms in the file 

system is completely up to the user. 

16.1.2 Repositories 

If you prefer to organize your layouts and datafields in a structured way or if you plan to create 
multiple layouts which share the same data basis (same datafields) the use of a so-called repository 
is recommended. A repository is a central database for layouts, datasources, datafield definitions 
and tray mappings. 

Layouts and datafield definitions are stored within a repository on a per “Project” base. A project 
defines datafields and holds (better: references) layouts. Each of the datafields defined in a project 
is accessible within every layout contained in that project. A repository can contain multiple projects 
and one special global project. Datasources and datafields which are defined within the global 
project (global datasources and datafields) may be used by all layouts in all projects. 

► A repository is used for organizing multiple layouts within a structured data base. A reposi-
tory holds tray mappings and is divided into projects. A project stores datasources, datafield 
definitions and references layouts. 

A repository is stored with the file extension .tfr. All projects are stored in subdirectories. Please, 

take care to maintain this directory structure. Do not change it manually! 
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In a repository you will find the following entries: 

 Tray Mappings  
These tray mappings are available for all 
layouts in all projects. 

 Global Datasources  
These datasoruces are available for all layouts 
in all projects. 

 Global Datafields  
These datafields are available for all layouts in 
all projects. 

 Projects 
A collection of layouts and datafields. Data-
field definitions are only valid within layouts of 
the project they are defined in. 

16.2 Basic Operations 

16.2.1 Open an existing Repository 

To open a repository select File ► Repository ► Open Repository… from the menu. Then select 
the repository file and confirm with OK. Alternatively use the menu File ► Open…. TFORMer 
allows you to open both, .tff-files (stand-alone forms) and .tfr-files (repositories). Once opened, the 
repository is displayed in the design tree in the ”Repository” tab – see figure above. 

16.2.1.1 Demo Repository 

The TFORMer installation includes a demo repository. This repository is named “Demos.tfr” and 
can be opened by selecting All Programs ► TEC-IT TFORMer 6.0 ► Examples ► Demo 
Repository from the Windows Start Menu. 

16.2.2 Create a New Repository 

Select File ► Repository ► New Repository… from the menu. A file dialog will appear. Enter a 
suitable filename. Then click Save. 

 

The new repository will be displayed in the design 
tree. 

 

► Important: Each repository has to be stored in a separate folder! Otherwise it will lead to 
problems. So, when creating a new repository, you should always create a folder first, then 
save the repository there. 

16.2.3 Save a Repository 

Select the repository inside the design tree and press Ctrl+S (or select File ► Save from the menu).  



 







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16.2.4 Import a Stand-alone Layout into a Repository 

You can import existing stand-alone layouts into the repository by following these steps: 

 
 

In the design tree locate the project, in which you 
want to import the layout.  

Right-click on the project and select Import Form… 
from the pop-up menu. 

 

The dialog below will appear. 

 

 
 

In  select the file that you want to import. 

 

Then click Next or Finish. 

 

If you click Next, you can assign a name and a 
description for the layout in the repository. 

By default the name of the imported file will be used 
as layout name. 

16.2.5 Export a Layout from the Repository 

Exporting a layout from a repository creates a stand-alone layout. 


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In the design tree locate the project, from which you 
want to export the layout. Then right-click on the 
layout and select Export Form… from the pop-up 
menu. 

 

An alternative method is to open the layout by 
double-clicking it in the design tree. Thereafter select 
File ► Save as…. 

16.2.6 Close a Repository 

Mark the repository in the design tree (the root entry). Then right-click on it and select Close 
Repository from the pop-up menu. Alternatively you can also use the menu File ► Repository ► 
Close Repository. 

16.3 Working with a Repository 

16.3.1 Projects 

Before you can add layouts and datafield definitions, you first have to create a project: Right-click 
on the repository in the design tree. Then select New Project from the pop-up window. Alternatively 
use the menu: Insert ► Project. The name and the description for the project can be edited in the 
properties window or using the F2 key. 

16.3.2 Insert a Layout 

Select File ► New… from the menu (or right-click on any item in the “Layouts” branch in the design 
tree and select New Form… from the pop-up menu) to open the following wizard: 
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In this dialog you select, whether you want 
to create a stand-alone form (), or if you 
want to add a form to a repository (). 

 

To insert the new layout into the repository 
select option . Then select the repository 
in . 

 

Click Next. 
The following dialog will appear: 

 
 

Select the project in . 

 

Then click Next. 

 

In this dialog you can finally select one of 
the available templates (analogous to 
section 6.2.2). 

 

Click Finish to accept. 

 

The selected layout template will be 
added to the selected project in the 
repository. 

 

If you click Next, you can assign a name 
and a description for the layout in the 
repository. 

By default the name of the imported file 
will be used as layout name. 








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17 General Settings 

17.1 Options Dialog 

In the options dialog you can customize common TFORMer settings. To open the dialog select 
Tools ► Options… from the menu. 

 
Figure 70: Options Dialog 

Please note: 

► The settings which apply for the output generation (see sections 17.4 to 17.10) are stored in 
the configuration file „TFORMer.xml“. 

► These settings are used for TFORMer Designer, TFORMer SDK and for TFPrint. 

► For more information on the configuration file see section E.2. 

17.2 General 

17.2.1 User Interface Settings 

Measurement system The measurement system can be set to: 

 System (Default)  
Uses the measurement system that is specified in the regional options of your operating 
system. 

 Metric (mm) 

 U.S.-System (inch) 

Use automatic zoom 
for new views (y/n) 

If enabled, all files that are opened will be set to “Automatic” zoom level (= fit the width of the 
layout window).  
By default this option is disabled. 

Edit content of 
elements after 
insertion (y/n) 

If enabled, upon insertion of a new text, barcode or picture element the dialog for editing the 
content will be opened automatically (see chapter 9).  
By default this option is enabled. 

Show tooltips in 
design (y/n) 

If enabled, TFORMer will display tooltips when hovering the mouse cursor over design 
elements or bands. These tooltips show information about assigned data, comments and 
printing conditions.  
By default this option is enabled. 
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Highlight on mouse 
over 

Specifies the type of highlighting and the highlighting color for elements which have the 
mouse focus in the design view. The following options are available: 

 Border 

 Border and Data (Default) 

17.2.2 Design Tree Settings 

Locate in Design-Tree 
(y/n) 

If enabled, TFORMer will automatically locate each element in the design tree which was 
selected it in the layout view. By default, this option is disabled. 

Show all open Forms 
(y/n) 

If enabled, the design tree shows the contents of all open documents. Otherwise it is popu-
lated with the contents of the current layout only. By default, this option is disabled. 

17.2.3 Grid Settings 

Width Horizontal resolution of the grid. 

Height Vertical resolution of the grid. 

Grid visible (y/n) Show or hide the grid in the layout view. 

Keyboard shortcut: Ctrl+G  

Snap to grid (y/n) If enabled, every graphical element that is inserted or moved will be positioned on the grid. 

Keyboard shortcut: Ctrl+R 

Hint: If this option is enabled you may position elements off the grid as well: Just press the 
Alt key during a drag and drop operation. 

17.3 Language 

Language The language to be used in menus and dialogs. 

17.4 PDF 

17.4.1 Properties 

Page Layout The page size (Letter, A4, …) for PDF output. 

Orientation The orientation (portrait or landscape) for PDF output. 

Color mode The color mode for PDF output: “Color”, “Grayscale” or “Black & White”. 

17.4.2 Fonts 

Embed as ___ (y/n) If this option is enabled, all used fonts will be embedded within the PDF file. This option 
ensures, that the PDF document is always displayed correctly, even if the required fonts are 
not installed on the system where the document is viewed. Embedding fronts increases the 
size of the generated PDF document. By default this option is enabled. You can choose the 
method for font-embedding: 

 TrueType: The complete TrueType font is embedded in the PDF file. 

 TrueType-Subgroups: Only the required parts of a TrueType font are embedded in the 
PDF file (smallest output size). 

 Type3: Fonts are embedded as type 3 fonts in the PDF file. Type 3 fonts should only be 
used when printing the resulting PDF on high resolution devices. 

Simulate bold fonts if 
not available (y/n) 

If this option is enabled, TFORMer will simulate the bold font in the resulting PDF file if the 
bold typeface is missing. By default this option is enabled. 

17.4.3 Image Resolution 

Reduce to ___ (y/n) If enabled, all images of which the resolution is larger than the specified value will be re-
sampled. Smaller images are stored in their original resolution. 

If disabled, all images are embedded in their original size. 



 
 

Page 104 of 139 

TFORMer Designer  User Manual  

17.4.4 Image Compression 

Method The compression method that is used for storing images in the PDF output: 

 Auto 
(All images which are provided as JPEG are embedded as JPEG. All other images 
(.bmp, .tif, …) are stored as Zip compressed bitmap data.) 

 Zip 
(All images are stored as Zip compressed bitmap data.) 

 Jpeg 
(All images are stored as JPEG images using the specified compression quality.) 

Quality The compression factor for JPEG images. 

17.5 HTML 

Page Layout The page size (Letter, A4, …) for HTML output. 

Orientation The orientation (portrait or landscape) for HTML output. 

Output Resolution The output resolution (in dpi) for rendering HTML pages.  
The pre-set value is the screen resolution 96 dpi. 

Optimal Barcode 
Resolution (y/n) 

If enabled, the module width of barcodes will be optimized for the (rather small) output reso-
lution of HTML pages. This option guarantees optimal barcode readability. 

Please note: As a result the size of the barcode may be reduced! 

17.6 PostScript 

17.6.1 Properties 

Page Layout The page size (Letter, A4, …) for PostScript output. 

Orientation The orientation (portrait or landscape) for Postscript output. 

Color mode The color mode for PostScript output: “Color”, “Grayscale” or “Black & White”. 

Duplex Single-sided and double-sided printing: 

 Printer Default (uses the settings from the printer driver) 

 Simplex (single-sided printing) 

 Vertical (double-sided printing using a vertical page turn) 

 Horizontal (double-sided printing using a horizontal page turn) 

17.6.2 Image Resolution 

Reduce to ___ (y/n) If enabled, all images of which the resolution is larger than the specified value will be re-
sampled. Smaller images are stored in their original resolution. 

If disabled, all images are embedded in their original size. 

17.6.3 Image Compression 

Method The compression method that is used for storing images in the PostScritpt output: 

 Automatic 
(The compression method is selected automatically. The user can control whether the 
JPEG and/or the Flate algorithms are basically allowed.) 

 JPEG 
(1 bit images are auto compressed. All other images are JPEG compressed.) 

 Flate 
(All images are flate compressed.) 

 RLE 
(All images are run length encoded.) 

 None 
(All images are embedded without any compression.) 

Enable JPEG 
compression (y/n) 

Enables JPEG compression. 

Quality The compression factor for JPEG images. 
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Enable flate 
compression (y/n) 

Enables flate compression (requires PostScript Language Level 3 support). 

17.7 Picture 

Page Layout The page size (Letter, A4, …) for image output. 

Orientation The orientation (portrait or landscape) for image output. 

Output Resolution The output resolution (in dpi) for rendering images.  
The pre-set value is the screen resolution 96 dpi. 

Color Mode The default color mode for image output: “Color”, “Grayscale” or one of various “Black & 
White” modes (e.g., Scattered Dither, Ordered Dither, Threshold). 

Font Anti-aliasing (y/n) If enabled, all fonts are anti-aliased. By default this option is enabled. 

TIFF Compression The compression method which is used for creating TIFF output.  

JPEG Compression The compression factor which is used for creating JPEG output. 

17.8 Zebra (ZPL) 

Page Layout The page size (Letter, A4, …) and the orientation (portrait or landscape) for ZPL-II output. 

Orientation The orientation (portrait or landscape) for ZPL-II output. 

Resolution The resolution (in dpi) of the used printer.  
The pre-set value is “8 dots/millimeter (203 dpi)”. 

Scaling (^JM) Selects the scaling factor for the output. Switch to Doubled if the resulting output is half of 
the required size. 

 Normal (default) 

 Doubled  

Please check out your ZPL-II manual for the ^JMA and ^JMB commands for details. 

Compression Selects the compression method that is used for compressing the bitmap which is sent to 
the ZEBRA printer. The following options are available: 

 None 
(The bitmap will not be compressed. This kind of transfer may be very slow but it is sup-
ported by all ZEBRA models.) 

 RLE 
(The bitmap will be RLE compressed. This option is supported by most ZEBRA models. 
This is the default option.) 

 PNG 
(The sent bitmap is a PNG image. This option is supported by newer ZEBRA models 
respectively newer ZEBRA firmware versions.) 

Dither Mode Selects the method used for simulating color output on a black & white printer. The following 
options are available: 

 Scatter (grayscale simulation method 1, this is the default) 

 Ordered (grayscale simulation method 2) 

 Threshold (no grayscale pattern, just black or white) 

Do not dither Text (y/n) If enabled, colored text is never dithered. By default this option is enabled. 

17.9 Barcodes 

Barcode Printing on 
Windows-Printers 

For the output on Windows-Printers TFORMer offers the following barcode rendering 
methods:  

 Default method  
(This method is given through the barcode DLL. Currently the default method is the 
quality mode – please, see below. However, it may change in later versions.) 

 Compatibility mode, supported by all printers  
(This method may result in suboptimal output quality, but it is compatible to nearly all 
printers. It uses the GDI rectangle functions for drawing the barcode symbols.) 

 Quality mode, supported by most printers  
(This method results in the best quality but may not be supported by all printers. It uses 
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advanced GDI drawing methods.) 

 Dual, a combination of above modes  
(This method produces correct output on most printers but might decrease drawing 
speed.) 

17.10 Formatted Text 

Hyphen used for 
output 

Specifies the separator character, which is used in case of a conditional word break. Select 
one of the list items or enter your own character (or string). 

Additional soft 
hyphens 

The standard character for conditional word breaks is the so called “soft hyphen” character 
(ASCII: 173 or ADh; Unicode: 00ADh; HTML: &#173 or &shy;). Whenever this character is 
encountered in a string a word break may be inserted at this position. Thus TFORMer can 
better utilize the available space within one text line. 

You can also define your own characters to be used as conditional hyphens (e.g., the 
negation character ¬). Just enter the respective characters into the field “Additional soft 
hyphens”. 

Please note: 

 Whenever a conditional word break is applied the specified separator character (see 
above) is printed. 

 The soft hyphen itself (standard or user defined) is never printed! If you specify a dash as 
conditional hyphen, the output of all(!) dashes will be suppressed! 
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18 Licensing 

18.1 License Types 

Please check out http://www.tec-it.com/order for available license types and pricing. 

18.2 Entering your License Data 

To enter the license data select Help ► License… from the menu. The dialog below will appear. 
TFORMer provides two methods for entering the license data: 

 Online Activation using the Activation Key (see 18.2.1). 
This is the default method. Internet access is required. 

 Manual Licensing (see 18.2.2). 
Please get in touch us with us if your system has no internet access or if you prefer to use 
the manual activation for any other reason. We will be glad to send you the license data 
which is suitable for manual licensing 

18.2.1 Online Activation using the Activation Key 

If you have received an activation key from TEC-IT, please use the online activation .  

 
Figure 71: License Dialog – Online Activation 

The following steps are required to license the product: 

1. In field  enter the activation key. 

2. In field  enter your email address. A license certification will be sent to this address 
automatically. 

3. Complete all remaining data (Company, Country, ZIP Code, City). For a successful 
activation all fields are required. 

4. Confirm the entered data by clicking Send. 

A message will inform you about the successful activation. In case of problems or errors, please 
contact TEC-IT. 







http://www.tec-it.com/order


 
 

Page 108 of 139 

TFORMer Designer  User Manual  

18.2.2 Manual Licensing 

Manual licensing is the alternative method for licensing if your system has no Internet connection. 
Select manual licensing  and enter the license data as provided by TEC-IT. 

► Please enter the license data exactly as you received it from TEC-IT!   
Spacing and upper/lower case letters are to be considered. To avoid typing errors, it is 
recommended to use “copy and paste” whenever possible: Copy the data from the license 
email which you have received from TEC-IT and paste it in the license dialog. 

► Single licenses  
If you are interested in a single (workstation) license, please tell us the so-called "System ID” 
of the target computer. You can find the System ID in the licensing dialog (see below). 

 

 
Figure 72: License Dialog – Manual Licensing 

The following steps are required to license the product: 

1. On the top of the dialog you see the System ID () of your computer. 
For single licenses we will ask you to send us the System ID of the target computer. 

2. In the field “Product” select “TFORMer”. 

3. In the field “Licensee” enter the name of the license holder. 

4. In the field “Kind of License” select the kind of license that you have purchased. Possible 
license types are: 

­ Workstation 
­ Site 

5. In the field “Number of Licenses” enter the number of licenses that you have purchased. 

6. In the field “Your License-Key” enter the license key exactly as received from TEC-IT. 

7. Confirm the dialog with OK. 

A message will inform you about the successful licensing. In case of problems or errors, please 
contact TEC-IT. 

18.3 Notes 

TFORMer stores the license data in the registry of the current user (HKEY_CURRENT_USER\ 
Software\TEC-IT Datenverarbeitung GmbH\TFORMer\6.0). For workstation wide licensing copy this 
license data to the corresponding HKEY_LOCAL_MACHINE registry path. 

Another possibility to license TFORMer is to use a license file named “TFORMer.ini”. This file must 

be stored in the same directory as “TFORMer.exe”. For details, please contact TEC-IT. 




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19 Contact and Support Information 

 
TEC-IT Datenverarbeitung GmbH 
 

Address: Wagnerstr. 6  

AT-4400 Steyr  

Austria/Europe 

Phone: +43 / (0)7252 / 72 72 0 

Fax: +43 / (0)7252 / 72 72 0 – 77 

Email: mailto:support@tec-it.com 

Web: http://www.tec-it.com 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

AIX is a registered trademark of IBM Corporation. 
Avery and all Avery brands, product names and codes are trademarks of Avery Dennison Corporation. 
HTML, DHTML, XML, XHTML are trademarks or registered trademarks of W3C, World Wide Web Consortium, Laboratory for Computer 
Science NE43-358, Massachusetts Institute of Technology, 545 Technology Square, Cambridge, MA 02139.  
JAVA® is a registered trademark of Sun Microsystems, Inc., 901 San Antonio Road, Palo Alto, CA 94303 USA.  
JAVASCRIPT® is a registered trademark of Sun Microsystems, Inc., used under license for technology invented and implemented by 
Netscape.  
Microsoft®, Windows®, Microsoft Word, Microsoft Excel® are registered trademarks of Microsoft Corporation.  
Navision® is a registered trademark of Microsoft Business Solutions ApS in the United States and/or other countries. 
Oracle® is a registered trademark of Oracle Corporation. 
PCL® is a registered trademark of the Hewlett-Packard Company. 
PostScript® is a registered trademark of Adobe Systems Inc. 
SAP, SAP Logo, R/2, R/3, ABAP, SAPscript are trademarks or registered trademarks of SAP AG in Germany (and in several other countries).  
 
All other products mentioned are trademarks or registered trademarks of their respective companies. If any trademark on our web site or in this 
document is not marked as trademark (or registered trademark), we ask you to send us a short message (mailto:office@tec-it.com) 
 

mailto:support@tec-it.com
http://www.tec-it.com/
mailto:office@tec-it.com
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Appendix A: Properties 

A.1 Form Properties 

A.1.1 Common 

Datasource Select the datasource which is used for printing. By default the manual datasource is 
selected. Whenever you change the datasource (e.g., in the data view), this setting is 
changed. 

A.1.2 Advanced 

Document Name This expression will be used as name of the generated output or spool file. If left blank, the 
file name is used. 

A.1.3 Watermark 

The watermark is a background picture which is printed per output page. 

File Name The file name of the picture. 

See section A.3.1.4. 

Picture-Mode The display mode of the picture. 

See section A.3.1.4. 

Picture Alignment The alignment of the picture on the printed page. 

See section A.3.1.4. 

A.1.4 Documentation 

Comment An arbitrary comment. For documentation purposes. 
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A.2 Band Properties 

A.2.1 Common 

Group By
2
 The records of a datasource will be grouped based upon this expression: Every time, the 

computed value of the expression changes, a new group will be started. Group-by 
expressions do not change the order of the records in the datasource. 

Group headers are printed when a group starts, group footers are printed after a group 
ends. 

Page Break
3
 Determines whether a page break will be inserted before and/or after this band. Possible 

values: 

 None 

 Before this Band 

 After this Band 

 Before and After this Band 

Row/Column Break
3
 Determines whether a row/column break will be inserted before and/or after this band. 

Possible values: 

 None 

 Before this Band 

 After this Band 

 Before and After this Band 

Pre-Evaluation This expression will be evaluated before the band is printed (see section 12.4). 

Post-Evaluation This expression will be evaluated after the band is printed (see section 12.4). 

A.2.2 Advanced 

Most settings in the group Advanced are available for Complex report and label layouts only. 

Tray For every single page of the output you can dynamically select a tray on the target printer. 
E.g., this might be useful for printing the first page of an invoice on a letterhead. 

The tray selection is performed by the first band on a new page (e.g., by the page header). 
The tray that is entered in the property of this band will be selected: 

 Tray 0 is the default tray (uses the setting of the current printer driver). 

 Tray 1 to 10 can be pre-configured (Tray Mappings ► Trays). 

For more details, please refer to section 12.6. 

Type The band type (Report Header, Page Header, …). 

Output Area
4
 The area, in which the band shall be printed: 

 Page 

 Label 

Print at Bottom
5
 By default, the report footer will be printed directly after the last detail band. By setting this 

value to True, the report footer will be printed at the bottom of the page (before the page 
footer). 

A.2.3 Control 

Printing Condition The printing condition decides at print-time, whether the band is printed or not (see section 
12.2). 

A.2.4 Position 

Height
6
 The band height. 

Width
6
 The band width. 

Can Grow
7
 Specifies, whether the height of the band is increased if required. This is useful if the band 

                                                      
 
 
2
 For group headers and group footers. 

3
 Not for page headers and page footers. 

4
 For report headers, page headers, page footers and report footers. 

5
 For report footers. 

6
 Availability depends on the layout type and on the band type.  
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contains elements with dynamic size (possible for text and picture elements). Allowed 
values are: 

 No 

 Height 

Can Shrink Specifies, whether the height of the band is decreased if possible. This is useful if the band 
contains elements with dynamic size (possible for text and picture elements). Allowed 
values are: 

 No 

 Height 

Print across Pages
3
 Specifies if the band may be printed across pages: 

 Yes (the band will be continued on the next page, if it does not fit in the remaining space 
on the current page) 

 Avoid (the band will be split only if it does not fit on an empty page) 

 No (the band will be clipped if it does not fit on an empty page) 

A.2.5 Documentation 

Name The name of the band (used for display only). 

Comment An arbitrary comment. For documentation purposes. 

A.2.6 Columns 

The group Columns is available for detail bands only. 

Columns Specifies, how many columns are used for printing the detail bands. 

If activated, each new record (respectively each record copy) is printed in a subsequent 
column. When designing the layout you have to consider, that only the respective  
percentage of the column width may actually be used for design elements (e.g., for 2 
columns you may only cover 50% of the width). The Row/Column Break has to be removed. 

Gap The gap between the columns. 

Width The width of a column. 

For the alternating output of two or more detail bands you have to consider, that each involved 
detail band must have the same column settings! 

                                                                                                                                                                  
 
 
7
 Not for page headers. 
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A.3 Element Properties 

A.3.1 Common 

A.3.1.1 Text Elements 

Text The text to be printed. 

Font Selects the font style and size. 

Fore Color The color of the text. 

Fill Color The color and the pattern of the text background. 

Line Color The color and the pattern of the bounding rectangle. 

Line Width The width of the bounding rectangle. 

Line Style The line style for the bounding rectangle (solid, dashed, …). 

Text Alignment The alignment of the text within the bounding rectangle. 

The following values are possible: 

Top, Left Top, Center Top, Right 

Center, Left Center Center, Right 

Bottom, Left Bottom, Center Bottom, Right 

  

Justify Turn justify on/off. 

Word Wrap If enabled, line-breaks will be ignored. 

Text Rotation Text rotation (0, 90, 180 or 270 degrees, counter clockwise). 

A.3.1.2 Barcode Elements 

Barcode-Data The data which is encoded as barcode symbol.  
The barcode data may contain static data and/or dynamic data (e.g., datafields). 

Barcode Type The barcode type (symbology). 

Check Digit Selects the check digit computation. 

Barcode Color The color of the bars. 

Font Selects the font style and size. 

Fore Color The color of the text. 

Fill Color The color and the pattern of the background. 

Human Readable Text The position of the human readable text (Above, Below, No). 

Human Readable Text 
Distance 

The distance between the barcode and the human readable text. 

Rotation Barcode rotation (0, 90, 180 or 270 degrees, counter clockwise). 

A.3.1.3 Line, Rectangle, Ellipse 

Fill Color The color and the pattern of the text background.  
(This property is not available for line elements.) 

Line Color Line color and pattern. 

Line Width The line width. 

Line Style The line style (solid, dashed, …). 

Radius The radius of the rounded corner. 

(This property is only available for rounded rectangles.) 

A.3.1.4 Picture 

File Name  The image file name. 

The following file formats can be used: .bmp, .gif, .jpg, .pcx, .png, .tga, .tif. 

File names can be specified using one of the following formats: 

 Windows file format  
(e.g., “C:\temp\sample.png”) 

 URL format (only available under windows!)  
(e.g., “http://www.tec-it.com/pics/sample.png”) 
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You can use absolute file names (e.g., “C:\sample.jpg”) and relative file names (e.g., 
“sample.jpg” or “img\sample.jpg”). As base for relative path specifications the path of the 
TFORMer file (.tff or .xmd) is used. 

Alignment The alignment of the picture within the bounding rectangle. 

The following values are possible: 

Top, Left Top, Center Top, Right 

Center, Left Center Center, Right 

Bottom, Left Bottom, Center Bottom, Right 

  

Rotation Picture rotation (0, 90, 180 or 270 degrees, counter clockwise). 

Mode The display mode: 

 Clip (The picture will be printed in its original size and might be clipped by the bounding 
rectangle.) 

 Stretch (The picture will be stretched to fit the bounding rectangle, regardless of its 
aspect-ratio.) 

 Zoom (The picture will be enlarged to its maximum possible size within the bounding 
rectangle, keeping its aspect-ratio.) 

 Tile (The picture will be replicated row- and column-wise inside the bounding rectangle.) 

Transparent Color All regions in the image that are filled with the selected color will be printed transparently.  

A.3.2 Advanced 

A.3.2.1 Text Elements 

Auto Font-Size If set to True, TFORMer automatically selects the biggest possible font size, for which the 
text to fits into the bounding rectangle without being cropped. 

Auto Font-Size 
Minimum 

Specifies the lower font size limit (in percent), if Auto Font-Size is enabled. 

Auto Font-Size 
Maximum 

Specifies the upper font size limit (in percent), if Auto Font-Size is enabled. 

Optimize Spaces If enabled, multiple consecutive spaces will be printed as one single space character.  
Sample: “TFORMer   Designer    ” will be printed as “TFORMer Designer”. 

Suppress Blank Lines If enabled, empty lines in a multi line text will not be printed.  

Sample: “TFORMer 

 

Designer” 

 will be printed as “TFORMer 

Designer” 

  

Line-Spacing The spacing between text lines. 

A.3.2.2 Barcode Elements 

For more information on the following properties, please refer to the Barcode Reference, which is 
available for download on www.tec-it.com. 

Escape Sequences Turn the translation of escape sequences on/off. 

Hex-Data Enable this property if your barcode data is provided as hex-string. TFORMer will convert it 
to ASCII characters automatically. Example: The hex-string “34373131” will be converted 
into the barcode data “4711”. 

Codepage This setting allows you to specify the codepage for encoding characters outside of the 
standard ASCII range (0-127). This means this setting is relevant for specific 2D barcodes 
only (others do not support the respective character range). 

Please note:  
If you choose any other page than the default codepage the characters might get mixed up 
or even unreadable. For public applications you should therefore always use the default 
codepage. If you try to encode special characters (like Ä or Ñ), please make sure that the 
2D symbology is able to encode these characters with the default codepage. 

Format The format property is used for formatting the utilizable data of the barcode. It is specified 
via a string that operates with substitute symbols to indicate how the data shall be structu-
red. 

Specifying a format string, you can: 

 Select subsets for Code 128 and UCC/EAN-128. 

 Define the desired Start/Stop characters for CODABAR. 

http://www.tec-it.com/
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 Reposition the Check-Digit (in special cases). 

 Encode the date, preamble, service class, postal and country code into the barcode data 
(MaxiCode). 

Bearer Width Adjust the horizontal lines above and below the barcode: 

0 inch (or mm) … no line  
x inch (or mm) … use the specified line width 

Module Width The module width is the width of the narrowest bar. 

Notch Height The notch height specifies how far the synchronization bars should jut out from the remain-
ing barcode. (E.g., the EAN code has synchronization bars on the left, in the middle and on 
the right.) 

Bar:Space Ratio This property is used to specify the relationship between the widths of the single bars and 
spaces of a barcode. The input format depends on the selected barcode type. – For Code 
2OF5 Interleaved you could specify the ratio “1:2:1:2”, e.g. 

Suppress Error 
Message 

In case of an error during the printing of a barcode (e.g., wrong input data), an error mes-
sage will be printed. This option allows you to suppress the error message. The space will 
be left blank instead. 

Optimal Resolution Automatically adjust the module width of the barcode (decrease it) to avoid aliasing prob-
lems on the output device. The module width is set to a multiple of the smallest available 
printing unit. 

Bar-Width Reduction When printing on inkjet printers, the ink that is absorbed by the paper tends to diffuse. 
Setting the bar width reduction allows you to work against this spreading of ink. 

The bar width reduction is specified in percent of the module width. E.g., when setting this 
value to 20 all bars will be narrowed by 20 percent of the module width. 

Barcode Encoding Specifies how the characters should be encoded inside the barcode. This setting is available 
for most 2D barcodes. (The barcode must be capable of encoding binary data.) 

Possible values: 

 automatic (TFORMer tries to minimize the barcode data) 

 binary 

A.3.3 Control 

Printing Condition The printing condition decides at print-time, whether the element will be printed or not (see 
section 12.2). 

Layer Assign the element to one of the predefined layers (see section 12.3). 

A.3.4 Position 

Left The left most coordinate of the element. 

Top The top most coordinate of the element. 

Right The right most coordinate of the element. 

Bottom The bottom most coordinate of the element. 

Width The width of the element. 

Height The height of the element. 

Can Grow
8
 Specifies, whether the dimensions of the element are adjusted according to its content. 

If a text is clipped inside the frame (relevant for dynamic content only) you can use the pro-
perty Can Grow. The size of the text element will be increased automatically as required. 
Allowed values are: 

 No 

 Height 

 Width 

 Height and Width 

If the height of the band which contains this element should grow accordingly, enable the 
“Can Grow” property of the band. 

Can Shrink
8
 Specifies, whether the dimensions of the element are adjusted according to its content. 

Allowed values are: 

 No 

                                                      
 
 
8
 For text and picture elements 
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 Height 

 Width 

 Height and Width 

If the height of the band which contains this element should shrink accordingly, enable the 
“Can Shrink” property of the band. 

Flush Top Adjust the top border to the specified band edge. 

Useful for drawing column separator lines in tables. Allowed values are: 

 No 

 Last Printed Band 

Flush Bottom Adjust the bottom border to achieve a common baseline.  

Useful for aligning an element to the bottom position of the band or other elements. Allowed 
values are: 

 No 

 Elements 

 Band 

Flush Right Adjust the right border to achieve a common vertical line to the right.  

Useful for aligning the right border of an element to the right position of the band or other 
elements. Allowed values are: 

 No 

 Elements 

 Band 

Shift Mode This property is used to move elements relative to other growing or shrinking elements. 
“Always” considers size-changes of other elements immediately. “When overlapped” only 
avoids intersections.  

Allowed values are: 

 Always 

 Don’t shift 

 When overlapped 

A.3.5 Margins 

These properties are available for Text Elements only: 

Margin Left These margins are used to confine the printing area within a text element. 

Margin Top 

Margin Right 

Margin Bottom 

A.3.6 Documentation 

Name The name of the element. 

Comment An arbitrary comment. For documentation purposes. 

A.4 Layer Properties 

A.4.1 Common 

Name The name of the layer. 

Display Color If Display Layer colors ( ) is enabled, all elements, which are assigned to that layer, will be 

drawn in the specified color. 

Visible Here you can toggle all elements of one layer visible or invisible.  
Please note: This is for editing purposes only! – The output will not be affected. 

A.4.2 Control 

Printing Condition The printing condition decides at print-time, whether the elements, which are assigned to that 
layer, will be printed or not (see section 12.2). 
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A.4.3 Documentation 

Description A simple description. Only for documentation purposes. 

Comment An arbitrary comment. For documentation purposes. 

A.5 Datafield Properties 

A.5.1 Common 

A.5.1.1 Datafield 

Name The name of the datafield.  
This name can be used to address the datafield in expressions. 

Data Type The type of the datafield. Choose one of the following: 

 Text 

 Integer 

 Floating-point 

We recommend the general use of the data-type "Text".  

Default Value The default value for the datafield. This value will be returned, if no other value is given. 

A.5.1.2 Computed 

Name The name of the datafield.  
This name can be used to address the datafield in expressions. 

Data Type The type of the datafield. Choose one of the following: 

 Text 

 Integer 

 Floating-point 

Expression The expression which is used to compute the value for the datafield. 

Compute Per Choose if the datafield is re-computed for every: 

 Record 

 Record copy 

A.5.1.3 Serial 

Name The name of the datafield.  
This name can be used to address the datafield in expressions. 

Data Type The type of the datafield. Choose one of the following: 

 Integer 

 Floating-point 

Start Value The start value for the serial number.  
If the “Store last value” property is enabled (see below), the start value will be updated auto-
matically after each print-job. 

Step Size The step size in which the serial number is incremented. 

Store Last Value (y/n) If enabled TFORMer remembers the last printed value. The next unused value will be as-
signed as start value for the next print job automatically. 

Update on Choose the trigger, on which the serial number is incremented: 

 Record 

 Record copy 

 Document 

 Page 

 Label 

Update Condition An optional condition controlling the increment of the serial number.  
If a condition was entered, the serial number will only be increased if the result of the ex-
pression is true. 
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A.5.2 Validation (Datafield) 

The Validation group is only available for normal datafields. 

Validation Rule This rule is verified when importing data. 

Validation Message If the validation-rule is violated, this message will be prompted. 

A.5.3 Aggregation (Computed) 

The Aggregation group is only available for computed datafields. 

Aggregation Type Selects one of the available aggregation functions or disables aggregation.  
Available values are: 

 None 

 Running Average 

 Running Sum 

Aggregation Region If aggregation is enabled, select the region for which the aggregation values are calculated: 

 All 
(do one aggregation within the whole range of the print-job) 

 Page 
(do a separate aggregation within the range of each new page) 

 Label 
(do a separate aggregation within the range of each new label) 

 Group 
(do a separate aggregation within the range of each new group) 

Group If the aggregation region is set to “Group”, use this field to enter the grouping condition. Enter 
the same condition as specified in the group header or group footer. 

Aggregation Filter An optional filter for aggregation values.  
If a filter was entered, single values will only be considered, if the expression returns true. 
Thus you can define, which values are considered for the aggregation, and which not. 

A.5.4 Advanced 

Caption These properties may be queried with the TFORMer SDK API. They have no functionality for 
printing. 

Display Order This property is used by the data grid of TFORMer Designer and by the tool QuickPrint to 
determine the order in which datafields are displayed. By default TFORMer sorts the data-
fields alphabetically. 

A.5.5 Documentation 

Description A simple description. Only for documentation purposes. 

Comment An arbitrary comment. For documentation purposes. 

A.6 Tray Mapping Properties 

A.6.1 Common 

Name The name of the tray mapping. 

A.6.2 Trays 

Tray 1 For each of the 10 logical trays in TFORMer you can assign a device-specific printer tray. 
You can assign tray names or paper format names. 

… 

Tray 10 

A.6.3 Documentation 

Description A simple description. Only for documentation purposes. 
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Comment An arbitrary comment. For documentation purposes. 

A.7 Repository 

Description A simple description. Only for documentation purposes. 

Comment An arbitrary comment. For documentation purposes. 

A.8 Tray Mapping Properties (Repository) 

Same as the Tray Mapping Properties described in A.6. 

A.9 Global Datafields (Repository) 

Same as the Datafield Properties described in A.5. 

A.10 Projects (Repository) 

A.10.1 Common 

Name The name of the project. 

A.10.2 Documentation 

Description A simple description. Only for documentation purposes. 

Comment An arbitrary comment. For documentation purposes. 

A.11 Forms (Repository) 

A.11.1 Common 

Name The name of the form. 

File The file name of the form. 

A.11.2 Documentation 

Description A simple description. Only for documentation purposes. 

Comment An arbitrary comment. For documentation purposes. 
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Appendix B: Supported HTML Tags and Entities 

B.1 HTML Tags 

B.1.1 Standard 

Tag Description 

<a> Anchor. 

Used for embedding links. Only the href attribute is supported.  
E.g., <a href=”http://www.google.com”>Link to Google</a> 

<b>, <strong> Bold text.  
Everything between the start tag <b> and the end tag </b> is rendered bold. 

<br> Line break.  
Inserts a line break. 

<font> Font. 

The following attributes are supported: 

 color 
Only hexadecimal values, no color names.  
E.g., <font color=”#ff0000”>. 

 name 
Selects a typeface.  
E.g., <font name=”Helvetica”> 

 size 
Use one of the predefined HTML font sizes within the range from 1 to 7.  
E.g., <font size=”2”> 

 style 
Supports the “font-size” attribute only.  
E.g., <font style="font-size: 12pt"> 

<i> Italic text.  
Everything between the start tag <i> and the end tag </i> is rendered italic. 

<p> Paragraph.  
<p> starts a new paragraph. </p> ends the paragraph. 

<strike> Strike through text.  
Everything between the start tag <strike> and the end tag </strike> will be striked through. 

<sub> Subscript. 
Everything between the start tag <sub> and the end tag </sub> will be subscript. 

<sup> Superscript. 
Everything between the start tag <sup> and the end tag </sup> will be superscript. 

<u> Underlined text.  
Everything between the start tag <u> and the end tag </u> will be underlined. 

Table 1: Supported HTML Tags 

B.1.2 TFORMer Specific 

Tag Description 

<Expr> Used by TFORMer internally. This tag embeds expressions.  

<HtmlExpr> Used by TFORMer internally. This tag embeds expressions, which are returning HTML. 

Table 2: Supported HTML Tags (TFORMer Specific) 

B.2 Named Entities 

Named Entity Character Description 

&amp; & Ampersand. 

&copy; © Copyright. 

&gt; > Greater than. 

&laquo; « Left angle quotation mark. 
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&lt; < Less than. 

&middot; · Middle dot. 

&nbsp;  Non breaking space. 

&plusmn; ± Plus minus. 

&raquo; » Right angle quotation mark. 

&reg; ® Registered Trademark. 

&trade; ™ Trademark. 

&shy;  Soft hyphen. 

&zws; 

&zerowidthspace; 

 Zero width space. 

Table 3: Supported HTML Entity Names (incomplete list) 
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Appendix C: Function Reference 

C.1 Functions 

Return Function Description 

long Abs («Number») Returns the absolute value of a number.  

date AddDays () Adds or subtracts the specified number of days to/from a date value. 

date AddMonths () Adds or subtracts the specified number of months to/from a date value. 

date AddWeeks () Adds or subtracts the specified number of weeks to/from a date value. 

date AddYears () Adds or subtracts the specified number of years to/from a date value. 

long Asc («Text») Returns the ASCII value of a given character or of the first character of «text». 

date CDate («Text») Converts the string «text» to a date. Provides an empty date if no conversion is 
possible. 

The date format in «Text» depends on the regional settings on your computer. This 
setting is configured in the Control Panel ► Region and Language under „Formats“. 

 German: Format = “24.12.2004” 

 English: Format = “12/24/2004” 

date CDateEx («Text», 
«Format») 

Converts a string into a date. The conversion format to be used is adjustable. For infor-
mation on how to specify the format, please refer to the description of the function 
Format («Date», «Format») below. 

Example: CDateEx ("31.12.2000", "dd.MM.yyyy"). 

double CDbl («Expr») Converts any value to a double value (floating-point notation).  
The result is 0.00 when a conversion is not possible. 

char CheckChar_ISO706
4Mod37_2 («Data») 

Calculates the check character according to ISO 7064 Mod 37-2. 

string CheckDigits 
(«Method», «Text») 

Returns the check digit for the given string as text. Possible values for «Method» are: 2 
(Modulo 10), 3 (Modulo 43), 4 (Modulo 47, 2 digits), 5 (DP Leitcode), 6 (DP Identcode), 
7 (Code11, 1 digit), 8 (Code11, 2 digits), 9 (USPS PostNet), 10 (MSI, 1 digit), 11 (MSI, 
2 digits), 12 (Plessey), 13 (EAN 8), 14 (EAN 13), 15 (UPC A), 16 (UPC E), 17 (EAN 
128), 18 (Code 128), 19 (Royal Mail 4 State), 20 (Modulo-11, PZN), 21 (Modulo-11, 
W=7), 22 (EAN 14), 23 (Modulo 10, Korean PA), 24 (Modulo 10, Planet), 25 (Modulo 
10, Italian Postal 2/5), 26 (Modulo 36, DPD Barcode), 27 (Modulo 16), 28 (Modulo 10, 
Luhn Algorithm). 

long CheckDP («Text») Returns the Deutsche Post check-digit (Leitcode, Identcode) of the specified value as 
long. 

long CheckMod10 
(«Text») 

Returns the Modulo 10 check-digit (weighted) as ASCII code. 
E.g., CheckMod10(”1203”) will return 52, which is the ASCII code for the character “4”. 
Please, use the function Chr(CheckMod10(..)) to get the result as a character. 

char CheckMod36 
(«Text») 

Returns the Modulo 36 check-digit of the specified value as character. 

char CheckMod43 
(«Text») 

Returns the Modulo 43 check-digit of the specified value as character. 

char Chr («Number») Returns the corresponding character for the specified ASCII value «Number». 

long CLng («Expr») Converts any value into a whole number. If a conversion is not possible, the result is 0. 

string CStr («Expr») Converts a value into a text. 

long Day («Date») Determines the day of the month [1..31]. 

long DayOfWeek 
(«Date») 

Returns the day of the week of a specified date [1..7]. 1=Sunday, 2=Monday, ... 

double DayOfYear 
(«Date») 

Returns the day of the year of a specified date [1..366]. 

double Exp («Number») Returns the value e
«Number»

, where e is the base of the natural logarithms. 

double Exp10 («Number») Returns the 10
«Number»

. 

long Find («Text», 
«SearchText», 
«nStart») 

Searches the string «Text» for «SearchText» starting from Position «nStart». Returns 
the position of the string or -1. The first character of a string is located at position 0. 

http://www.tec-it.com
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long FindReverse 
(«Text», 
«SearchText», 
«nExclude») 

Searches the string «Text» for «SearchText» in reverse order excluding «nExclude» 
characters at the end. Returns the position of the string or -1. The first character of a 
string is found at position 0. 

string Format («Number», 
«Pattern») 

Formats «Number» according to the specified pattern string «Pattern».  
Format placeholders: 

# digit or no value, 
0 '0' or digit 
. decimal point 
, comma 
+  - sign 

string Format («Date», 
«Pattern») 

Formats «Date» according to the specified pattern string «Pattern».  
Format placeholders: 

dd day of month (01 – 31) 
MM month double-digit (01 – 12) 
MMM month three-digit (Jan – Dec) 
yy year double-digit (01) 
yyyy year four-digit (2001) 

Example: Format (CDate("12/24/2009"), "MMM, dd yyyy") returns Dec, 24 2009.  

See also section C.4 Formats. 

double Fract («Number») Returns the fractional unit of «Number». 

long Hour («Date») The hour of a specified date [00..23]. 

string IIf («Condition», 
«TrueExpr», 
«FalseExpr») 

Returns the value of «TrueExpr» if «Condition» is evaluated as (TRUE or not equal to 
0) . 
Returns the value of «FalseExpr» if «Condition» is evaluated as (FALSE or equals 0). 

bool IsDate («Text», 
«Format») 

Checks if the given string can be converted into a valid date using the specified 
conversion format. For information on how to specify the format, please refer to the 
description of the function Format («Date», «Format») above. 

long IsEmpty («Text») Test whether the string «Text» is empty or not. 

long IsEven («Number») Returns TRUE if «Number» is even. 

long IsLastPage () Returns TRUE if the page being printed is the last page of the document.  

bool IsLeapYear 
(«Date») 

Returns TRUE if the specified date occurs within a leap year.  

long IsOdd («Number») Returns TRUE if «Number» is uneven. 

string KeepChars («Text», 
«KeepChars») 

Removes all characters in «Text» which are NOT included in «KeepChars». 

string LastValue 
(«VarName») 

Returns the last value of a given datafield (the value of the datafield from the previous 
record).  

string Left («Text», 
«nLength») 

Returns the first characters «nLength» of a string.  

long Len («Text») Returns the length of the given string.  

double Log («Number») Returns the natural logarithm of «Number». 

double Log10 («Number») Returns the logarithm of «Number». 

string Lookup («Key», 
«NamedValues», 
«DefaultValue») 

Retrieves the value associated with the specified key. If the key is not found the default 
value is returned. 

Example: Lookup ("KEY1", "key1=value1 key2=value2", "DefaultValue") returns 
“value1”. 

string Mid («Text», 
«nStart», 
«nLenght») 

Returns the substring of string «Text» starting at position «nStart» with length 
«nLength». The first character of a string is located at position 0. 

long Minute («Date») The minutes of a specified date/time [00..59]. 

long Month («Date») The month of the specified date [1..12]. 

date Now () The actual date and time. 

double Pow («Number», 
«Power») 

Returns the result of «Number» raised to the power of «Power». 

double RandomDbl 
(«MinValue», 
«MaxValue») 

Generates a random number (type double) in the range [MinValue..MaxValue]. 

long RandomLng 
(«MinValue», 

Generates a random number (type long) in the range [MinValue..MaxValue]. 
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«MaxValue») 

string RandomStr 
(«Length», 
«AllowedChars») 

Generates a random string of given length using the given characters. 

Example: RandomStr (6, "0123456789ABCDEF") might return "12AF42". 

string RemoveChars 
(«Text», 
«RemoveChars») 

Removes all characters in «Text» which are included in «RemoveChars». 

string Replace («Text», 
«SearchText», 
«ReplaceText») 

Replaces each occurrence of «SearchText» in string «Text» with «ReplaceText». 

string Right («Text», 
«nLength») 

Returns the last characters «nLength» of a string.  

double Round («Number», 
«Precision») 

Returns «Number» rounded using precision digits. If 0 is «Precision» the result will be 
rounded to a whole number. 

long Second («Date») The second of a specified date/time [00..59]. 

double Sqrt («Number») Returns the square root of «Number». 

long SumOfDigits 
(«Number») 

The sum of all digits of «Number». 

long SumOfDigits1 
(«Number») 

Returns the one digit sum of all digits of «Number». 

string ToLower («Text») Converts all character in the string «Text» to lower case. 

string ToUpper («Text») Converts all character in the string «Text» to upper case. 

string Trim («Text») Removes leading and trailing spaces. 

string TrimLeft («Text») Removes leading spaces.  

string TrimRight («Text») Removes trailing spaces. 

double Value («Text») Converts «Text» to a double value. 

long WeekOfYear 
(«Date») 

The calendar week of a specified date/time [1..52]. 

long Year («Date») The year of the specified date/time. 

Table 4: Functions 

C.2 System Datafields 

Function Description 

BandName The name of the current band. 

BandType The type of the current band. 

Column The current column number (label printing) [0..x]. 

ComputerName The name of the computer (hostname). 

Copy The actual number of copies [1..NumCopies]. 

Device The name of output device (Printer). 

Device Type The type of the output device (usually Winspool). 

Form The name of the current form. 

LogPage The number of the current logical page
9
 [1...NumLogPages]. 

Several logical pages can be printed per physical page. 

NumCopies The count of all copies [1..x]. 

NumLogPages The count of all logical pages
9
 [1...x]. 

Several logical pages can be printed per physical page. 

NumPages The count of all physical pages (sheets) [1..x]. 

NumPrintItems Total number of items to be printed. Sum of the copy count of all records. 

NumRecordCopies The number of copies of the actual record. 

                                                      
 
 
9
 A logical page is usually the area of a label on the output page. Every Row/Column Break starts a new logical page. 
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NumRecords The count of all input-records. 

Page The actual page number [1..NumPages]. 
Every printed physical page (sheet) increases the page number by 1. 

PrintedItems Number of currently printed items, including the current item. 

Project The name of the current project. 

ProjectDir The directory of the current project. 

Record The actual record number [1..NumRecords]. 

RecordCopy The actual number of record copy. 

Repository The name of the current repository. 

RepositoryDir The directory of the current repository. 

Row The current row number (by Label print) [0..x]. 

tfDocumentName This name will be used for the spool-job under Microsoft Windows. Can be set via an 
expression. 

tfServerJobFile The job file of TFORMer Server. 

tfServerJobID The job ID of TFORMer Server. 

tfServerJobTimesPrinted For TFORMer Server only: How often has this server job already been printed. 

XResolution Horizontal device resolution in dots per inch (25.4 mm). 

YResolution Vertical device resolution in dots per inch (25.4 mm). 

Table 5: System Datafields 

C.3 Common Expressions 

Expression Description 

“- “ + CStr (Page) + “ -“ Inserts the page number into the layout. 

“EUR ” + Format («Number», “########.00”) Formats a value into a EUR price. 

“Page ” + CStr (Page) Inserts a formatted page number into the layout. 

“Page ” + CStr (Page) + “ of ” + CStr(NumPages) Inserts the page number and the count of all pages into the layout.  

“USD ” + Format («Number», “########.00”) Formats a value into a USD price. 

CStr (NumPages) Inserts the count of all pages into the layout. 

Format (Now (), “hh’:’mm’:’ss tt”) Inserts the actual time (12 hours). 

Format (Now), “HH’:’mm’:’ss”) Inserts the actual time (24 hours). 

Now () Inserts the current date into the layout. 

Table 6: Common Expressions 

C.4 Formats 

C.4.1 Numbers 

Expression Description 

Format («Number», “#,###,##0.00+”) Formats a number with a trailing sign (+ or -) (e.g., 1.299,20+). 

Format («Number», “#,###,##0.00-”) Formats a number with an optional trailing sign (only if negative) 
(e.g., 1.299,20-). 

Format («Number», “*,***,**0.00-”) Formats a number with leading starts and an optional trailing sign 
(only if negative) (e.g., ***1.299,20-). 

Format («Number», “+#,###,##0.00”) Formats a number with a leading sign (+ or -) (e.g., +1.299,20). 

Format («Number», “-#,###,##0.00”) Formats a number with an optional leading sign (only if negative) 
(e.g.,  -1.299,20). 

Format («Number», “-0.000.000.00”) Formats a number with an optional leading sign (only if negative) 
(e.g.,  -0.001.299,20). 

Table 7: Number Formats 
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C.4.2 Date 

Expression Description 

Format (Now (), “dd’-‘MM’-‘yy”) Formats the actual date (e.g., 29-01-07). 

Format (Now (), “dd’-‘MM’-‘yyyy”) Formats the actual date (e.g., 29-01-2007). 

Format (Now (), “dd’.‘MM’-‘yyyy”) Formats the actual date (e.g., 29. Jan ‘07’). 

Format (Now (), “dd’.’MM’.’yyyy”) Formats the actual date (e.g., 29.01.2007). 

Format (Now (), “ddd’,’d’.‘MMM’.’yyyy”) Formats the actual date (e.g., Mon., 29. Jan. 2007). 

Format (Now (), “dddd’,’d’.‘MMM’.’yyyy”) Formats the actual date (e.g., Monday, 29. Jan. 2007). 

Format (Now (), “dddd’,’d’.‘MMMM yyyy”) Formats the actual date (e.g., Monday, 29. January 2007). 

Table 8: Date Formats 

C.4.3 Time 

Expression Description 

Format (Now (), “h’.’m’.’s tt”) Formats the current system time and appends am or pm (according 
to the language settings of your system) (e.g., 9:6:5 am/pm). 

Format (Now (), “H’.’m’.’s”) Formats the current system time (e.g., 21:6:5). 

Format (Now (), “h’.’mm’.’ss tt”) Formats the current system time and appends am or pm (according 
to the language settings of your system) (e.g., 9:06:05 am/pm). 

Format (Now (), “H’.’mm’.’ss”) Formats the current system time (e.g., 7:06:05). 

Format (Now (), “hh’.’mm’.’ss tt”) Formats the current system time and appends am or pm (according 
to the language settings of your system) (e.g., 09:06:05 am/pm). 

Format (Now (), “HH’.’mm’.’ss”) Formats the current system time (e.g., 21:06:05). 

Table 9: Time Formats 

C.5 Operators 

Please note that there may be more than one operator for identical operations. In this case you can 
select your preferred notation. 

Operator Description 

! Logical NOT. 

!= Comparative operator not equal. 

% Modulo. 

& Bitwise AND. 

&& Logical AND. 

* Multiplication. 

+ Addition (add values, concatenate strings). 

- Subtraction. 

/ Division. 

< Comparative operator smaller than. 

<= Comparative operator smaller than or equal. 

<> Comparative operator not equal. 

= Comparative operator equal. 

== Comparative operator equal. 

> Comparative operator greater than. 

>= Comparative operator greater than or equal. 

^ Bitwise XOR. 

and Logical AND. 

not Logical NOT. 

or Logical OR. 
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xor Bitwise XOR.  

| Bitwise OR. 

|| Logical OR. 

~ Bitwise NOT. 

Table 10: Operators 

C.6 Constants 

Constant Description 

"\n" Linefeed. 

False Logical value FALSE. This value is usually the result of a condition. If the condition is not 
fulfilled the resulting value is FALSE. 

True Logical value TRUE. This value is usually the result of a condition. If the condition is fulfilled 
the resulting value is TRUE. 

Table 11: Constants 
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Appendix D: Layout Schemes 

D.1 General 

Basically TFORMer distinguishes two layout types: Labels and Reports. Each of these two types 

allows different variations in the page layout: 

 When printing Labels usually one detail band is printed on each label. A label is also referred 
to as logical page area. This area can be printed once or multiple times on each physical 
page. 

 When printing Reports multiple details bands are printed underneath each other. The page 
(minus the headers and footers) is filled with detail bands. The area on which the detail 
bands are printed is internally also treated as logical page (= as label). 

Figure 73 to Figure 81 use the following color keys for page areas and bands: 

 The red frame marks the page area, which may, on demand, be divided into multiple labels. 

 The dashed frame marks one label (one logical area). 

 Depending on the settings for this band, it is either printed inside or outside of the label area. 
(Applies to page headers, page footers, report headers and report footers.) 

 This band is always printed inside of the label area.  
(Applies to detail bands, report headers and report footers.) 

TFORMer fills each physical page with page headers, detail bands, page footers, etc. If no space is 

left a new physical page is started. 
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D.2 Report 

For the layout type “Report” the following variations are available: 

 Simple – see section D.2.1 

 Columns – see section D.2.2 

 Complex – see section D.4 

D.2.1 Simple 

Page Header

Page Footer

Detail Band

Detail Band

Detail Band

Detail Band

Detail Band

Report Header

Report Footer

 
Figure 73: Simple Report 

For a simple report start with the template <Custom 
Report> and select the variation “Simple Report” (see also 
6.2.2.1). 

 

In the page setup dialog you specify the paper size and the 
page margins. 

 

Examples: 
File ► New Form… ► (6) Samples ► Report_1 
File ► New Form… ► (6) Samples ► Report_2 

D.2.2 Columns 

Page Header

Page Footer

Detail Band

Detail Band

Detail Band

Detail Band

Detail Band

Report Header

Report Footer

Detail Band

Detail Band

 
Figure 74: Report with Columns 

For a report with columns start with the template <Custom 
Report> and select the variation “Columnar Report”. 

 

In the page setup dialog you specify the paper size, the 
page margins and the columns. 

 

Hint: 
When using a fixed number of columns and if you set 
Width=”0” the available horizontal space is divided equally. 

 

Example: 
File ► New Form… ► (6) Samples ► Report_5 
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D.3 Labels 

For the layout type “Label” the following variations are available: 

 Label Printer– see section Fehler! Verweisquelle konnte nicht gefunden werden. 

 Label Sheets – see section D.3.2 

 Complex – see section D.4 

D.3.1 Label Printer 

Label

(Detail Band)

Label

(Detail Band)
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Figure 75: Label Printer 

For printing on label printers (e.g., ZEBRA
®
 thermo transfer 

printers) start with the template <Custom Label> and select 
the variation “Label Printer” (see also 6.2.2.3). 

 

In the page setup dialog you specify the label size. 

 

Example: 
File ► New Form… ► (2) Transportation ► DHL ► 
DHL_EuroConnect 

D.3.2 Label Sheets 

Detail Band

Detail Band

Detail Band

Detail Band

Detail Band

Detail Band

Detail Band Detail Band

 
Figure 76: Label Sheets 

For printing on label sheets (e.g. Avery
®
 standard formats) 

start with the template <Custom Label> and select the 
variation “Label Sheets” (see also 6.2.2.2). 

 

Hint: 

If you intend to use different paper sizes for your printout 
you can set the number of rows and columns to “auto”. In 
this case TFORMer will calculate the number of labels that 
fit on the output page. 

 

Example: 
File ► New Form… ► (6) Samples ► Label_1 
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Detail Band

Detail Band

Detail Band

Detail Band

Detail Band

Page Header

Page Footer

Detail Band Detail Band

Report 

Header

 
Figure 77: Label Sheets with Headers and 
Footers 

If required you can also insert additional page headers and 
footers respectively report headers and footers for label 
sheets: 

 

 
 

Example: 
File ► New Form… ► (6) Samples ► Label_2 
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D.4 Complex 

For <Custom Label> and for <Custom Report> you can choose the layout variation “Complex” 
which refers to the same design mode in both cases. When using “Complex” you have full access to 
all band properties, even to those which are hidden in the basic design variations otherwise. 

For implementing the following layout schemes it does not matter if you are starting with the 
template <Custom Label> or <Custom Report>. In both cases you have full control over the design. 
The only difference is the different base design you are starting with. 

D.4.1 Labels with Headers and Footers 

Page Header

Page Footer

Detail Band

Page Footer

Page Header

Detail Band

Page Footer

Page Header

Detail Band

Page Footer

Page Header

Detail Band

Page Footer

Page Header

Report Header

Report Footer

 
Figure 78: Label Sheets with Headers and 
Footers 

If you want to print headers and footers on labels start with 
the template <Custom Label> and select the variation 
“Complex Labels”. Insert the desired page headers and/or 
page footers. 

 

When setting the Output-Area to “Page” (= default) 
TFORMer will print the header/footer across the whole 
physical page width. 

When setting the Output-Area to “Label” (see ) TFORMer 
will print the header/ footer within the label. 

 

Header/ Footer: Advanced 

 Output-Area Label  

 

Please note: 
You can also use more than one header (or footer) in your 
design. For example, you can use one page header which 
is printed per page and one page header which is printed 
per label. 
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D.4.2 Reports in Labels 

Page Header

Page Footer

Detail Band

Detail Band

Detail Band

Detail Band

Detail Band

Detail Band

Detail Band

Detail Band

Detail Band

Detail Band

Detail Band

Detail Band

Report Header

Report Footer

 

For printing multiple detail bands inside one label start with 
the template <Custom Label> and select the variation 
“Complex Labels”. Remove the Row/Column Break for the 
detail band (see ). 

TFORMer will print as many detail bands as possible for 
the given row height.  

 

Please make sure to use reasonable values for the detail 
band height . If your label is 60 mm high and if your detail 
band is 20 mm high three detail bands will fit on one label. 

 

Detail Band: Common 

 Page Break None 

 Row/Column Break None  

 Position 

 Height 20.000 mm  

 

Please note: 
Headers and footers may be added as required (see also 
section D.4.1).  

 

Examples: 
File ► New Form… ► (6) Samples ► Report_3 
File ► New Form… ► (6) Samples ► Report_4 

Page Header
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Detail Band

Detail Band

Page Header
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Detail Band
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Figure 79: Reports in Labels 
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D.4.3 Report with Detail Band Columns 

Page Header

Page Footer

Detail Band

Detail Band

Detail Band

Detail Band

Detail Band

Report Header

Report Footer

 
Figure 80: Report with Detail Band Columns 

In order to print a report with multiple detail bands in one 
line start with the template <Custom Report> and select the 
variation “Complex Report”. (Please make sure not to 
change the predefined settings for the page subdivision, so 
the page will not be divided into multiple labels. The correct 
settings are: 1 row, 1 column, 0 width and 0 height). 

 

Remove the Row/Column Break for the detail band (see 
). In the section Columns  enter the required column 
configuration. If you want to print multiple different detail 
bands in one line, you have to apply the same column 
settings for all of these bands. Otherwise line breaks will be 
inserted. 

 

Variant A: Fixed number of columns with identical width 
 

Detail Band: Common 

 Page Break None 

 Row/Column Break None  

 Columns  

 Columns 2 

 Gap 0.000 mm 

 Width (auto) 
 

In this example the page width is divided in two equal 
columns (see also Figure 80, left). You can let TFORMer 
calculate the column width automatically or you can enter it 
manually. 

Please note: In the layout the detail band is drawn over the 
whole page width. However, you may only use the part of 
the band which corresponds to the column width (in this 
case half of the band width). 

 

Variant B: Multiple detail bands with individual widths 
 

Detail Band: Common 

 Page Break None 

 Row/Column Break None  

 Columns  

 Columns (auto) 

 Gap 0.000 mm 

 Width (auto) 
 

In this case TFORMer automatically determines the space 
which is required for each detail band. Thus the page can 
be filled with detail bands that have different widths. 

 

 

Example: 
File ► New Form… ► (6) Samples ► Report_5 
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D.4.4 Labels with Detail Band Columns 
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Figure 81: Label Sheets with Detail Band 
Columns 

In order to print multiple columns per label start with the 
template <Custom Label> and select the variation 
“Complex Labels”. 

 

Remove the Row/Column Break for the detail band (see 
). In the section Columns  enter the required column 
configuration (see also D.4.3). 

 

In this example two columns with the same width are 
printed on the label. 

 

Detail Band: Common 

 Page Break None 

 Row/Column Break None  

 Position 

 Height 50.000 mm 

 Width  80.000 mm 

 Columns  

 Columns 2 

 Gap 0.000 mm 

 Width (auto) 

 

Please note: 
The width of the detail band is the same as the label width. 
When setting the number of rows to 2 the design on the 
detail band must not cover more than 50% of the detail 
band width (in this case 40.000 mm)! 
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Appendix E: Advanced Configuration 

E.1 Template File Path 

The file path for the template files can be set in the windows registry. You can find the appropriate 
settings either under HKEY_CURRENT_USER or under HKEY_LOCAL_MACHINE: 

[HKEY_CURRENT_USER\Software\TEC-IT Datenverarbeitung GmbH\TFORMer\6.0\Directories] 

TemplateDir="Some directory where the templates are stored" 

When storing the setting under HKEY_LOCAL_MACHINE then it is valid for all users on the compu-
ter: 

[HKEY_LOCAL_MACHINE\Software\TEC-IT Datenverarbeitung GmbH\TFORMer\6.0\Directories] 

TemplateDir="Some directory where the templates are stored" 

E.2 Configuration File TFORMer.xml 

All output specific settings from the options dialog (see chapter 17) are stored in the configuration 
file TFORMer.xml. 

This file is located in the application data directory of the current Windows user: 

%LocalAppData%\TEC-IT\TFORMer\7.0\TFORMer.xml 

Please note: 

► Each Windows user account uses its own configuration file. 

► The settings from the configuration file are used for TFORMer Designer, TFORMer SDK 
and for TFPrint. 

► The standard settings (defaults on the first program start respectively in case of a missing 
TFORMer.xml file in the user application data directory) are taken from the global application 
data directory (see below). 

The standard configuration file is located in the global application data directory: 

%ProgramData%\TEC-IT\TFORMer\7.0\TFORMer.xml 

For a complete description of the configuration file, please refer to the Developer Manual. 
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Appendix F: Creating CSV Files with Excel® 

In order to create a CSV file with Microsoft
®
 Excel

®
, please follow these steps: 

 
 

First create a table with the desired data. Make 
sure that every column has a column name (see 
). 
 
The column names should match the names of the 
datafields used in the layout. 

 

 
 

Then select Office Button ►Save as ►Other 
Formats from the menu. 

Navigate to the desired output folder and enter a 
file name (e.g., “Data”). Under  choose “CSV 
(Comma delimited) (*.csv)”. Then click Save. 

 

 
 

When opened in a text editor the CSV file should 
look like this. All columns must be separated by 
semicolons. 

 

 




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Files 

 
New Form ...........................  Ctrl+N 

 Open ..................................  Ctrl+O 

 Save ...................................  Ctrl+S 

 Close Form .........................  Ctrl+W, Ctrl+F4 

Switch between open Files
 

Select the file from the menu “Window” respec-

tively by using the layout picker . Alternatively 
use the following keyboard shortcuts: 

 Next File .............................  Ctrl+Tab 
 Previous File ......................  Ctrl+Shift+Tab 

Layout and Printing 

 Layout View .......................  Ctrl+L 

 Data View ...........................  Ctrl+D 

 Preview ..............................  Ctrl+Space 

 Page setup .........................  Alt-P 

 Print ...................................  Ctrl+P 

The Page Setup can also be opened via 
double-click on the form selection area  or via 
double-click on the gray area . 

Editor Customization 

 Grid Visible (on/off) .............  Ctrl+G 
 Snap To Grid (on/off) ..........  Ctrl+R 
 Zoom In ..............................  Ctrl++ 
 Zoom Out ...........................  Ctrl+- 
 Zoom In/Out .......................  Ctrl+Mousewheel 
 Auto Zoom ..........................  Ctrl+0 
 Zoom 100% ........................  Ctrl+1 
 Zoom 200% ........................  Ctrl+2 
 Zoom 300% ........................  Ctrl+3 
 Zoom 400% ........................  Ctrl+4 
 Zoom 50% ..........................  Ctrl+5 
 Scroll vertically ...................  Mousewheel 
 Scroll horizontally ...............  Shift+Mousewheel 

 

Right Click – Context Menu 

If you are unsure which operations can be performed on a selected 
object, open the context menu by clicking the right mouse button – see 
. 

Renaming 

To change the name of a datafield, tray mapping, layer, band or design 
element, select the entry in the tree view. After another click (or after 
pressing the F2 key) the name can be edited. 

Layers 

Double-click on the layer icon in the design tree to toggle the visibility. 

Default Element Properties 

You can save the current format styles (font style, color, line width, …). 
These styles will be applied automatically when inserting a new ele-
ment. Use the context menu (right mouse button) to: 

   Set Default-Format (based on current selection) 
   Apply Default-Format (to current selection) 

 Editing 

 Undo ..................................  Ctrl+Z, 
Alt+Backspace 

 Redo ..................................  Ctrl+Y 

 Cut .....................................  Ctrl+X 

 Copy ..................................  Ctrl+C 

 Paste ..................................  Ctrl+V 

 Delete.................................  Del 

 Select all Elements .............  Ctrl+A 

Element Content 

 Edit the content of 
selected text, barcode 
and picture elements ..........  F2 

Text Properties 

 Bold ....................................  Ctrl+B 

 
Italic ...................................  Ctrl+I 

 Underline ............................  Ctrl+U 

Move Elements 

While dragging elements with the mouse you 
can use the following modifier keys: 

 Snap to horizontal and 
vertical axis.........................  Shift 

 Copy Mode .........................  Ctrl 
 Fine Positioning ..................  Alt 

Insert/Resize Elements 

While inserting or resizing elements with the 
mouse you can use the following modifier keys: 

 Square/Circle ......................  Shift 
 Centered ............................  Ctrl 
 Fine Positioning ..................  Alt 

Align Elements (for multiple selection) 

 
Align Left ............................  Ctrl+ 

 
Align Right ..........................  Ctrl+ 

 Align Top ............................  Ctrl+ 

 Align Bottom .......................  Ctrl+ 

Keyboard Shortcuts 

 






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Band Order (if a band is selected) 

 Move Up.............................  Alt+ 
 Move Down ........................  Alt+ 

Datasource 

 
Reload data ........................  F5 

Miscellaneous 

 TFORMer Help ...................  F1 
 Cancel operation ................  

(e.g., cancel a mouse 
drag and drop) 

ESC 

 


