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2 Disclaimer 

The actual version of this product (document) is available as is. TEC-IT declines all warranties 
which go beyond applicable rights. The licensee (or reader) bears all risks that might take place 
during the use of the system (the documentation). TEC-IT and its contractual partners cannot be 
penalized for direct and indirect damages or losses (this includes non-restrictive, damages through 
loss of revenues, constriction in the exercise of business, loss of business information or any kind of 
commercial loss), which is caused by use or inability to use the product (documentation), although 
the possibility of such damage was pointed out by TEC-IT. 

 

 
We reserve all rights to this document and the information contained therein. Reproduction, 
use or disclosure to third parties without express authority is strictly forbidden. 
 

 
Für dieses Dokument und den darin dargestellten Gegenstand behalten wir uns alle Rechte 
vor. Vervielfältigung, Bekanntgabe an Dritte oder Verwendung außerhalb des vereinbarten 
Zweckes sind nicht gestattet. 
 

© 1998-2010  
TEC-IT Datenverarbeitung GmbH  
Wagnerstr. 6 

A-4400 Austria  
t.: +43 (0)7252 72720  
f.: +43 (0)7252 72720 77  
http://www.tec-it.com 
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3 Introduction 

3.1 What is TFORMer QuickPrint? 

TFORMer QuickPrint is a tool for quickly printing labels, reports and forms. It is shipped together 
with the form layout designer TFORMer Designer. The tool QuickPrint allows you to load existing 
layouts, fill them with data and print them on one of the supported output devices (or export them to 
one of the supported file formats). 

3.2 How to run TFORMer QuickPrint? 

In order to start TFORMer QuickPrint use the Windows
®
 Start Menu: 

Start ►All Programs ►TEC-IT TFORMer 6.0 ►Tools ►Print Tool QuickPrint 

3.3 System Requirements 

► Windows 2000 or higher. 

► TFORMer QuickPrint requires the .NET 2.0 runtime components! 

3.4 About this Document 

This document covers the following issues: 

 User interface and workflow – see chapter 4. 

 Select the form layout and the output type – see chapter 5. 

 Provide the print data – see chapter 6. 

 Start the print job – see chapter 7. 

 Additional information on the use of serial numbers – see chapter 8. 
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4 General 

4.1 User Interface 

 
Figure 1: User Interface 

The user interface contains the following sections: 

 Common settings. See section 5.1. 

Form layout selection. See section 5.2. 

Output configuration. See section 5.3. 

Input area (and related functions ). See chapter 6. 

Print. See chapter 7. 

Menu. 

Preview of the form. 

4.2 Working with TFORMer QuickPrint 

After starting the tool QuickPrint, first you have to configure some settings (see also chapter 5). 
Use the buttons  to  to adjust the common settings, to select the desired layout and to select the 
output type (file or printer). – Instead of the buttons you can also use the Configuration menu. 

Next enter the print data in the input area  (see chapter 6). 

Finally start printing with button  (see chapter 7). 



 

 

 



 



 



 



 


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4.3 Configuration Files 

TFORMer QuickPrint supports the loading and saving of configuration files. This gives you the 
possibility to change the layout, the output medium, an optional serial number file and an optional 
user data file with a few mouse-clicks. 

Configuration files use the extension .qpi and are saved in XML format. They contain the settings 
from  to . 

► When starting TFORMer QuickPrint the most recently saved settings are loaded automati-
cally. You can continue with the data input and with the printing of the last form layout imme-
diately. 

► To load a specific configuration file use the menu File ► Open..., double-click the .qpi file or 
pass the .qpi file as a command line parameter to TFORMer QuickPrint. 

You can manage different configurations via the File menu: 

New Creates a new configuration.  
All settings are reset to default. 

Open… Loads an existing configuration.  
The last used printing data is displayed in the input area. 

Save /   
Save as… 

Saves the current configuration.  
The filename can be assigned freely. 

4.4 Print Mode 

When you are done with the configuration you have the possibility to switch to the so called “Print 
Mode” (use the menu Configuration ► Printmode). In this mode all configuration dialogs are locked. 

The user can only change the print data and start a print-job. 

The current mode (configuration mode or print mode) is stored in the configuration file. – In order to 
prevent the user from changing the configuration, the configuration file should be marked as read-
only. 

4.5 Storing the most recent Print Data 

By default TFORMer QuickPrint automatically stores the most recently used print data (see section 
5.2, checkbox “Save data automatically after printing”). This data is restored in the input area when-
ever a configuration file is opened respectively when QuickPrint is started. 

For automatically saving the last printed record (and for manually saving the current record by 
clicking the button Save Data) QuickPrint internally creates one XML file per layout. This file is 
named <layout file name> + “_QP.xml” and it is stored in the “Data Directory” (see section 5.1). It 
holds the data for one record. 

For multiple customers you might probably want to use more than one data file for one layout. Thus 
the last printed data will be available for each single customer. In order to achieve this we recom-
mend to create multiple configuration files. Then for each configuration file specify a separate data 
file (see section 5.2). 
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5 Configuration 

5.1 Common Settings 

Via the Common button the general program settings are adjusted: 

 
Figure 2: Common Settings 

Username An arbitrary username. 

This name is only required when the QuickPrint serial number implementation is used in-
stead of embedding the serial number in the form layout! 

For more information on serial numbers, please refer to chapter 8. 

Serials Directory The directory for the serial number file “QuickPrint.XML”. 

This directory is only required when the QuickPrint serial number implementation is used 
instead of embedding the serial number in the form layout! 

For more information on serial numbers, please refer to chapter 8. 

Data Directory The directory for storing the last printed data. 

In this directory, the last printed data for the layout is stored. This data is loaded together 
with the corresponding form layout and it is displayed in the input area. The data files are 
named <layout file name> + “_QP.xml”. For projects new subfolders are created. 

Please note: This directory is only used if no specific data file is adjusted (see 5.2). 

5.2 Select Form Layout 

Via the Form button the form layout is selected: 

 
Figure 3: Form Layout Selection 

Repository Select a repository (*.tfr) or stand-alone form layout (*.tff). 

Project If a repository was selected use this combo-box to select the project inside the repository. 

Form If a repository was selected use this combo-box to select the form layout inside the project in 
the repository. 
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Save data 
automatically after 
printing 

Use this checkbox to automatically save the entered data after printing. If enabled, Quick-
Print will show the last printed data in the input area each time a form is re-opened. 

The data will either be stored in the Data Directory (see section 5.1) or in a specific data file 
(see below). 

Use a specific Data-File Using this property you can force QuickPrint to use a specific file name and location for the 
data file (which stores the last used data) instead of the default name and location. 

Please note: The specified file name does not have to exist yet. You can also create a new 
file by typing a new file name. 

5.3 Output Configuration 

Via the Output button the output format is selected: 

 
Figure 4: Output Configuration 

Type Select the output format. 

You can choose one of the following output types: 

 Printer – output to a printer. 

 PDF – output to a PDF file. 

 PostScript
®
 File – output to a PostScript file. 

 PostScript
®
 Printer – output to a PostScript printer. 

 HTML – output to a HTML file. 

 Text – output to a text file. 

 BMP Image – output to a BMP image file. 

 GIF Image – output to a GIF image file. 

 JPG Image – output to a JPG image file. 

 PCX Image – output to a PCX image file. 

 PNG Image – output to a PNG image file. 

 TGA Image – output to a TGA image file. 

 TIF Image –  output to a TIF image file. 

 Multi-Page TIF – output to a TIF image with multiple pages. 

 Zebra File – ZPL-II output to a file. 

 Zebra Printer – ZPL-II output to a Zebra printer. 

File Output file or printer. 

Depending on the output type, select the output file name (including the file extension) or the 
printer. 
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6 Input Area 

6.1 General 

After a form layout was selected (see section 5.2) the input area is enabled. This area is used for 
editing the print data. To type in the required field values you can either use the  

 form view (for single records) – see Figure 5 or the 

 table view (for multiple records) – see Figure 6. 

Use checkbox  to switch between the two styles. 

 
Figure 5: Input Area – Form View 

 
Figure 6: Input Area – Table View 

► Only the table view allows you to create and edit multiple records simultaneously. To insert a 
new record edit the record in the last row  and press the return key. A new row will be 

added. 

6.2 Functions for the Input Area 

The following functions are available for the input area: 

 
Saves the data from the current record in the data file. So it will be available when re-opening 
the configuration for the next time (even if the form layout was not printed). 

 
Fills each datafield with its default value (as specified in the datafield definitions in the 
TFORMer Designer form layout). 

 
Clears all fields in the form view respectively all records in the table view. 

 



 



 


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7 Print Form 

7.1 General 

When pressing the Print button (see Figure 1, ) the output will be created according to the speci-

fied output settings (see Chapter 5.3). 

 File: 
After the successful creation of the file it is automatically opened with the associated 
Windows

®
 application (e.g. PDF with Acrobat Reader). 

 

 Printer: 
No further confirmation is displayed. 
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8 Serial Numbers 

8.1 General 

There are two different methods for generating serial numbers: 

 Serial Numbers in the Form Layout (recommended method) – see 8.2! 

 QuickPrint Serial Numbers – see 8.3! 

 

► Please note: Using serial numbers (both methods) also works with multiple users. TFORMer 

ensures the unique allocation of serial numbers within the whole network. 

8.2 Serial Numbers in the Form Layout 

For generating serial numbers TFORMer Designer provides a specific datafield type “Serial”. 
Using this datafield type allows you to embed the serial numbers directly in the form layout. This 
means the serial number is handled by the TFORMer print engine. No additional adjustments in 
QuickPrint are required. 

8.3 QuickPrint Serial Numbers 

This alternative method can be used if you do not want to define the serial number directly inside 
the form layout (see above). In this case the serial number is generated completely independent in 
QuickPrint. It replaces the value of an arbitrary datafield. 

In order to generate a serial number with QuickPrint you have to 

 create a serial number file named (see section 8.3.1) and 

 specify the path to this file in the Common Settings dialog (see section 5.1). 

Please make sure to use identical datafield names in the serial number file and in the form layout. 
Only in this case the datafield will be filled with the serial number. 

8.3.1 The Serial Number File 

The serial number file has to be named “QuickPrint.XML” and can be saved in an arbitrary directory. 
It stores the actual values for one or more serial numbers (datafields). The step size for the incre-
ment of each serial number can be specified. 

Example: 

<?xml version="1.0" standalone="yes"?> 

<root> 

  <ItemNumber current="1017" stepSize="1" /> 

</root> 

Figure 7: Serial number file (Example) 

In this example the datafield “ItemNumber” is treated as a serial number. The actual value of the 
datafield is set to 1017. When printing a form which uses this datafield, the value of the datafield will 
be incremented by 1 (parameter stepSize) for each new record respectively record copy. 




