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2 Disclaimer

The actual version of this product (document) is available as is. TEC-IT declines all warranties
which go beyond applicable rights. The licensee (or reader) bears all risks that might take place
during the use of the system (the documentation). TEC-IT and its contractual partners cannot be
penalized for direct and indirect damages or losses (this includes non-restrictive, damages through
loss of revenues, constriction in the exercise of business, loss of business information or any kind of
commercial loss), which is caused by use or inability to use the product (documentation), although
the possibility of such damage was pointed out by TEC-IT.

&4  We reserve all rights to this document and the information contained therein. Reproduction,
use or disclosure to third parties without express authority is strictly forbidden.

B Fir dieses Dokument und den darin dargestellten Gegenstand behalten wir uns alle Rechte
vor. Vervielfaltigung, Bekanntgabe an Dritte oder Verwendung aul3erhalb des vereinbarten
Zweckes sind nicht gestattet.

© 1998-2013
TEC-IT Datenverarbeitung GmbH
Hans-Wagner-Str. 6

A-4400 Austria

t.: +43 (0)7252 72720

f.. +43 (0)7252 72720 77
http://www.tec-it.com
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3 Introduction

3.1 What is TFORMer QuickPrint?

TFORMer QuickPrint is a tool for quickly printing labels, reports and forms. The tool QuickPrint
allows you to load existing layouts, fill them with data and print them on any of the available printers.
Besides that it is possible to print into files".

3.2 How to run TFORMer QuickPrint?

In order to start TFORMer QuickPrint use the Windows® Start Menu:

Start »All Programs » TEC-IT TFORMer 7.5 » Tools » Printing Tool QuickPrint

3.3 System Requirements

» Windows XP SP 3 or higher.
» Mac OS X on request.
» Runs on 32 bit and 64 bit operating systems.

3.4 About this Document

The user manual covers the following topics:

= User interface — see chapter 4.

=  Printing — see chapter 5.

= Program Settings — see chapters 6 and 7.

= Using different Configurations — see chapter 8.
=  Serial Numbers— see chapter 9.

t Currently you can only select PDF output. All other file formats that are supported by the TFORMer print engine (like
PostScript, ZPL, various image file formats) are available on request.
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4 User Interface

4.1 Main Window
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Figure 1: Main Window

The user interface is divided into the following areas:

©® Menu — see section 4.2.
® Layout Selection — see section 4.3.
© Preview Panel — see section 4.4.
® Input Area — see section 4.5.
© Buttons for Printing and Preview — see section 4.6.
® Shortcut: Edit with TFORMer Designer — see section 4.7.
4.2 Menu
42.1 File
Open Layout... Opens a custom TFORMer layout.
Alternatively you can also use the layout selection area ® and choose Custom »
Open Layout... (see also section 4.3).
Shortcut: Ctrl+O
Print Prints the current layout.
Shortcut: Ctrl+P
PDF Preview Generates a PDF Preview and opens it with the default PDF viewer.
Exit Exits TFORMer QuickPrint.
Shortcut: Ctrl+Q

WWW.TEC-IT.COM Page 6 of 22




4.2.2 Configuration

General Settings... Opens the general settings dialog (see also chapter 7).
Printer Settings... Opens the printer settings dialog (see also chapter 6).
4.2.3 Help
TFORMer QuickPrint Help Displays the TFORMer QuickPrint User Manual.
Shortcut: F1
TEC-IT Web Site Opens the page http://www.tec-it.com in the default web browser.
About TFORMer QuickPrint... Displays information about TFORMer QuickPrint and the program version.

4.3 Layout Selection

QuickPrint =NNC X

File Configuration Help
) F"*”‘- *“
-T‘ - ’mh J ’ - .'\
@

e
;- VDA AIAG » . m‘ BAT

Custom... VDA 4902 AIAG Volkswagen G... General Motors  Caterpillar G51 Labels
K'_'. . VDA 4902 V4 (Deutsch)

= VDA 4902 V4 (Deutsch) - KLT
ODETTE

VDA 4902 V4 (Deutsch) - Stahl-Lieferungen

Odette / Galia
v VDA 4902 V4 (English) L\\S@
a VDA 4902 VDA 4902 V4 (Frangais) Hide Preview
L sbel Type (SIN VDA 4902 V4 (Esparicl) i Y .ﬂ5 131
=rellhes VDA 4902 V4 (Portugués) ‘E I L T80 Mt 5700 KAWOEROLATTER

Receiver (Line 1 VAT TWERFE AG & III"III“ 345 450 |.-|
Receiver (Line Z) INDUSTRIESTRASSE 135b 765-HGD89-123

- R, ©
Receiver (Line 3) D-3000 HANNOVER. 20 usmas
i R,
Receiver (Line 5) @ | ll ' D_!“l!ll |MHNXL

Dock-Gate A5L31 I il l||||||||||||
Edit with TFORMer Designer Number of labels to print: 1 l FEFRETEN ] [L{:’] Print "]
h A

Figure 2: Layout Selection

Layouts are organized in groups.

To select a layout first choose the desired group by clicking on one of the icons in @, then choose
the layout from the drop-down menu @®. (If a group contains only one layout the drop-down menu
will be skipped.)

Please note that the “Custom” icon allows you to open a custom layout from file. All opened layouts
will be added to the drop-down menu for quick selection. On Program exit the most recent 10 items
are stored.

Whenever the layout is changed the following areas are updated:

= The information bar ® shows the name of the selected layout.
= The input area @ shows the input fields for the layout — see also section 4.5.

WWW.TEC-IT.COM Page 7 of 22



http://www.tec-it.com/

= The spin control ® shows the number of labels to print. This value is stored for each
individual layout! — See also section 4.6.

= The preview panel ® shows a small preview of the current layout — see also section 4.4.

For information on how to configure the layout selection (the layout groups and the group items)
please refer to chapter 8 and to Appendix B.

4.4 Preview Panel

The preview panel shows a small image of the selected layout (created with default data):

e,
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Figure 3: Preview Panel

You can hide/show the preview panel by clicking the link @ or by enabling/disabling the option

Preview on the general settings dialog (see chapter 7).

4.5 Input Area

The input area allows you to edit the data which is printed on the label. It lists all editable data fields
for the selected layout (in this case for the label “VDA 4902 V4 (English)”). Unused data fields (=
data fields which are not used in the design) are hidden by default. However, they can be revealed
if required (see section 7.2.3).

Receiver (Line 1)
Receiver (Line 2)
Receiver (Line 3)
Receiver (Line 4)
Receiver (Line 5)
Dock-Gate
Advice Note No
Supplier Address
Net Weight
Gross Weight
MNumber of Boxes

Part Mo

VDA 4902 V4 (English)

Label Type (SINGLE, MULTI, MIXED) SINGLE

MAYR. WERKE AG
INDUSTRIESTRASSE 135b

D-3000 HANNOVER. 20

A5-L131

2581752

CS5 MAW/3, 6750 KAISERSLALTERNM
345

450

01

m

765-HGD8%9-123

Figure 4: Input Area
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Please note:

> When selecting a layout for the first time the input area will be filled with default values (as
specified in the data field definitions in TFORMer Designer).

> QuickPrint stores the entered data automatically. When opening the same layout for the
next time the most recently used input data is available.

> Some data fields may have input validation. In this case they accept only specific values. If
the input validation fails the layout cannot be printed.

» When hovering with the mouse over an input field a tooltip will show the data field comment
from TFORMer Designer (if available). — Please, see below:

VDA 4902 V4 (English)

s

Label Type (SINGLE, MULTI, MIXED) Sillel= I ‘ ‘

Receiver (Line 1) MAYR, WERr[ SINGLE, MULTL, MIXED l.

Fimmmivsme 1 me T TRIF ICTRTECTR ACCE 130k

Figure 5: Input Area Tooltip Information

4.6 Buttons for Printing and Preview

The following controls are used for printing respectively for the PDF preview:

PDFPreviewgl [L,Enprint (3} vl

Mumber of labels to |:|rint:o1 -

Figure 6: Buttons for Printing and Preview

In ® adjust the number of labels that you want to print. Alternatively you can adjust this value on the
print dialog (for details, please refer to section 5.2.2).

Please note:
» The number of label copies is stored for each individual layout!

Button ® generates a PDF preview and opens it in the standard PDF viewer. Other than the small
preview image (see 4.4) this preview will use the label data from the input area (see 4.5).

Button © starts printing. Alternatively you can also use the keyboard shortcut Ctrl+P. or select File
» Print from the menu.

Please note:

» By default a confirmation dialog is opened before printing. On this dialog you can select the
printer and adjust some additional settings.

» You can also instruct the program to skip the print dialog. In this case there is no more con-
firmation before the job is sent to the printer.
You will find the appropriate adjustment in section 6.2.2, setting Print Dialog.
Alternatively you can also select “Do not show this dialog again” if the dialog is currently
opened (see Figure 8, 8).

> For details on the print dialog, please refer to chapter 5.

HINT: The small triangle ] on the right side of the print button will bring up an additional menu:
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(=} Print - ‘ |

& Print Ctrl+P
Printer Settings...
L

Figure 7: Print Button Menu

4.7 Shortcut: Edit with TFORMer Designer

If you click on the link Edit with TFORMer Designer the current layout will be opened in TFORMer
Designer (provided that you have the designer installed on your system). Thus you can inspect or
even change the layout during the design phase.

Please note, that you can also disable this link if required. You will find the appropriate adjustment
in section 7.2.3.
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5 Print Dialog

5.1 Introduction

To open the print dialog click on the Print button, press Ctrl+P or select File » Print from the menu.
The following dialog will appear:

Print l T |-l
Device
Output to: [DefaultSyshem Printer (1) v]
Printer: [ (2] v]
Copies
Mumber of Labels toprint: 1 [3] @
Label Sheet
Start Row: 0 O
Start Column: 0 = O
Déo not show this dialog again Print l [ Cancel
Figure 8: Print Dialog
Please note:
» If the print dialog does not appear, please check the appropriate setting in the printer set-
tings dialog (see section 6.2.2).

5.2 Output Parameters

In the print dialog you can specify the output parameters as discussed below. When finished click
Print in order to send the job to the printer (or to create the output file).

5.2.1 Device
(1 Output to Choose one of the following output types:
= Default System Printer
(Output to the default printerz.)
= Printer
(Output to the selected printerz.)
= PostScript
(Force PostScript Output®.)
= Zebra
(Force ZPL Output®)
= PDF
(Output into a PDF file®.)
(2] Printer For the “Default System Printer” and for “PDF” output this selection is locked.
For all other output types select the target device from a list of printers which are
available on your operating system.

> The print data is generated via the GDI interface (Microsoft Windows).
% The print data is generated by the TFORMer print engine.
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5.2.2 Copies
(3] Number of Labels to Specifies the number of labels to print.
print This value is equal to the number of record copies in TFORMer Designer.
Please note:
= This value is stored for each individual layout!
= |f the number of label copies is greater than 1 TFORMer might try to print multiple
labels per sheet of paper (depends on the settings in the layout). You can influence
this behavior by editing the layout settings in TFORMer Designer.
Example: If you want to make sure that each copy of the VDA 4902 label is printed
on a separate sheet of paper change the number of rows and columns to “1” instead
of “(auto)”.
5.2.3 Label Sheet
(4] Start Row, If the TFORMer layout is set up for printing multiple labels on one sheet of paper you
Start Column can use these parameters to leave the first labels on the sheet blank.
The exact behavior of this setting depends on the “Print Order” which is selected in the
corresponding layout.
Example:
= Start Row =2
= Start Column =0
—Columns Print order “Down, — Columns Print order “Across,
then Across”: The then Down”: The
first two labels in " first two rows will
%’ the left column will E be left empty.
o be left empty. e
5.2.4 Additional Settings
e Do not show this dialog When enabled the print dialog will no longer be shown. Instead each job is directly sent
again to the selected printer without further confirmation.
If you want re-enable the print dialog, please refer to the setting Print Dialog on the
printer settings dialog (see section 6.2.2).
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6 Printer Settings

6.1 Introduction

Select Configuration » Printer Settings... from the menu. The following dialog will appear:

Printer Settings

Device

Qutput to: ’Defﬁult System Printer - ]

Printer: [

Program Behaviour

Print Dialog: Show confirmation dialog before printing

oK l [ Cancel

L

Figure 9: Printer Settings

6.2 Parameters

6.2.1 Device

Output to Choose one of the following output types:

= Default System Printer

(Output to the default printerz.)
= Printer

(Output to the selected printerz.)
= PostScript

(Force PostScript Output®.)
= Zebra

(Force ZPL Output®.)
= PDF

(Output into a PDF file®.)

Printer For the “Default System Printer” and for “PDF” output this selection is locked.
For all other output types select the target device from a list of printers which are available
on your operating system.

6.2.2 Program Behavior
Print Dialog Show the confirmation dialog before printing (y/n)?

= When checked the print dialog is shown before printing (default).

= When unchecked the print dialog is skipped.

WWW.TEC-IT.COM
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7 General Settings

7.1 Introduction

Select Configuration » General Settings... from the menu. The following dialog will appear:

General Settings

(BRI

Layout Selection

Directory:

User Interface
Input Area:
Preview:

Shortcut:

Configuration File:  Layouts. xml|

Layout Data Storage Location

LayoutData,

[ show unused data fields
Show preview window
Shaw link "Edit with TFORMer Designer”™

G Default
&

[ OK ] l Cancel

.

Figure 10: General Settings

7.2 Parameters

7.2.1

Layout Selection

Configuration File

This file provides the structure for the layout selection menu (see Figure 1, 8).
Please note:

= You can use absolute or relative file paths.
Relative paths are relative to the location of the workspace file (see Appendix A).

For more information on the layout configuration file, please refer to Appendix B!

7.2.2 Layout Data S

torage Location

Directory

Specifies the directory where the layout data (= the user input) will be stored. For each
layout a separate data XML file is created.

Please note:

= You can use absolute or relative file paths.
Relative file paths are relative to the location of the workspace file (see Appendix A).

7.2.3 User Interface

Input Area Show unused data fields If checked the input area will also display the unused data
(y/n)? fields (= data fields which are not used in the layout).

Preview Show preview window If checked the preview panel on the right side of the main
(y/n)? window is shown (see Figure 1, ©).

Shortcut Show link “Edit with If checked the link Edit with TFORMer Designer is shown

TFORMer Designer” (y/n)? | (see Figure 1, 9©).

WWW.TEC-IT.COM
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8 Using different Configurations

8.1 Introduction

Typically QuickPrint starts with a default configuration. This default configuration provides a selec-
tion of common labels from industry and logistics.

If you want to use different settings (e.g., a different layout selection) you can customize the existing
configuration or you can create your own additional configurations. This chapter will explain the
necessary steps.

8.2 Configuration Files

QuickPrint requires the following two configuration files:

=  Workspace File (see Appendix A)
The workspace file stores all settings from the configuration menu. That includes the settings
for the user interface, the current printer selection or the directory for print data storage. The
layout selection menu is included via an external configuration file (see also section 7.2.1):

= Layout Configuration File (see Appendix B)
The layout configuration file provides the structure for the layout selection menu and it
contains the references to all layout files.

8.3 Default Configuration

The default configuration files are located in the QuickPrint application data directory:

| %appdata%/TEC-IT/TFORMer/7.5/QuickPrint

They are named Workspace.xml (for the workspace file) and Layouts.xml (for the layout configu-
ration file).

8.4 Create a Custom Configuration

In order to create a new configuration, copy the existing XML files and edit them as required.

Please note:
» The workspace file will be updated automatically each time you run QuickPrint.
» The layout configuration file requires manual editing.

8.5 Use a Custom Configuration

If you want to use a custom workspace file you have to pass it as com- = =
mand line parameter to the QuickPrint application. In order to do so you @ @

: . . : o [ [
can create shortcuts with the respective working configurations: QuickPrint  QuickPrint

Config A Config B

WWW.TEC-IT.COM Page 15 of 22
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9 Serial Numbers

9.1 Introduction

For generating serial numbers TFORMer Designer provides the data field type “Serial”. Using this
type allows you to embed serial numbers directly in your layouts. The TFORMer print engine will do
the automatic consecutive numbering. In QuickPrint no additional adjustments are required.

Please note:

> The serial numbers are also suitable for multi-user environments. TFORMer provides an
internal locking mechanism in order to guarantee globally unique numbers.

9.2 Printing Errors

If you try to print a layout with serial numbers you might get the following error message:
Error @

“¥%  The label could not be printed!

Description:

Info: Locked by

Computer: WORKSTATION @

Process: TFORMerQT_QuickPrint.exe [C:\Program Files (x86)\TEC-

IMTFORMer7\Bint]

Source: C:/ProgramData/TEC-IT/TFORMer/7.0/QuickPrint/Serial Test.tfs_lock
Error Code: 0x00000005

. A

Figure 11: Error when Printing Layouts with Serial Numbers

Explanation:

» The layout cannot be printed at the moment, because the internal serial number counter is
used by a different print process.

» The name of the workstation which causes the lock is displayed in @.

Possible reasons for the error:
» The layout is opened in TFORMer Designer — see 9.2.1.
» Simultaneous printing in a multi-user environment — see 9.2.2.

9.2.1 Layoutis being edited

If the layout is opened in TFORMer Designer (e.g., as a consequence of clicking on the link Edit
with TFORMer Designer) the serial number counter is locked. You have to close the file in order to
remove the lock.

Solution:
» Close the layout in TFORMer Designer and re-try printing.

WWW.TEC-IT.COM Page 16 of 22
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9.2.2 Simultaneous Printing

When using QuickPrint in a multi-user environment (= multiple QuickPrint clients with access to

the same layout files), this error will usually occur if two or more users try to print the same layout at
the same time.

Solution:
> Wait a few seconds and re-try printing.

» If you cannot print for a considerable time, check whether the print job which causes the lock
is still active. If not, delete the lock file. You will find the lock file in the same directory as the
TFORMer layout.
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10 Contact and Support Information

10.1 Free Support
If you have any questions, please contact us:

Email: support@tec-it.com
Web: http://www.tec-it.com/support/

Don’t hesitate to tell us your feedback! If the product does not fulfill your requirements, please tell us
why. We are highly interested in meeting the requirements of our customers.

10.2 How to Unlock the Demo Version

QuickPrint is licensed via TFORMer Designer or TFORMer SDK. License keys can be obtained
from TEC-IT by Email, online order form or FAX.

Email: sales@tec-it.com
Online; http://www.tec-it.com/order/
Fax: +43/(0)7252/72720-77

10.3 Company Contact Information

TEC-IT Datenverarbeitung GmbH

Address: Hans-Wagner-Str. 6
AT-4400 Steyr
Austria/Europe

Phone: +43/(0)7252/72720
Fax: +43/(0)7252/72720-77
Email: support@tec-it.com
Web: http://www.tec-it.com

AlX is a registered trademark of IBM Corporation.

HTML, DHTML, XML, XHTML are trademarks or registered trademarks of W3C, World Wide Web Consortium, Laboratory for Computer
Science NE43-358, Massachusetts Institute of Technology, 545 Technology Square, Cambridge, MA 02139.

JAVAR is a registered trademark of Sun Microsystems, Inc., 901 San Antonio Road, Palo Alto, CA 94303 USA.

JAVASCRIPT® is a registered trademark of Sun Microsystems, Inc., used under license for technology invented and implemented by
Netscape.

Microsoft®, Windows®, Microsoft Word®, Microsoft Excel® are registered trademarks of Microsoft Corporation.

Navision is a registered trademark of Microsoft Business Solutions ApS in the United States and/or other countries.

Oracle® is a registered trademark of Oracle Corporation.

PCL® is a registered trademark of the Hewlett-Packard Company.

PostScript is a registered trademark of Adobe Systems Inc.

SAP, SAP Logo, R/2, R/3, ABAP, SAPscript are trademarks or registered trademarks of SAP AG in Germany (and in several other countries).

All other products mentioned are trademarks or registered trademarks of their respective companies. If any trademark on our web site or in this
document is not marked as trademark (or registered trademark), we ask you to send us a short message (mailto:office@tec-it.com)
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Appendix A: Workspace File (Program Settings)

A.1 Introduction

» The workspace file stores all settings from the configuration menu. The configuration is auto-
matically loaded on program start and it is saved when the application is closed.

> The layout selection menu is included via an external configuration file (see Appendix B).
» QuickPrint supports the use of different working configurations. Therefore you have to pass
the respective workspace files as command line parameters (see section 8.5).

» The default workspace file is located in the QuickPrint program data directory
%appdata%/TEC-IT/TFORMer/7.5/QuickPrint/Workspace.xml

A.2 File Structure

The workspace file is structured as follows:

<Workspace version="1.0">
<Layouts filename="Layouts.xml" currentLayout="VDA 4902 V4 (English)">
<Layout name="Customl" repository="C:/Temp/Customl.tff" project="" form=""/>
<Layout name="Custom2" repository="C:/Temp/Custom2.tff" project="" form=""/>
<Layout name="Custom3" repository="C:/Temp/Custom3.tff" project="" form=""/>
<l=-= L0 ==>
</Layouts>
<Settings>
<General>
<LayoutDataDirectory>UserData/</LayoutDataDirectory>
<ShowPreviewPanel>true</ShowPreviewPanel>
<ShowTFormerLink>true</ShowTFormerLink>
</General>
<Printer>
<PrinterType>System Default Printer</PrinterType>
<PrinterName></PrinterName>
<ShowPrintDialog>true</ShowPrintDialog>
</Printer>
</Settings>
</Workspace>

A.3 The XML Nodes in Detalil

A.3.1 Root Node
This node identifies the workspace file:

Workspace The root node.
version The file format version.

A.3.2 Layouts

This node specifies the set of selectable layouts and their menu structure. The actual configuration
relies on an external XML file (see Appendix B). The most recently loaded custom layouts are
stored as subordinate <Layout> elements.

Layouts The top level node for the layout configuration.
filename The external layout configuration file.
Please note:

= You can use absolute or relative file paths.
Relative paths are relative to the location of the workspace file.

currentLayout The name of the most recently selected layout (will be restored when loading a
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workspace).

A.3.2.1 Layout

Layout This node specifies a custom layout which was loaded via File » Load Layout.... QuickPrint stores up
to 10 of these custom layouts.

name

repository

project

form

The display name and the file reference for the layout.
For a description of the attributes see section B.3.3!

A.3.3 Settings

This node stores the settings from the configuration menu:

A.3.3.1 General

LayoutDataDirectory

The directory for storing the print data (= the user input) for each single layout.
Please note:

= You can use absolute or relative file paths.
Relative paths are relative to the location of the workspace file.

ShowPreviewPanel

Show the preview panel (y/n)?

ShowTFormerLink

Show the link “Edit with TFORMer Designer” (y/n)?

A.3.3.2 Printer

PrinterType

The selected printer type (“Output to”).

PrinterName

The selected printer name (“Printer”).

ShowPrintDialog

Show the print dialog (y/n)?

WWW.TEC-IT.COM
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Appendix B: Layout Configuration File

B.1 Introduction

the structure for the layout selection menu.
» This file must be edited manually.

> The default layout configuration file is located in the QuickPrint program data directory:
%appdata%/TEC-IT/TFORMer/7.5/QuickPrint/Layouts.xml

> The layout configuration file contains the set of selectable TFORMer layouts and it provides

B.2 File Structure

The layout configuration file is structured as follows:

<Config Version="1.0">
<Slides>
<Slide caption="Group 1" imagepath="MyImage.png">
<Templates>
<Template name="Layout 1" repository="MyLayout.tff" />
<Template name="Layout 2" repository="MyRepository.tfr" project="MyProject"
form="MyForm" />
</Templates>
</Slide>
</Slides>
</Config>

Please note that the default layout configuration file contains additional XML elements and
attributes which are not explained below. This additional information may be used in future
QuickPrint version. Currently they are unused, so you can ignore them.

The sample above will result in the following layout selection:

Misc.®
Group1
Layout 1

@ layout?

Figure 12: Layout Group Example

B.3 The XML Nodes in Detalil

B.3.1 Root Node

This node identifies the layout configuration file.

Config The root node.

Version ‘ The file format version.

B.3.2 Slides

The node <Slides> must contain one or more <Slide> elements:

Slide The slide element specifies the caption and the icon for the layout group (see Figure 12, ©).

caption The caption for the layout group (e.g., “Group 1”).
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imagepath

The image for the layout group (e.g., “Mylmage.png”).
Please note:
= You can use absolute or relative file paths.
Relative paths are relative to the location of the layout configuration file.
= The image size is 84 x 54 pixels.

B.3.3 Templates

The node <Templates> must contain one or more <Template> elements:

Template

The template element specifies the display name and the file reference for a TFORMer layout.

name The display name for the item in the layout selection menu (e.g., “Layout 2” — see
Figure 12, ®).
repository The file reference for the TFORMer layout.
Please note:
= You can use absolute or relative file paths.
Relative paths are relative to the location of the layout configuration file.
= For stand-alone forms provide the name of the .tff file.
= For repositories provide the name of the .tfr file.
Furthermore you have to provide the project name and the form name (see
below):
project The name of the project within the repository.
(Only required for repositories.)
form The name of the layout within the given project inside the repository.

(Only required for repositories.)
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