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2 Disclaimer 

The actual version of this product (document) is available as is. TEC-IT declines all warranties 
which go beyond applicable rights. The licensee (or reader) bears all risks that might take place 
during the use of the system (the documentation). TEC-IT and its contractual partners cannot be 
penalized for direct and indirect damages or losses (this includes non-restrictive, damages through 
loss of revenues, constriction in the exercise of business, loss of business information or any kind of 
commercial loss), which is caused by use or inability to use the product (documentation), although 
the possibility of such damage was pointed out by TEC-IT. 

 

 
We reserve all rights to this document and the information contained therein. Reproduction, 
use or disclosure to third parties without express authority is strictly forbidden. 
 

 
Für dieses Dokument und den darin dargestellten Gegenstand behalten wir uns alle Rechte 
vor. Vervielfältigung, Bekanntgabe an Dritte oder Verwendung außerhalb des vereinbarten 
Zweckes sind nicht gestattet. 
 

© 1998-2010  
TEC-IT Datenverarbeitung GmbH  
Wagnerstr. 6 

A-4400 Austria  
t.: +43 (0)7252 72720  
f.: +43 (0)7252 72720 77  
http://www.tec-it.com 
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3 Introduction 

3.1 Professional Documents Created With Ease 

Many thanks for evaluating TFORMer! 

The TFORMer product family represents a complete, lean and powerful solution for generating 
arbitrary documents. It combines the features of barcode labeling tools with the characteristics of 
report generators into a unified printing-solution. It provides professional layout and output capa-
bilities, an integrated barcode generator, full-featured UNICODE support and it supports direct PDF 
generation. It can be used on client and on server side and it is available for all major operating 

systems. 

 

                      

 

The functionality of TFORMer is available for end-users as well as for software developers: 

End-Users benefit from the graphical layout editor with instant output capabilities: TFORMer 
Designer offers outstanding design and printing features for reports, tables, lists, serial letters, 
industry forms, vouchers and barcode labels. Furthermore the numerous ready-to-use label and 
report templates for industry and logistics (e.g., VDA-4902, Odette, GALIA, AIAG, …) will be a valu-
able assistance. 

Software developers use TFORMer SDK as reporting tool for direct printing, PDF generation, 
PostScript-, HTML, image or ZPL-II output. Layouts are designed graphically with TFORMer 
Designer. The TFORMer SDK is then used to provide dynamic data for the layouts and to generate 

the output. This core functionality for printing and output is available for all major operating systems. 

3.2 TFORMer Basics 

In contrast to a word processor which is mostly used for static content, TFORMer generates output 
based on dynamic data. Examples for dynamic contents are article-numbers used in product labels 

or addresses used in serial letters. 

Dynamic content is provided by an external data source like a database, a file, an arbitrary appli-
cation or by the user. Such an external data source is read by TFORMer during printing. So-called 
data fields are used to access the external data. They serve as placeholders for dynamic content in 
the layout. To simplify usage, TFORMer provides a mapping mechanism to bind external data to 

the data fields used in a layout. 
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This data-centric output scheme is maintained in all cases. Even when printing pure static 
documents (like personal address labels without any dynamic data) a data source is required for 
controlling the number of printed labels. 

Data

Output

Design (.ttf, .tfr)

Preview

Enter manually

Import from File

Import from Database

Printer PDF HTML Text

Generate automatically

PostScript
®

 
Figure 1: Architectural Overview 

Layouts created with TFORMer Designer are able to perform computations and to react on the 
values of datafields. Thus, TFORMer enables you to embed the complete output logic of a 
document into the layout. 

3.3 Output Formats 

Once a layout was designed it produces identical results across printer models, operating systems 
and formats. The following formats are supported: 

 Direct Printing 
Print layouts directly on all printers supported by Microsoft

®
 Windows

®
. 

 PDF 
PDF export with full-featured barcode support, Unicode and font embedding. 

 PostScript
®
  

Used for printing under Linux/UNIX and for pre-press applications. 

 HTML
1
 

The built-in HTML output is ideal for previewing and for web-based applications. 

                                                      
 
 
1
 Due to the nature of HTML some output features may be limited or not available. 
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 Image Formats  
The built-in image output supports BMP, GIF, JPG, PCX, TGA, PNG and TIF formats 
(including multipage TIF). 

 ZEBRA
®
  

Print to ZEBRA
®
 printers without any additional driver. ZPL-II output is generated directly. 

 ASCII  
Pure ASCII output without any graphics for special purpose requirements. 

3.4 System Requirements 

3.4.1 Operating Systems 

TFORMer Designer requires one of the operating systems listed below. It works with 32-bit and 64-

bit operating systems. 

 Microsoft
®
 Windows 2000 

 Microsoft
®
 Windows XP 

 Microsoft
®
 Windows Vista 

 Microsoft
® 

Windows 7  

 Microsoft
®
 Windows Server 2003 (including Terminal Server) 

 Microsoft
®
 Windows Server 2008 (including Terminal Server) 

TFORMer Designer includes the output kernel of the TFORMer SDK. This output kernel is 
available for Linux

®
 and UNIX

®
 as well. For details check out the Developer Manual. 

3.4.2 Memory 

512 MB RAM is the recommended minimum (1 GB for Windows Vista or higher). Actual memory 
requirements depend on the type and size of the generated output. 

3.4.3 Disk Space 

TFORMer needs approximately 30 MB on disk. When using the .NET based API of the TFORMer 
SDK or the printing utility TFORMer QuickPrint please also consider .NET 2.0 requirements. 
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4 User Interface 

This chapter will give you an overview of the TFORMer user interface. 

4.1 Main Window 

 
Figure 2: User Interface 

The main window is divided into the following areas: 

 Menu (see 4.2). 

 Toolbars (see 4.3). 

 Layout View, Data View and Preview (see 4.4). 

 Design Tree Window (see 4.5). 

 Properties (see 4.6). 

 Status Bar (see 4.7). 

 Layout Tabs (see 4.8). 

 














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4.2 Menu 

The menu gives you access to the following functions: 

4.2.1 File 

New Form… Create a new layout. Choose a template and adopt it to your needs. 

Shortcut: Ctrl+N 

Open… Open an existing layout (or repository). 

Shortcut: Ctrl+O 

Save Save the current layout. 

Shortcut: Ctrl+S 

Save as… Save the current layout with a new name. You can also save layouts as ZIP-files. 

Close Form Close the current layout. 

Shortcut: Ctrl+W or Ctrl+F4 

Templates Templates can be used as basis for new layouts. 

 Save as Template… Save the current layout as template. 

 Organize Templates… Organize the templates in a hierarchical structure. 

Layout View Switch to the layout view (see section 4.4.2). 

Shortcut: Ctrl+L 

Data View Switch to the data view (see section 4.4.3). Use this view to manually edit or import data 
from external data sources. 

Shortcut: Ctrl+D 

Preview Switch to the print preview (see section 4.4.4). 

Shortcut: Ctrl+Space 

Page Setup… Choose the margins and the orientation of the page. 

Printer Setup… Choose a printer and edit the printer properties. 

Print… Print the layout on a printer of your choice or generate file output (PDF, PostScript
®
, 

HTML, Text). 

Shortcut: Ctrl+P 

Repository A repository is a central location which references multiple layouts in a structured way 
(see chapter 16). 

 New Repository…  Create an empty repository. 

 Open Repository… Open an existing repository. 

 Close Repository Close an open repository. 

Exit Exit TFORMer. 

4.2.2 Edit 

Undo Revert the last change. 

Shortcut: Ctrl+Z 

Redo Revert the last Undo. 

Shortcut: Ctrl+Y 

Cut Copy all selected objects (rectangles, texts, printing bands, datafield definitions, ...) to 
the clipboard and remove them from the layout. 

Shortcut: Ctrl+X 

Copy Copy all selected objects to the clipboard. 

Shortcut: Ctrl+C 

Paste Insert the content of the clipboard. 

Shortcut: Ctrl+V 

Delete Remove all selected objects. 

Keyboard: Del 

Element-Content… Edit the content of a text, barcode or picture element. 

Shortcut: Double-Click the Element or press F2 

Printing-Condition… Edit the printing condition for the selected band or element (see also section 12.2). 

Group-By… Edit the group-by expression for the selected “group header” or “group footer”. 
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Pre-Evaluation… Edit the pre-evaluations for the selected band (see also section 12.4). 

Post-Evaluation… Edit the post-evaluations for the selected band (see also section 12.4). 

4.2.3 Insert 

Project Insert a new project into the repository.  

Form… Insert a new layout into the repository.  

Data Insert a new 

 Datafield…  Create a new datafield (see also section 10.2.1.1). 

 Datasource… Create a new data source (see also section 13.3.2.1). 

 Source-Parameter… Create a new source parameter (see also section 13.5.2.1). 

Tray-Mapping Insert a new tray mapping (see also section 12.6). 

Layer… Insert a new layer (see also section 12.3). 

Band Insert a new band (page header, detail band, …) – see also chapter 7. 

Element Insert a new element (text, barcode, line, …) – see also chapter 8. 

4.2.4 Layout 

Layout View Switch to the layout view (see section 4.4.2). 

Shortcut: Ctrl+L 

Z-Order Overlapping elements can be re-ordered: Send the selected element(s) to the front or to 
the back (see also section 8.2.10.3). 

Align Align two (or more) selected elements (see also section 8.2.10.1). 

Size Adjust two (or more) selected elements in size (see also section 8.2.10.2). 

Horizontal Spacing  Enlarge or reduce the horizontal distance between elements within a selection (see also 
section 8.2.10.4). 

Vertical Spacing Enlarge or reduce the vertical distance between elements within a selection (see also 
section 8.2.10.4). 

Band Order Re-arrange the order of selected bands (see also section 7.3.6). 

Shortcuts: Alt+ and Alt+ 

4.2.5 Data 

Data View Switch to the data view (see section 4.4.3). Use this view to manually edit or import data 
from external data sources. 

Shortcut: Ctrl+D 

Refresh Reload the data from the data source. 

Shortcut: F5 

New Datafield… Insert a new data field (see also section 10.2.1.1). 

New Datasource… Create a new data source (see also section 13.3.2.1). 

Edit Datasource… Edit the current data source (see also section 13.3.2.3) 

New Source-Parameter… Insert a new source-parameter (see also section 13.5.2.1). 

Edit Source-Parameter… Edit a source-parameter (see also section 13.5.2.3). 

Edit Filter… Edit the filter (see also section 13.6.1). 

Apply Filter Apply the filter (see also section 13.6.2). 

4.2.6 Tools 

Customize… Customize the toolbar (not available in this version). 

Options… Open the options dialog window (see chapter 17). 

4.2.7 View 

Layout Switch to the layout view (see section 4.4.2). 

Shortcut: Ctrl+L 

Data Switch to the data view (see section 4.4.3). Use this view to manually edit or import data 
from external data sources. 
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Shortcut: Ctrl+D 

Preview Switch to the print preview (see section 4.4.4). 

Shortcut: Ctrl+Space 

Layer Colors Toggle the display color of the elements between layer colors and element colors (see 
also section 12.3.3). 

Status Bar Show or hide the status bar (see Figure 2, ). 

Application Look Select the appearance of the user interface. Choose between Office XP, Windows XP 
and Office 2007 (blue, black, aqua, silver) styles. 

Properties Show or hide the properties window (see Figure 2, ). 

Design Tree Show or hide the design tree window (see Figure 2, ). 

Toolbar Show or hide single toolbars (see Figure 2, ). 

Zoom Select the zoom factor. You will find the selected zoom factor shown next to the zoom 
symbol in the status bar:  

 
Shortcut: Ctrl++, Ctrl+– or Ctrl+Mousewheel 

4.2.8 Window 

Close All Documents Close all opened documents. 

Document List At the bottom of the Window menu all open documents are listed with their names. To 
select one of the documents, click at the appropriate menu entry. 

4.2.9 Help 

TFORMer Help Display the TFORMer manual. 

Keyboard: F1 

Online FAQ Open the default browser and navigate to the TFORMer Designer frequently asked 
questions web page. 

License… Open the License dialog for TFORMer Designer (see chapter 18). 

Check for Update… Check if an update of TFORMer Designer is available. 

Buy TFORMer Online Open the default browser and navigate to the online order form. 

TEC-IT Website Open the default browser and navigate to http://www.tec-it.com. 

About TFORMer… Display information about TFORMer Designer and the program version. 
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4.3 Toolbars 

The most commonly used program functions are accessible via toolbars. Each of the toolbars can 
be shown or hidden (menu View ► Toolbar). 

The following toolbars are available: 

Default 
 

(New/Open/Save File, Layout View, Data View, Preview, Print, …)  

  

Layout 
 

(Alignment, Size, Z-Order, Spacing) 

  

Content and 
Expressions  

(Element-Content, Printing Condition, Group-By, Pre-Evaluation, Post-Evaluation) 

  

Format 
 

(Font and Font size) 

  

 
 

(Font style, Text Alignment, Colors, Line styles, …) 

  

Layer 
 

(Assign Elements to a Layer, Add Layer, Layer Colors)  
  

Barcode 
 

(Choose Barcode Symbology) 
  

Data 
 

(Refresh, New Datafield, New Datasource, New Source-Parameter, Edit Datasource, Edit Source-
Parameters, Edit Filter, Apply Filter)  

  

Repository 
 

(New Printer, New Project, New Datafield) 

  

Elements 
 

(Insert Graphical Elements) 
  

Bands 
 

(Insert different kinds of Bands: Report Header, Page Header, Detail Band, …) 
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4.4 Layout View, Data View and Preview 

4.4.1 Introduction 

TFORMer offers three different views for a single form. 

The default view is the layout view (). It is used to create the layout. The layout usually utilizes 
datafields (like [Printed Items] in the layout below) as placeholders for the actual data. For details 

regarding datafields, please refer to chapter 10. 

The data for the datafields is provided by a datasource. It can be edited in the data view (). 

TFORMer also offers a preview, which instantly renders the resulting output using the layout and 

the data of the adjusted datasource (). 

 
Figure 3: Layout View 

You can switch between the views by pressing the corresponding tabs or by using the File or View 

menus (see 4.2.1 and 4.2.7). 

  
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4.4.2 Layout View 

The layout view is used to create layouts: 

 
Figure 4: Layout View 

On the worksheet  you can place all kinds of graphical elements like text elements, lines, rect-
angles, barcodes and images. Such elements can be moved, resized or deleted. Furthermore, you 
can add and remove single print areas like page headers and page footers. These areas are called 
bands (see chapter 7). 

On the left and on the top of the layout there are rulers () which assist you when positioning 
elements. After starting TFORMer Designer for the first time, the measuring unit is set to ”System 

(Default)”. You can change this value in the options dialog (menu Tools ► Options…). 

It is possible to zoom the layout using the menu View ► Zoom or the hotkeys Ctrl++ and Ctrl+-. You 
can also adjust the zoom factor by holding down the Ctrl key and by simultaneously turning the 

mouse wheel. 

For more information on how to design layouts, please refer to chapters 6 to 12. 






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4.4.3 Data View 

The data view is used to administrate datasources. You can create, switch and modify datasources. 
Furthermore, the content of the active datasource is shown. This is the data which is used for 
printing the layout. 

 
Figure 5: Data View 

The data view mainly consists of a data grid showing the current data (). Use the navigation 
buttons in  to select rows or to jump to a specific row in the datasource. In  you will find func-
tions for manipulating and selecting datasources. When checkbox  is activated all datafields which 
are not used in the layout will be hidden. 

By default TFORMer assigns a manual datasource to a newly created layout. This means that you 
can enter values for datafields manually in the grid. It is also possible to create and edit other types 
of datasources (e.g., ODBC database access) in this view. For more information regarding the data 
view, please refer to section 13.2. 

4.4.4 Preview 

This tab shows an instant preview of the output using the selected datasource. 

 
Figure 6: Preview 







 
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Use the functions in  to change the zoom factor, switch between single page or double-page 
preview, show/hide label boundaries, navigate between pages or to jump to a specific page. For 
details, please refer to chapter 14. 

4.5 Design Tree Window 

4.5.1 Layout Tree 

The design tree window shows a structured view of the layout. It lists all objects in a single place 
and allows the selection of objects per mouse click. Even such elements, which are occluded in the 
design view, can be selected in the design tree easily.  

 
Figure 7: Design Tree Window 

 
Figure 8: Delete a Datasource 

The design tree window  lists all objects in a hierarchical tree structure. You can expand single 
branches of the tree by clicking the  symbol and you can collapse them by clicking the  symbol. 

To select an object, click on it with the left mouse button. Hold down the Shift key or the Ctrl key for 
multiple selection. Figure 7 shows a selected text element (), which is located in the page header 
of a layout called “PickList_10.tff”.  

If you right-click on a tree item a context menu will appear (see Figure 8, ). The context menu 
offers various functions for the selected object. 

If TFORMer encounters an error in a user defined computation, the affected item is drawn red. For 

more information, please refer to section 10.4. 

4.5.2 Repository Tree 

If a repository is used, a second tab will be shown next to the Design tab . Clicking tab  switches 
to the tree view of the repository. A repository is a central database for layouts, datafield definitions 
and tray-mappings. For details, please refer to chapter 16. 







 





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4.6 Properties 

The complete layout structure in TFORMer is based on objects (bands, text boxes, datasources, 
etc.). To adjust the properties of such objects the properties window is used. For a completive list of 
all object properties, please refer to Appendix A. 

The properties of the following objects can be modified: 

 Forms 

 Bands 

 Elements (graphical design elements) 

 Datasources and Source-Parameters 

 Datafields 

 Layers 

 Tray-Mappings 

 Projects (Repository) 

 

 
Figure 9: Properties Window 

All properties are grouped into categories (like “Common”, “Advanced” or “Position”, see ). The 

categories help you to locate properties more easily. 

Properties are accessible as “field:value” pairs. E.g., the property “Text” is currently set to “Ex-
press”. The color (“Fore Color”) is set to red. 

The area  shows information on the selected property. 

Button  is used to turn the auto-hide feature of the properties window on or off. Click the  symbol 
once to make the window slide away. To recover its previous state, hover with the mouse over the 

 button. By clicking the auto-hide button again, the window will be fixed in its previous posi-
tion. 

Button  closes the properties window. 

► TFORMer Designer supports multiple object selection. This can be used to change the pro-
perties of multiple objects simultaneously. A change will be applied to all objects within the 
selection. 








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4.7 Status Bar 

The status bar displays information about position and measurement of the selected design 
element. Furthermore the zoom factor of the layout view is shown. 

 
Figure 10: Status Bar 

 shows the coordinates of the upper left corner of the selected element (or of the element with the 
mouse focus). 

 shows the dimensions of the selected element (or of the element with the mouse focus). The 
measuring unit used for displaying positions or dimensions can be adjusted in the options dialog 
(menu Tools ► Options…). 

 shows the current zoom factor used for displaying the content of the layout view. The zoom factor 
can be adjusted via the menu (View ► Zoom) or by holding down the Ctrl key and by simulta-

neously turning the mouse wheel. 

4.8 Layout Tabs 

When working with multiple layouts, each of these layouts is represented by a tab (see ). To 
switch between layouts click on the corresponding tab in  or use the layout picker . To close the 
current layout click on the  symbol inside the tab. 

 
Figure 11: Change layouts quickly by using tabs 

  

 
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5 Printing Concept and Workflow 

5.1 Introduction 

TFORMer uses one universal output concept to produce all different kinds of outputs like: 

 Reports – a table, a list or a letter usually spanning multiple pages. 

 Labels (Normal Printer) – a layout which is printed repeatedly in multiple rows and columns 
on each page. 

 Labels (Label Printer) – a layout which is printed once on each page. One page is one label. 

 Hybrid Layouts – a mix of the first two variants. 

The output concept is based on the logical separation of the layout () into different printing areas 
(e.g., report header, page header, detail area, page footer and report footer). Such a printing area is 
called band. 

Each of these bands fulfills a specific purpose. By combining bands and by adjusting their proper-
ties, different layout schemes can be produced. The figure below illustrates the printing of a simple 
report (). 

Layout Output Input Data with Datafields

 
Figure 12: Printing Concept 

In contrast to a word processor which is mostly used for static content, a report generator like 
TFORMer generates output based on dynamic data. Good examples for dynamic contents are the 

article numbers on product labels, the addresses in serial letters and the order positions in invoices. 

The dynamic content is usually provided by an external datasource (). This is either a text file, a 

database, an arbitrary application or user specified data. 

5.2 Rendering the Layout 

Each print-out is based on the form layout. The form layout uses different design elements like text 
elements, barcode elements, shapes and pictures which are placed on bands (see Figure 13, ). 

When generating the output, each of the bands will be rendered repeatedly: Usually a detail band is 
rendered for each single record (see Figure 13, ) of the datasource. Page header and page footer 
are rendered at the top respectively bottom of each page automatically (see Figure 13, ). The 



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report header and the report footer are printed at the beginning and at the end of the report (see 

Figure 13, ). In this way the output is assembled. 

BarcodeText PictureShape

Layout Output Input Data with Datafields

Reference Datafields

in Text, Barcode or Image Elements

(e.g. [ArticleNo])

...

 
Figure 13: Rendering the Layout 

For providing the content you have various possibilities: Text, barcode and image elements can be 
filled with fixed data. Aside from that they can also reference the fields in a datasource. Such 
references will be resolved during print time and the actual data is inserted (see Figure 13, ). 
However, not only the fields in the datasource may be used to provide dynamic data. TFORMer 
also provides system fields (e.g., the current page number) and functions (e.g., the current date), 
and you can perform your own arbitrary computations. Besides that, you can easily create your own 
serial numbers and use them in the layout. 

5.3 Datasource Concept 

For generating output TFORMer requires data. The records and the datafields control the content 
and the appearance of the output. As a rule of thumb TFORMer prints one detail band per record of 

the datasource. 

Please note, that this data-centric output scheme is maintained in all cases, even when printing 
pure static documents like personal address labels. In this case the number of records (or the copy 
counter for records) controls the number of printed labels. 

A datasource can be seen as a simple table, which is read row by row (record by record) by 
TFORMer during printing. Each record (each row) provides the values for one or more datafields 

used in the layout (e.g., “ArticleName”, “ArticleNo” and “ArticlePrice”). 
























