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2 Disclaimer 

The actual version of this product (document) is available as is. TEC-IT declines all warranties 
which go beyond applicable rights. The licensee (or reader) bears all risks that might take place 
during the use of the system (the documentation). TEC-IT and its contractual partner cannot be 
penalized for direct and indirect damages or losses (this includes non-restrictive, damages through 
loss of revenues, constriction in the exercise of business, loss of business information or any kind of 
commercial loss), which is caused by use or inability to use the product (documentation), although 
the possibility of such damage was pointed out by TEC-IT.  

 

 
We reserve all rights to this document and the information contained therein. Reproduction, 
use or disclosure to third parties without express authority is strictly forbidden. 
 

 
Für dieses Dokument und den darin dargestellten Gegenstand behalten wir uns alle Rechte 
vor. Vervielfältigung, Bekanntgabe an Dritte oder Verwendung außerhalb des vereinbarten 
Zweckes sind nicht gestattet. 
 

© 1998-2018  
TEC-IT Datenverarbeitung GmbH  
Hans-Wagner-Str. 6 

A-4400 Austria  
t.: +43 (0)7252 72720  
f.: +43 (0)7252 72720 77  
https://www.tec-it.com 
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3 Introduction 

3.1 What is TBarCode SDK? 

TBarCode SDK is a set of professional tools for the generation of barcodes. More than 100 
different symbologies (linear barcodes, 2D barcodes and stacked barcode variants) can be printed 
or exported as graphics files. All industry formats are supported. The barcodes can be generated in 
the highest possible resolution and quality. 

TBarCode SDK is available in several versions for different operating systems, applications and 
programming environments. The following versions are included in this setup: 

TBarCode OCX A Microsoft® ActiveX® compliant barcode control. It can be used with 
Microsoft® Office applications as well as by software developers. 

TBarCode .NET A .NET barcode library for software developers. It includes barcode 
controls for Windows Forms and ASP.NET 2.0. 

TBarCode Library A DLL for Windows platforms for software developers.  

(A DLL for Windows CE/Windows Mobile is available on request. Please 
contact us with your platform details.) 

3.2 Scope of this Document 

This document concentrates on the use of TBarCode OCX in Microsoft Office applications. 

In contrast to the other two components (TBarCode .NET, TBarCode Library) TBarCode OCX 
may be used without any programming knowledge. This makes it easy to use and you will get 
results in quasi no time. Using the OCX control you can integrate bar codes in text documents, 
spreadsheets and the like. First, insert the barcode object in the desired document. Then adjust the 
barcode properties (barcode type, data, etc.) in the provided dialogs. 

The first part of the document explains how to use TBarCode OCX in Office Applications like Word, 
Excel, Access and InfoPath. A few simple examples also demonstrate the possibility of pro-
gramming the control in Visual Basic for Applications. 

The second part of this document describes all available barcode properties, which can be adjusted 
in the property dialogs. All of these parameters are described in detail. 

If you are a software developer and if you are interested in integrating barcode features into your 
own applications please check out the accompanying developer manuals, developer references 
and sample applications (see Appendix A). 

3.3 What is TBarCode OCX? 

TBarCode OCX is a Microsoft® ActiveX® compliant barcode control. Such an ActiveX control is 
sometimes called OLE control or OCX control. In German, it is named "Steuerelement". 

You can use TBarCode OCX in: 

 Microsoft® Office: barcodes are embedded into documents, forms or databases easily. 

 Development environments: integrate barcodes into your own application(s). 

 Report-Generators and Reporting Engines: Enhance the output with barcode functionality. 

 Web Applications: Use barcode technique as part of browser-based applications.  
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 Most programming and script languages. 

Examples1, where you can use TBarCode OCX for barcode generation: 

 Microsoft Word 
 Microsoft Excel® 
 Microsoft Access® 
 Microsoft InfoPath® 
 Microsoft SharePoint® 
 Microsoft Visio® 
 Microsoft Visual Basic® 
 Microsoft Visual C++® 

 Microsoft ASP (VBScript®) 
 Microsoft Internet Explorer® 
 Microsoft Visual FoxPro® 
 Microsoft Dynamics Nav® 
 Navision Financials® 
 PHP 4.x, PHP 5.x 
 Borland C++ Builder® 
 Borland Delphi® 

 Borland Quick Reports® 
 Sybase® PowerBuilder 
 Crystal Reports® 8 
 ActiveReports (Data Dynamics) 
 IBM® Object REXX® 
 Alpha Five Database (XBasic) 
 ASNA Visual RPG® 
 And a lot of more applications… 

3.4 Restrictions of the Demo Version 

In the demo version, the barcodes will be drawn with a demo-hint. That means that the word 
“Demo” or the phrase “www.tec-it.com” is drawn partially over the barcode. The demo-hint does not 
influence the readability of the barcode in a negative way. 

► In special cases (e.g. very small or high-resolution barcodes), you may want to test the pro-
duct without restrictions. To obtain a temporary license key contact sales@tec-it.com. 

► For enabling the full-featured version (without the demo hints), you can obtain a license key 
from TEC-IT (https://www.tec-it.com/order). 

► For more information on licensing TBarCode, please refer to chapter 11. 

3.5 Important Security Notice 

► Version 8.0 and newer versions include a fix, which was implemented in response to a 
security leak (a malicious web site in conjunction with Internet Explorer and an installed 
TBarCode ActiveX). Up to now, no real threat is known, but it is strongly recommended to 
update all TBarCode installations as soon as possible. 

                                                      
1 For applications, not supporting ActiveX technology you may use other TEC-IT Barcode Tools (e.g. Barcode Studio). 
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4 Installation 

4.1 Requirements 

The following operating systems are supported: 

 Microsoft Windows 10 

 Microsoft Windows 8 

 Microsoft Windows 7 

 Microsoft Windows Server 2012 and 2012 R2 

 Microsoft Windows Server 2008 and 2008 R2 

TBarCode OCX was tested with the following Microsoft Office versions (in particular with Microsoft 
Word, Excel, Access, Visio and InfoPath): 

 Microsoft Office 2003  

 Microsoft Office 2007 

 Microsoft Office 2010 (32-bit and 64-bit)  

 Microsoft Office 2013 (32-bit and 64-bit) 

 Microsoft Office 2016 (32-bit and 64-bit) 

4.2 Download and Setup 

Download TBarCode SDK from https://www.tec-it.com/Download ► TBarCode SDK and execute 
the setup application. Depending on your selection one or more of the following components are 
installed – along with documentations and sample applications:  

 TBarCode OCX 
A barcode ActiveX control for Microsoft Office users and for software developers. User 
manual and API reference are included in the setup. 

 TBarCode Library 
For software developers. Developer manual and API reference are included in the setup. 

 TBarCode .NET 
For .NET developers. Developer manual and API reference are included in the setup. 

 

► Administrative rights are required to install TBarCode SDK.  

► TBarCode OCX is an ActiveX control. ActiveX controls must be registered within the Micro-
soft Windows operating system before they can be used. This registration is executed auto-
matically by the setup application. On demand, you can register the OCX file manually with 
the command line tool “regsvr32.exe”. 
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5 Insert Barcode into Microsoft Office 

5.1 General 

This and the following chapters will explain how to use TBarCode in Microsoft Office applications. 
For the following three products, the usage of the TBarCode control is the same (see TBarCode 
QuickStart manual): 

 Microsoft Word 2003 (and earlier versions) 

 Microsoft Excel 2003 (and earlier versions)  

 Microsoft Access 2003 (and earlier versions)  

In Office 2007 / Office 2010 / Office 2013 inserting the TBarCode control has slightly changed. How 
to do this is explained in the sections 5.3, 5.4: 

 Insert Barcode in Microsoft Word 2007 (and newer versions) 

 Insert Barcode in Microsoft Excel 2007 (and newer versions) 

 Insert Barcode in Microsoft Access 2007 (and newer versions) 

Finally, the usage of TBarCode in Microsoft InfoPath is explained in chapter 9. 

5.2 Microsoft Office 2003 

5.2.1 Insert Barcode in Word 2003 using the Menu 

 
Figure 1: Insert Barcode using the Menu (Microsoft Word) 

Application How to insert 

Word  Select Insert ► Object… from the menu (). 






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Excel  Select TBarCode11 from the list of object types  and confirm with OK. 

 A new barcode object will be inserted (). 

Access  Open your report (or form) in the design mode (see 6.2). 

 Select Insert ► ActiveX Control… from the menu. 

 Select TBarCode11 from the list of object types and confirm with OK. 

 A new barcode object will be inserted. 

InfoPath Please refer to section 9.3.3. 

5.2.2 Insert Barcode in Word 2003 using the Control Toolbox 

 
Figure 2: Insert Barcode using the Control Toolbox (Microsoft Word) 

► Please note: In Word and Excel the toolbar is named “Control Toolbox”, in Access just “Tool-
box”. 

 

Application How to insert 

Word  If the Control Toolbox  is not visible, please open it as follows: 

­ right-click on one of the visible toolbars and select Control Toolbox or 
­ select View ► Toolbars ► Control Toolbox from the menu. 

 Click on the More Controls icon. – A list with available controls will 
appear (see). 

 Select the entry TBarCode11. 

 Now move the mouse cursor to the desired position and click the left 
mouse button. The TBarCode control  will be inserted. 

Excel 

Access 

InfoPath Please refer to section 9.3.3. 

5.3 Microsoft Office 2007 

5.3.1 Insert Barcode in Word 2007 

You can also insert a barcode as follows: 

 Click the Office button on the top left of the Word window and then select Word Options. 







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 Enable the Developer tab in the Ribbon: 

 

 Then go to the Developer tab and click Legacy Tools ► More Controls. Select TBarCode11 
from the list of ActiveX Controls and confirm with OK. The barcode will be inserted at the 
current cursor position. 

 

5.3.2 Insert Barcode in Excel 2007 

 Enable the Developer tab in the Ribbon (Excel Options) 

 

Figure 3: Excel 2007: Excel Options - Show Developer tab 

 Go to the Developer tab and select Insert  ► More Controls 
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Figure 4: Excel 2007: More Controls 

 
Figure 5: Excel 2007: Select TBarCode11 

 

 Select TBarCode11 from the list of object types and confirm with OK. 

 Now move the mouse cursor to the desired position and draw a rectangle to the position 
where the bar code should be. A TBarCode control will be inserted. 

 

► Please note: In Word 2007 and Excel 2007 the ”Control Toolbox” can be found in the 
Developer tab, in Access 2007 inside the Design Tab.  

For inserting barcodes in Microsoft Excel 2003, use the TBarCode QuickStart manual provided in 
the Windows start menu. 

5.3.3 Insert Barcode in Access 2007 

 Open a new report in Design View. 

 

 Click the ActiveX Controls symbol in the Design tab Controls section. 
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 Select TBarCode11 from the list of ActiveX Controls and confirm with OK. 

 

 A TBarCode control will be inserted. 

 

► For adjusting the barcode properties right click, the bar code control and select TBarCode11 
Object ► Properties from the context menu (see also 6.3). 

For inserting barcodes in Microsoft Access 2003, use the TBarCode QuickStart manual provided in 
the Windows start menu. 

5.4 Microsoft Office 2010 / Office 2013 / Office 2016 

5.4.1 Insert Barcode in Word 2010 / Word 2013 / Word 2016 

 Select File ► Options. 

 

 Go to the page Customize Ribbon and check the list entry Developer. 
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 Then go to the Developer tab and click Legacy Tools ► More Controls. Select TBarCode11 
from the list of ActiveX Controls and confirm with OK. The barcode will be inserted at the 
current cursor position. 

 

 

5.4.2 Insert Barcode in Excel 2010 / Excel 2013 / Excel 2016 

 Enable the Developer tab in the Ribbon (File ► Options ► Customize Ribbon) 

 

Figure 6: Excel 2010: Excel Options - Show Developer tab 
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 Go to the Developer tab and select Insert ► More Controls 

 

 
Figure 7: Excel 2010: More Controls 

 
Figure 8: Excel 2010: Select TBarCode11 

 

 Select TBarCode11 from the list of object types and confirm with OK. 

 Now move the mouse cursor to the desired position and draw a rectangle to the position 
where the bar code should be. A TBarCode control will be inserted. 

 

► Please note: In Word 2010 and Excel 2010 the ”Control Toolbox” can be found in the 
Developer tab, in Access 2010 inside the Design Tab.  

5.4.3 Insert Barcode in Access 2010 / Access 2013 / Access 2016 

 Open a new report in Design View (Create ► Report Design). 

 

 Click the ActiveX Controls symbol in the section Design ► Controls. 
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 Select TBarCode11 from the list of ActiveX Controls and confirm with OK. 

 

 A TBarCode control will be inserted. 

 

► For adjusting the barcode properties right click, the bar code control and select TBarCode11 
Object ► Properties from the context menu (see also 6.3). 

5.5 Insert Barcode per Code 

Using VBA (Visual Basic for Applications), you can insert the barcode per code. For more informa-
tion, please refer to section 8.3. 
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6 Adjust Barcode Parameters  

6.1 General 

TBarCode offers the possibility to change all barcode related settings (barcode type, barcode data, 
check digit method, barcode appearance, etc.) to your needs. There are three different methods for 
changing barcode parameters. These methods are explained in section 6.3. 

► Please keep in mind:  
In order to select, move, resize, edit and program the TBarCode control you have to be in 
Design Mode. When leaving the design mode, the control is locked and cannot be edited. 

6.2 Activate the Design Mode 

Application How to activate the Design Mode 

Word See section 6.2.1. 

Excel 

Access See section 6.2.2. 

InfoPath See section 9.3. 

6.2.1 Microsoft Word or Excel 

 

Switch to Design Mode by clicking on the 
triangle symbol  in the Developer Ribbon. 

 

If this ribbon is not visible, please refer to 
chapter 5. 

 

6.2.2 Microsoft Access 

   

You can activate the Design Mode when opening 
the form (or report): 

 Open the desired form (or report) by 
double-click and choose Design View  
from the menu. 

or 

 Right-click on the form/report name and 
select Design View () from the pop-up 
menu. 

 





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6.3 Barcode Parameters 

The barcode parameters can be adjusted either by using the Property Pages, the Property List or 
VBA Code.  
Except for some special settings (which are available in the property list or via code only) TEC-IT 
recommends the use of the property pages. The property pages are designed for easy adjustment 
of the TBarCode properties. 

6.3.1 Property Pages 

 
Figure 9: Property Pages (Microsoft Word) 

Application How to open the Property Pages 

Word  Make sure that you are in Design Mode (see section 6.2). 

 Right-click on the TBarCode object . 

 Select TBarCode11 Object ► Properties from the pop-up menu (). 

 The property pages  will appear. 

Excel 

Access 

InfoPath  Make sure that you are in Design Mode. 

 Right-click on the TBarCode object and select TBarCode11 
Properties… 

 

► For detailed information about the property pages and about the available settings, please 
refer to chapter 10. 










