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2 Disclaimer 

The actual version of this product (document) is available as is. TEC-IT declines all warranties 
which go beyond applicable rights. The licensee (or reader) bears all risks that might take place 
during the use of the system (the documentation). TEC-IT and its contractual partners cannot be 
penalized for direct and indirect damages or losses (this includes non-restrictive, damages through 
loss of revenues, constriction in the exercise of business, loss of business information or any kind of 
commercial loss), which is caused by use or inability to use the product (documentation), even if 
TEC-IT has been advised of or TEC-IT has pointed out the possibility of such damages.  

 

 
We reserve all rights to this document and the information contained therein. Reproduction, 
use or disclosure to third parties without express authority is strictly forbidden. 
 

 
Für dieses Dokument und den darin dargestellten Gegenstand behalten wir uns alle Rechte 
vor. Vervielfältigung, Bekanntgabe an Dritte oder Verwendung außerhalb des vereinbarten 
Zweckes sind nicht gestattet. 
 

© 1998-2011  
TEC-IT Datenverarbeitung GmbH  
Hans-Wagner-Str. 6 

A-4400 Austria  
t.: +43 (0)7252 72720  
f.: +43 (0)7252 72720 77  
http://www.tec-it.com 
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3 Introduction 

3.1 About 

TEC-IT Barcode Studio is a tool for generating and printing barcodes.  

Barcode Studio creates more than 100 different barcode symbologies: linear, 2D, postal and GS1 
composite barcodes are supported. All barcode parameters are adjustable. The barcodes are 
created as image files (e.g. for using it in your artwork), as high quality vector images (for graphics 
design or pre-press applications), copied to the clipboard or printed directly with any printer. Batch 
barcode generation with external or manual entered data is also supported. 

If you have any questions, please contact us. 

Address: Hans-Wagner-Str. 6  

AT-4400 Steyr  

Austria/Europe 

Phone: +43 / (0)7252 / 72 72 0 

Fax: +43 / (0)7252 / 72 72 0 – 77 

Email: office@tec-it.com 

Web: http://www.tec-it.com 

3.2 Supported Operating Systems 

 Mac OS (10.4 or higher) for Intel 

 Windows 7 

 Windows Vista 

 Windows XP 

 Windows Server 2003 

 Windows Server 2008 

 Linux/UNIX (please refer to www.tec-it.com or request a build) 

3.3 Restrictions of the Demo Version 

► A demo marker across the barcode indicates that the demo version is active. The correct-
ness of the barcode is not affected. 

► To obtain a license key for the full version (without the demo marker) please order Barcode 
Studio online at http://www.tec-it.com/order/default.aspx. 
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4 Installation 

4.1 Install Barcode Studio on Microsoft® Windows 

On Microsoft
®
 Windows operating systems (XP, Vista, etc.), Barcode Studio is installed with the 

Windows Installer. If the Windows Installer is not available on the system, please download it from 
the following link: 

http://www.microsoft.com/downloads/details.aspx?FamilyID=889482fc-5f56-4a38-b838-

de776fd4138c&displaylang=en 

Please follow the steps as outlined below (administrator privileges are required). 

1. Open the installer by double-clicking it. 

2. Follow the instructions in the installation wizard. 

By default, Barcode Studio is installed in the following directories: 

C:\Program Files\TEC-IT\BCStudio12  (binary files + documentation) 

C:\ProgramData\TEC-IT\BCStudio\12.0 (templates, option file, etc.) 

4.2 Install Barcode Studio on Mac OS X® (10.4 or higher) 

For Mac operating systems (Mac OS X 10.4 or higher), Barcode Studio is provided as a dmg-file. 

Please follow the steps as outlined below. 

1. Open the dmg-file by double-clicking it. 

2. Drag the program icon onto the application path. 
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5 Quick-Start 

5.1 Introduction 

This chapter will guide you through the most important functions of Barcode Studio by showing 
you how to create an EAN13 barcode. For more detailed explanation of the user interface and the 
available functions and settings, please refer to the chapters 6 to 10. 

► Starting with Barcode Studio version 11 pre-defined barcode templates are available. The 

creation of standardized barcodes is simplified dramatically (see section 5.3).  

5.2 How to Create an EAN13 Barcode 

 
Figure 1: Quick-Start – Barcode Studio Main Window 

In order to create an EAN13 barcode, please follow these steps: 

Select the barcode type (symbology) – see section 5.2.1. 

Enter the barcode data – see section 5.2.2. 

Select the output resolution – see section 5.2.3. 

 Specify the barcode dimensions – see section 5.2.4. 

 Fine-tune the module width – see section 5.2.5. 

 Set font style and size – see section 5.2.6. 

 Export or print the barcode. 







 







 
 
 

Page 10 of 73 

 

Barcode Studio User Manual  

5.2.1 Select Barcode Type (Symbology) 

  
 

Select the required barcode type (symbology) in . Choose 
“EAN 13”. 

Hint: If you press the E key, the first entry starting with an “E” will 
be selected. 

 

5.2.2 Enter Barcode Data 

The EAN13 barcode needs exactly 12 digits (or 13 digits including the check digit). By default you 
will see the sample data “123456789012” if the checkbox “Example Data” is checked. 

 

 
 

Enter the data to be encoded in . Alternatively you can also 
use the Data Input Assistant (see 7.7.1.1). 

  

 

The barcode view is updated after every change. The barcode 
cannot be drawn before you have entered the required twelve (or 
thirteen) digits. 

If “Example Data” is not checked, the current input data may be invalid for the selected barcode 
(e.g. wrong characters or a wrong number of characters). In this case you will see an error message 
like the following: 

Error: Wrong number of input characters (12 chars needed)! 

For a list of the most common error messages, please refer to Appendix B. 

► The 13
th
 digit in the resulting EAN13 barcode (in this case the digit “3”) is the check digit. It 

will be calculated automatically. 

► If you enter 13 instead of 12 characters you need to provide the correct check digit yourself. 
This is not recommended. A wrong check digit may make the barcode unreadable! 




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5.2.3 Select Output Resolution 

► Barcode Studio uses the selected resolution for computing the barcode images. Thus it is 
essential to adjust a resolution which leads to readable barcodes (see also section 5.2.5).   

► Usually higher resolutions lead to a better barcode quality. However, at the same time it is 
important that the selected resolution accords to the resolution of the output device (or of the 
image processing software). 

 

 

The output resolution can be adjusted in .  

 

In this example the output resolution is changed to 
“300 dpi”. If you are planning to print the barcode on a 
laser printer you would most probably select a higher 
resolution (600 or 1200 dpi). 

If you want to export the barcode as image for your 
web page you could also choose “Screen Resolution” 
or “72 dpi (BMP)”.  

 

► If you use barcode images in pre-press applications, please take care to avoid any scaling or 
resizing of the generated barcode image. This may lead to inaccuracies and distortions 
rendering the barcode unusable. Generate the barcode image in exactly the resolution and 
size as required! 

5.2.4 Specify Barcode Dimensions 

The barcode dimensions can be modified by changing width, height, and module width. 

Most label or barcode specifications require specific barcode dimensions. The following values are 
commonly used for EAN13: 

Magnification 
factor 

Module width [mm] Width [mm] Height [mm] 

0.80 0.264 (SC0) 29.83 20.73 

1.00 0.330 (SC2) 37.29 25.91 

1.50 0.495 (SC6) 55.94 38.87 

2.00 0.660 (SC9) 74.58 51.82 

Table 1: EAN13 Dimensions (not complete) 

 
 

In this example we use the magnification factor 1.00. 

 

Enter the width and the height in . The appropriate 
module width will be calculated automatically. 

 




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The barcode now looks like this: 

 

5.2.5 Fine-tune the Module Width 

Yet the quality of the barcode is not perfect yet (see the Quality Watch at the top right corner of the 
Barcode Studio application window): 

 

To optimize the barcode quality we recommend fine-tuning the module width. You have the follow-
ing possibilities to do so: 

 Select the option “Optimize” (see Figure 1, ). 

 Choose the unit “Pixel” and enter a whole-numbered value in the field “Module Width”. 

 Increase the output resolution. 

The first two options both lead to a perfect barcode quality. 

5.2.6 Set Font Style and Size 

The font properties are set via the “Select Font” dialog. You can open this dialog by clicking the  
button in the “Text Placement” section (see Figure 1 ). 

This example uses a 10 pt Courier New font: 
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5.3 Barcode Templates 

The list of barcode templates contains a selection of frequently used barcode types including their 
default settings.  

► The templates which are part of the Barcode Studio installation comply with various bar 
coding standards. By using these templates you create optimal barcodes and you save time 
for an optional certification of the barcode. 

In order to create an EAN 13 barcode with default settings please perform following steps: 

Go to the templates list. 

Select the entry “EAN 13 / SC2 (100%)…” 

Enter the barcode data – see section 5.2.2. 

 Adjust any other settings if needed. 

 Export or print the barcode. 

 

 
Figure 2: Quick-Start with Templates – Barcode Studio Main Window 

 










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6 Using Barcodes in Applications  
(Exporting Barcodes) 

This chapter provides general instructions for using the created barcodes in applications. An 
explanation of the user interface and of the available barcode settings can be found in the following 
chapters. 

6.1 General 

You can export the barcodes created in Barcode Studio in the following ways: 

 Copy the barcode to the clipboard (as image) and paste it into your application. 

 Copy the barcode to the clipboard (as metafile) and paste it into your application. 
(Available under Microsoft Windows only.) 

 Export the barcode to an image file. 

 Export a series of barcode images (batch job). 

Before exporting a barcode you have to adjust the required barcode settings. The size of the 
resulting barcode image can be controlled by changing the dimensions (width, height, and module 
width) and the output resolution (DPI) – see also section 7.7.2 . These settings apply to all kinds of 
export operations.  

6.2 Resolution and Readability 

► Do not resize exported barcode images with image manipulation software (like Photoshop
®
)! 

The quality and the readability might suffer! 

► Whenever possible, let Barcode Studio create the barcode in the required size and 

resolution to avoid resizing later on. 

6.2.1.1 Barcode Quality 

When exporting the barcode to a bitmap image (BMP, GIF, JPG, PNG, TIF), it must be converted 
from its internal resolution (high) to a graphical pixel resolution (low). During this process (raste-
rizing) the module width can vary due to rounding errors. 

When exporting a barcode to a vector based image format (EPS) or as metafile to the clipboard, the 
internal representation of the barcode symbol allows very high resolutions (which are independent 
of the adjusted dpi). Thus it is recommended to use vector based image formats (EPS) whenever 
possible. However, in the context of certain applications (e.g. web applications) it is inevitable to use 
bitmap images. 

The readability of a barcode can be estimated by considering the quality watch (see section 7.1, ). 
The quality of a barcode depends on the selected output resolution, size and content. To ensure an 
optimal readability check the option “Optimize”. 

6.2.1.2 Module Width 

Larger module widths usually lead to a better readability of a barcode. In practice, for most linear 
barcodes, the module width should never be less than 0.19 mm.  
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6.3 Export to File 

If you want to export a barcode as an image file, select Export ► Export Barcode… from the menu 
or press the keyboard shortcut Ctrl+E. In the Save Image File dialog choose a file name and select 
the image file type (e.g. “Bitmap (*.bmp)”). Then confirm by pressing the Save button. 

The saved image can now be imported in your target application. (Example: In Microsoft
® 

Word you 
can insert the barcode image by selecting Insert ► Image ► From File… from the menu.) 

► The exported barcode symbol will match the preview in Barcode Studio exactly. 

► For a list of available image formats, please refer to Appendix C. 

► If you export images with a bitmap based file format (see Appendix C), resizing of the 
imported image is not recommended! 

6.4 Copy to Clipboard (As Image) 

To copy the current barcode as an image to the clipboard, you have to select Copy to Clipboard (As 
Image) from the menu (located in the Export submenu) or from the toolbar. You can also press the 
keyboard shortcut Ctrl+B. 

Then switch to your target application and paste the barcode (e.g. in Microsoft
®
 Word) by pressing 

Ctrl+V (or by selecting Edit ► Insert from the menu). 

► Resizing barcode images may result in a loss of quality, in the worst case in unreadable 
barcodes.  

6.5 Copy to Clipboard (As Metafile) 

To copy the current barcode as vector based metafile (EMF) to the clipboard select Copy to 
Clipboard (As Metafile) from the menu (located in the Export submenu) or from the toolbar. You can 
also press the keyboard shortcut Ctrl+M. 

Then switch to your target application and paste the barcode (e.g. in Microsoft
®
 Word) by pressing 

Ctrl+V (or by selecting Edit ► Insert from the menu). 

► Metafiles can only be used under Microsoft
®
 Windows. 

► Due to the vector based format you may resize the imported image within your target 
application without heavy losses in readability. 

► The resulting barcodes may differ in dependence of the selected resolution and target 
application from the preview in Barcode Studio in size.  

6.6 Export Data List 

Data lists are used for exporting a series of barcode images and/or for label printing. Such a data 
list can be imported, generated and edited. See also chapter 8 Data List and 9 Label Printing. 
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7 Barcode Studio User Interface 

7.1 Main Window 

 
Figure 3: User Interface 

The main window is split into the following areas: 

 Menu (see section 7.2) 

 Toolbar (see section 7.3) 

 Barcode View (see section 7.6) 

 Quality Watch (see section 7.4) 

 Barcode Settings (see chapter 7) 

 2D Settings (available only for certain Barcode Symbologies) 

 Barcode Types and Templates (see section 7.5) 

7.2 Menu 

The menu gives you access to the following functions: 

7.2.1 File 

New Creates a new document (with initial barcode settings). 

Shortcut: Ctrl+N 

Open… Opens an existing barcode settings file (*.bc). 














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Shortcut: Ctrl+O 

Save Settings 

Save Settings As… 

Saves the current barcode settings (symbology, dimensions, module width, etc.) into a file. 
Barcode settings files have the extension .bc. 

Shortcut: Ctrl+S (for Save) 

Export Barcode… Exports the barcode to a picture file. 

Shortcut: Ctrl+E 

Save As Template… Saves the current barcode settings as template file. 

Refresh Templates Refreshes the template list. 

Shortcut: Ctrl+R 

Print Barcode Info… Prints the barcode and the most important settings (size, resolution, etc.). 

Print Labels… Prints the data list as labels (see also chapter 9).  

Shortcut: Ctrl+P 

 Hints for Printing: 

 The output resolution, and therefore the values for quality and deviation, depends on the 
printer settings.  

 Note: Inkjet printers sometimes produce better results if the bar width reduction is used 
(see also section 7.8.2.3). 

Exit Exits Barcode Studio. 

Shortcut: Ctrl+Q 

7.2.2 Data List 

File Import… Imports data from a text file and adds it to the data list. 

Shortcut: Ctrl+I 

Create Sequence… Creates a data sequence and adds it to the data list. 

7.2.3 Export 

Export Barcode… Exports the barcode to a picture file. 

Shortcut: Ctrl+E 

Copy to Clipboard (As 
Image) 

Copies the barcode as image to the clipboard. 

Shortcut: Ctrl+B 

Copy to Clipboard (As 
Metafile) 

Copies the barcode as metafile to the clipboard (not available on Mac OS). 

Shortcut: Ctrl+M 

Export Data List… Exports the data list as a series of barcode images. 

Shortcut: Ctrl+L 

7.2.4 Tools 

Options… Specifies the Application Options (see Chapter 10). 

7.2.5 Help 

Help Opens the documentation. 

Shortcut: F1 

Barcode Reference Opens the barcode reference document in the web browser. 

TEC-IT Website Opens the page www.tec-it.com in the web browser. 

Advanced Label Printing Opens a suggestion for advanced label printing software in the web browser. 

YouTube Videos Opens a page with videos about Barcode Studio in the web browser. 

Barcode Studio on 
Facebook 

Opens the Barcode Studio web site on Facebook. 

Buy Barcode Studio Opens the TEC-IT order form in the web browser. 

License... Opens the dialog for entering your license data. 

Check For Update… Checks for updates of Barcode Studio. 

About Barcode Studio Displays information about the application, version number and copyright. 
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7.3 Toolbar 

 
Figure 4: Toolbar 

The toolbars offer following functions: 

 
New Creates a new barcode (with pre-defined settings). Shortcut: Ctrl+N 

 
Open Opens an existing barcode settings file (*.bc). Shortcut: Ctrl+O 

 
Save Saves the current barcode settings to your hard disk. Shortcut: Ctrl+S 

 
Print Prints the data list as labels. Shortcut: Ctrl+P 

 
Export Barcode Exports the barcode to a picture file. Shortcut: Ctrl+E 

 
Copy to Clipboard (As Image) Copies the barcode as image to the clipboard. Shortcut: Ctrl+B 

 
Copy to Clipboard (As Metafile) Copies the barcode as metafile to the clipboard. Shortcut: Ctrl+M 

 
Export Data List Exports the data list as a series of barcode images. Shortcut: Ctrl+L 

 
Help Opens the documentation. Shortcut: F1 

7.4 Quality Watch – Status Section 

 
Figure 5: Quality Watch 

7.4.1 Deviation 

The less the deviation the better are quality and readability of the barcode. The deviation depends 
on the output resolution and the print ratio of the barcode. You can also improve the quality by 
changing the module width to an appropriate value. As measurement unit select “Pixel” and set the 
module width to an integer value (1, 2, 3, etc., 25, etc.). 


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The field “Deviation” will report one of the following values: 

Tolerance Aberration Description 

Perfect 0% Optimal output quality.  

Fair 1-15% Should be readable with most barcode scanners. 

Poor 16-25% May be readable. 

Bad! 26-50% Not readable in most cases. 

Data Loss! 51-100% Total or partly loss of information. Unreadable barcode. 

Table 2: Barcode Qualities 

7.4.2 Quality 

The quality of the barcode – the higher the deviation, the lower is the quality. 

7.4.3 Character Count 

Displays the number of characters in the barcode data. 

7.4.4 Resolution 

The current output resolution in dpi (dots per inch). 

7.4.5 Hint Box 

The hint box  displays information about the current barcode quality as well as recommended 
actions for improving the readability. 

7.5 Barcode Types and Templates 

7.5.1 Barcode Type 

Select the required barcode type (= symbology) from the Barcodes list (see Figure 3, ). For a 
better overview the list is divided into 1D Symbologies, 2D Symbologies, Postal Codes, GS1 
DataBar, HIBC Codes and SCANPAY Barcodes. 

► For 2D codes like Aztec Code, Codablock-F, PDF417, MicroPDF, Micro QR-Code, 
MaxiCode, Data Matrix, QR-Code, GS1-DataBar Stacked and variants, as well as for all 
symbologies which are derived from these (HIBC, QR-Code 2005, etc.), and for all 
Composite Symbologies you need a 2D license. For the other symbologies a 1D license is 
sufficient. 

If you want to learn more about the selected symbology, please examine the Barcode Reference 
from the Help menu. 

If a filter is active the number of shown barcode types is displayed in the tab header. 

7.5.2 Template 

Select the required template from the Templates list. If you choose a template all previously 
adjusted settings are overwritten with the template settings. 

You can add your current configuration to the templates by saving it with Save As Template… from 
the File menu. To refresh the template list choose the menu item Refresh Templates. 

If a filter is active the number of shown templates is displayed in the tab header. 
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7.5.3 Filter  

In order to find the desired barcode type or template more easily, the user can add a filter text in the 
field below the Barcodes / Templates list. Filters restrict the elements shown by the lists. 

The user may switch between two filter options by Text or by Encodable Data, what can be done by 

clicking the link with the opposite text. 

7.5.3.1 Filter by Text 

The affected lists only show those list entries that contain the filter text or are related to it. This 
option applies to both, Barcodes and Templates list.  

7.5.3.2 Filter by Encodable Data 

The Barcode list is restricted to the barcode types that are able to encode the filter data. 

   
Figure 6: Filter by Text  Filter by Encodable Data 

7.6 The Barcode View 

 
Figure 7: Barcode View 

The Barcode View shows the barcode in its actual appearance (as it will be printed). 

To change the size of the barcode, enter the required dimensions in the “Appearance” section (see 
section 7.7.2). The quality of the barcode depends on the output resolution and on the module 
width. You will find a quality watch in the “Status” section (see section 7.4). 
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7.7 Page General 

7.7.1 Data 

 
Figure 8: Data Section 

7.7.1.1 Barcode Data 

The barcode content is entered in the field “Barcode Data”  or by using the “Data Input Assistant” 
. The assistant allows the input of unstructured raw data as well as the comfortable input of 
special data formats (e.g., the contact data for a business card). However such data formats are not 
supported by all barcode types. The assistant may also be used for importing barcode data from a 
text file. 

Please note: 

► Each barcode type is able to represent a specified set of data-characters. Some barcode 
symbologies can hold digits. Others may contain alphanumeric characters (digits + letters + 
punctuation characters). Again, others may use the full ASCII character set. 

7.7.1.2 Data Input Assistant 

 
Figure 9: Data Input Assistant 

The Data Input Assistant allows you to comfortably enter the barcode data in different formats. 
Depending on your selection in  a different input mask will be show in . E.g., if you have 
selected a business card format in , then  will show the corresponding input fields for first name, 
last name, company, etc. If you have selected the GS1 format then  will show a table for editing 
the single AIs (Application Identifiers) in the barcode (see example below). Barcode Studio will do 





 






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the correct formatting for the particular barcode data automatically. The formatted data can be 
inspected in . 

► The number of available data formats in  depends on your current barcode selection. For 
Code 128 the editing will be restricted to raw data. For other symbologies (like QR-Code) a 
variety of data formats is available. 

► Besides that Barcode Studio offers the possibility to specify your own data formats. If 

required, please contact us! 

Furthermore the assistant allows you to import barcode data from a text file (button Load File…). 
For clearing all data fields, please use the Reset button. 

The data input for the “Raw Data” format (pre-selection) is quite similar to the input in the main 
window. However the assistant offers you the additional possibility to enter the data in a multi-line 

edit control (use the button ). 

Below you will find examples for editing different data formats: 

Example Calendar Entry:  
(As symbology the QR-Code is used) 

 
Figure 10: Data Input Assistant – vCalender 
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Example GS1 Application Identifier:  
(As symbology GS1 128 is used) 

 
Figure 11: Data Input Assistant – GS1 Application Identifier 

7.7.1.3 Add Control Characters 

You can enter control characters directly in the edit field or use the context menu. Open the context 
menu by right-clicking in the edit field and choose Add Control Characters. Then select the control 
character to insert from the submenu. 

Because control characters are represented by special character combinations (like \F for FNC1), 
Barcode Studio activates escape sequences automatically (see section 7.8.1.3).  

 
Figure 12: Add Control Character 

For more information on all available control characters, please refer to the “Barcode Reference” 
available on www.tec-it.com or via the menu Help ► Barcode Reference. 
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7.7.1.4 Check Digit Override 

Some barcodes with a predefined number of utilizable data characters (like all EAN, UPC, Postnet 
and RSS-14 codes) contain a check digit on a fixed position in the barcode data. 

Example: 

 

 

The EAN13 code consists of 12 utilizable digits and 1 check digit on 
the last position (). 

If you enter 12 digits as barcode data the check digit will be calculated 
and inserted automatically. However, you can also enter all 13 digits 
and override the calculated check digit. 

 

► Note: If the barcode data already contains a check digit, the barcode is only valid if the 
check digit is equal to the automatically calculated check digit. 

► Only if the check digit method is set to None (see section 7.8.1.2), the correctness of a 
check digit remains unchecked. Under normal circumstances you should not use this setting 
– we recommend relying on the automatic calculation of the check digit(s) by Barcode 
Studio. 

7.7.1.5 Composite Data 

The Composite Data field () is only enabled if the selected barcode type supports composite data 
(check if the Composite page is visible) and if a 2D Composite Component has been selected 
(“Auto”, “CC-A”, “CC-B” or “CC-C”) on that page. 

► You can also enter the composite data in the Barcode Data field by separating the compo-
site data from the linear barcode data by the vertical bar character "|". 

7.7.1.6 Hex Data 

If this option is selected (see Figure 8, ) the barcode data is treated as hexadecimal data. This 
property applies to the barcode data field and to the composite data. 

Whenever Hex Data is enabled, Barcode Studio treats manually entered data as well as imported 
data as a hexadecimal character sequence. This sequence is internally converted to a normal 
character sequence before a barcode is generated. 

7.7.1.7 Example Data 

If the option “Example Data” is selected (see Figure 8, ), Barcode Studio provides a valid exam-
ple data string for the currently selected barcode type. The data is adapted automatically if you 
change the symbology. 

 
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7.7.2 Appearance 

 
Figure 13: Appearance Section 

7.7.2.1 Unit 

Field  specifies the measurement unit for displaying and/or entering the dimensions of the bar-
code. Possible values are:  

 Millimeter 

 Inch 

 Mils (=1/1000 inch)  

 Pixel. 

7.7.2.2 Dimensions (Width, Height) 

Use the settings  and  to change the width and the height of the barcode. The preview is up-
dated immediately. 

Unit Description 

Millimeter The width and the height of the barcode in millimeters. 

The physical width (in pixels) can be calculated as follows:  
width (pixels) = width (mm) / 25.4 * resolution (dpi) 

Inch The width and the height of the barcode in inches. 

The physical width (in pixels) can be calculated as follows:  
width (pixels) = width (inch) * resolution (dpi) 

Mils The width and the height of the barcode in mils. 

The physical width (in pixels) can be calculated as follows:  
width (pixels) = width (mils) / 1000 * resolution (dpi) 

Pixel The width and the height of the barcode in pixels. 

The width and the height are specified in pixels. The resulting dimension on the screen 
depends on the adjusted resolution (dpi). 

Table 3: Units 

7.7.2.3 Module Width 

The module width is entered in field . 

Every barcode is divided into several "modules". A module is the smallest bar (or space) 
segment. The module width is the fundamental measuring unit for barcodes. All bar and space 
widths base on this setting. A change of the module width causes a change of the barcode width 
and vice versa. 

Exceeding the lower limit of the module width leads to unreadable barcodes (e.g., if the module 
width is smaller than 1 pixel). The minimum limit depends on the resolution of screen, printer, or 
image. 














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7.7.2.4 Resolution (DPI) 

Enter the required resolution in : 

Resolution (DPI) Description 

Screen Resolution The image will be exported in exact the same size as displayed in Barcode Studio.  
Depending on your operating system and on the display settings within the operating system 
this resolution may differ. Typical values are 72, 96 or 120 dpi. 

Printer Resolution Use the DPI setting of the currently selected printer. 

72 dpi (BMP) Create the image with 72 dpi. 

96 dpi 

 : 

2540 dpi 

Create the image with the given dpi.  
Higher dpi values result in larger (and more detailed) image files. 

Custom Resolution… Create the image with the custom resolution added in the field aside. 

Table 4: Resolution Settings 

► To increase the accuracy of the barcode symbol you can increase its resolution.  

► Consider that the resolution set in Barcode Studio must fit to the resolution of the printer or 
the target application. 

► Image Export: Most applications show (and print) images (and therefore barcodes exported 
as image) in screen resolution. If the resolution of the barcode image is higher than the 
screen resolution, the output size will be displayed bigger than in Barcode Studio.   
Example: If your screen resolution is 96 dpi and the exported image has a resolution of 300 
dpi it will be displayed about 3 times as large as in Barcode Studio. 

► However, only few professional layout applications consider the resolution correctly.  

► The dpi value can only be stored in certain image formats!  
E.g., when exporting an image as GIF file, the adjusted resolution (dpi) will not be stored. 
Only the formats BMP, JPG, PNG, and TIF are capable of storing the resolution.  
For detailed information, please refer to Appendix C. 

7.7.2.5 Optimize 

If the “Optimize” option  is checked, the module width of the barcode will be set to a whole-
numbered pixel size (to the nearest lower value). Hereby the pixel deviation is reduced to a 
minimum or eliminated completely.  
In other words: The barcode is printed using whole-numbered pixel sizes only. This avoids aliasing 
effects and guarantees an optimal scanning quality. 

► If the “Optimize” option is checked, the module width will be adjusted for optimum output 
quality. 

► This setting can be very helpful especially for lower resolutions. 

► The barcode view shows the barcode symbol in optimal quality only, if the resolution was set 
to “Screen Resolution”. The preview is not detailed enough to display higher resolutions 
correctly. More detailed output can only be achieved on the according output devices 
(printer, image, etc.). 

7.7.2.6 Reset Button 

Use the  button to reset the barcode to its initial size. 

7.7.3 Text Placement 

This section describes the settings regarding the human readable text. 
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Figure 14: Text Placement Section 

7.7.3.1 Show Text 

If enabled, the “human readable text" is displayed. (Default: enabled) 

Many barcode types, as for instance the 2D symbologies, do not have a human readable text. For 
these types the option can’t be enabled. 

7.7.3.2 Print Text Above 

If enabled, the “human readable text” is printed above instead of below the barcode symbol. 
(Default: disabled). 

This setting cannot be enabled in conjunction with barcode types like EAN 8, EAN 13, UPC A, or 
UPC E. 

7.7.3.3 Alignment 

This property adjusts the alignment of the human readable text (Default, Left, Right, and Center). 

7.7.3.4 Text Distance 

This property adjusts the distance between the “human readable text” and the barcode (in mm). 

7.7.3.5 Font 

Click the  button to select the font for the human readable text. The selected font is displayed in 
text box . 

7.8 Page Settings 

7.8.1 Advanced Barcode Settings 

  
Figure 15: Advanced Barcode Settings Section 






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7.8.1.1 Format/Subset 

The format string is used for formatting the utilizable data of the barcode according to defined rules. 
It operates with substitute symbols to indicate how the data shall be structured.  
With the format string it is possible to insert constant characters to the barcode data. Control 
characters make it possible to change the Subsets for Code 128, EAN 128 and UCC 128 or to 
define the desired start/stop character of CODABAR. 

For more information on format strings, please refer to the “Barcode Reference” available from 
www.tec-it.com or via the menu Help ► Barcode Reference. 

7.8.1.2 Check Digit 

This property specifies the check digit calculation method. In order to guarantee that the barcode 
data is going to be read properly a check digit can be added at the end of the utilizable data. A 
comparison of the barcode content with the check digit informs the scanning device (scanner) about 
incorrect scans and forces the device to repeat or reject the scan. The check digit calculation 
method is standardized for certain common barcodes types. Using check digits is mostly optional – 
but often recommended for particular symbologies and standards. 

When set to default the check digit is calculated according to the specification of the selected 
barcode. Modifications are admissible for barcodes with selectable check digit methods or for 
special applications only. 

For additional information on check digit calculation, please refer to the “Barcode Reference” 
available from www.tec-it.com or via the menu Help ► Barcode Reference.  

7.8.1.3 Encoding / Code Pages 

With the fields Encoding Mode () and Code Page () the user can affect the interpretation of the 
input data. 

For a general overview about encoding and code pages, please refer to the “Barcode Reference” 
available from www.tec-it.com or via the menu Help ► Barcode Reference. 

► Data is always passed as UNICODE stream to Barcode Studio. Since UNICODE charac-
ters always consist of more than one byte and most of the barcode types are only able to 
encode one byte per character, it is not always clear how the input data should be inter-
preted. So we give you the possibility to decide yourself. 

► Per default the input data is converted to the selected Code Page (see below). If other kinds 
of interpretations are needed, you have to change this property. 

You have following possibilities: 

Value Description 

Selected Code Page Converts the input data to the code page, which is selected in the property Code Page. 
(default) 

Lo-Bytes only Considers only the lower bytes of the input characters, the higher bytes are ignored.  

Lo- before Hi-Byte The data is passed as it is. No conversion is done. All bytes are considered. A lower 
byte is passed before the higher byte. 

Hi- before Lo-Byte Consider both bytes but change the order of lower and higher byte. That means a 
higher byte is encoded before the lower byte. 

Table 5: Compression 

The code page is related to the property Encoding Mode. It is only considered if the encoding mode 
is set to Selected Code Page. You can choose between several pre-defined code pages (e.g. ANSI, 
ISO 8559-1 Latin I, UTF-8, Shift-JIS…) or add the ID of a custom code page by selecting Custom 
Encoding… and by entering the ID in the edit field aside.  



 
 
 

Page 29 of 73 

 

Barcode Studio User Manual  

7.8.1.4 Escape Sequences 

The use of escape sequences is appropriate if you need to encode control characters like carriage 
return or FNC1 into the barcode. 

This option specifies, whether escape sequences (like “\n”) shall be translated or not (default: no). 
Each escape sequence starts with a backslash (“\”) and is followed by one or more characters. For 
a list of recognized escape sequences, please refer to the additional document “Barcode Refe-
rence” available via the menu Help ► Barcode Reference or from www.tec-it.com. 

► If escape sequences are activated, the backslash character can’t be used directly in the bar-
code data. It must be replaced by a double back-slash “\\” in order to be encoded correctly. 

 

7.8.2 Drawing 

  
Figure 16: Drawing Section 

7.8.2.1 Quiet Zone 

Click the Adjust Quiet Zones… button to open the Quiet Zones dialog.  

This property adjusts the sizes of the quiet zones around the barcode. The sizes can be given in 
several units like number of modules, Millimeters, Inches, Mils, and Pixels. 

 
Figure 17: Quiet Zones 

You can configure the quiet zone for all four sides of the barcode independently from each other. By 
clicking Reset Values all values are reset to zero. 

7.8.2.2 Colors / Transparency 

Click the Change Colors… button to open the Colors/Transparency dialog.  







 
 
 

Page 30 of 73 

 

Barcode Studio User Manual  

 
Figure 18: Colors Dialog 

Click the  button beside the color that you want to change. Then select the desired color in the 
appearing dialog. 

For Color The foreground color of the barcode (color of the bars). 

Back Color The background color of the barcode (color of the spaces). 

Text Color The color of the “human readable text”. 

Back Style Mode for drawing the background of the barcode. The background can be set either to transpa-
rent (background shines through) or opaque (= default; background is overwritten with the 
background color). This setting is also relevant if you use copy and paste (clipboard). 

7.8.2.3 Bar Width Reduction 

When printing on inkjet printers, the ink that is absorbed by the paper tends to diffuse. Setting the 
bar width reduction allows you to work against this spreading of ink. This property is also useful for 
laser printers with high toner saturation. 

The bar width reduction can be specified in several measure units like percent of the module width, 
mm, Inch, and Mils. For instance, if the unit is set to percent and the value is set to 20 all bars will 
be narrowed by 20 percent of the module width. 

► Be careful: When using this feature we recommend you to do several test scans to make 
sure that the barcode can be scanned correctly. A common value to start with is 15%. 
Setting the bar width reduction to more than 50 percent might leave the barcode unreadable! 

7.8.2.4 Bearer Bars 

Select the kind of bearer bars you want to use. Bearer bars help a decoder to detect the full width of 
a barcode and reduce the possibility of partial scans (decoding only a part of the symbol). You can 
change the width of the Bearer Bars in . 

7.8.2.5 Notch Height 

This property adjusts the height at which the synchronization bars (e.g. the double lines in EAN on 
the left, center and on the right side) extend the regular barcode height. 

7.8.2.6 Print Ratio 

The print ratio describes the relationship between the different bar- and space-widths of a barcode 
(do not mix this up with the width/height ratio of a symbol!). It is specified by a list of colon-
separated-values. The list starts with n bar widths, followed by m space widths. The numbers n and 
m depend on the barcode type. 

The single values specify a multiple of the module width: 

 1   “Equal to the module width”,  




